Posts created by ella

 
 
All 4 Dracula games freeze on me but I just call up the task manager. I do NOT "End Task". I bring the game back and Resume. An annoyance but an easy, quick fix without losing the level.
 
 
I'm not disappointed with the difficulty, it's just that it has such a different look. It is hardly recognizable as being related to I,II &III. The other 3 resembled each other with small differences and welcomed familiar items and ways of doing things. Plus the artwork isn't nearly as good as the first 3. I really, really hope there is a Dracula V with a return to the look of the first 3.
 
 
I so love Dracula I, II and III.....I was hoping #IV would be similar, with a few twists. I wish I hadn't purchased it. I'm only at Level 15...will keep trying.
 
 
 posted in Rainbow Mosaics: The Forest's Guardian on Jan 19, 18 9:15 PM
How does one get the 1,000's of coins in these games? Been able to get everything else just not the the big number. I love this series.
 
 
 posted in Rainbow Mosaics: Treasure Trip on Dec 11, 17 7:43 PM
Does only a perfect game allow you to get the 15,000 coin tab? Obviously, I have not had a perfect game or I might know.
 
 
 posted in Glass Masquerade on Jul 25, 17 8:01 PM
I, too, can't believe I wasted a credit on this very short game! Even the simplest of this type of game goes on for many more levels than this....Not happy!
 
 
 posted in Christmas Wonderland 7 on Jul 18, 17 6:38 PM
I am only trying the trial version. It opens so huge, that I cannot see any menu. To remove, must go to task manager. Have tried several times.
I have WINDOWS 10...fully updated.
 
 
Same problem... Today I tried uninstalling and re-installing but that did not help, either. I have contacted HELP. Surely, they are getting a lot of complaints. I have all 3 Dracula games and love them.
 
 
I have all 3 Dracula games and love them. Not a minute of problems until I did the 'update'. Some update! Please give me the option of returning to the original. It HAS to be the update as I have finished this game many, many times before. DO SOMETHING!
 
 
I have the beetles in inventory, trying to place them in the proper coloured holes in the nest but they won't go in.
 
 
 posted in Venice Deluxe on Mar 30, 13 3:10 PM
Figured it out! Easy peasy...
 
 
 posted in Venice Deluxe on Mar 30, 13 12:58 PM
How does one 'use' the Cupid?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator