Posts created by queticogal

 posted in MatchVentures on Sep 29, 17 11:10 AM
LilRedFoxx wrote:Even though I clicked to skip the battle room, each time I try to play game it goes to the battle room and my cursor won't work. I have shutdown & restarted computer--everything I know to do when I go back to PLAY, I end up at the same battle room and cannot even close the game without going to Task Manager, etc.

same problem on Level 11. Have uninstalled and re-installed but problem still exists.

 posted in MatchVentures on Sep 29, 17 11:08 AM
iheathco wrote:I'm in level 11 and tried the boss battle but didn't win. When I return to that screen later, I get stuck. Tiles won't move and there is no "back" or menu option. Is anyone else experiencing this? Any tips (other than uninstall and reinstall) to get out of it? I'm using a Mac running Sierra.

I'm having the same problem. Using a PC with Windows 10.
Have uninstalled and re-installed, but problem still persists.
 posted in Silver Tale on Apr 23, 16 3:56 PM
Silver Tale level 41 froze on me. I've started the level then had to leave but the game "saved" my progress, as different other times, but this time I now need to re-find the torch and buy a gold key. Had already done that.
I have Windows 10 and no problems with video card.
Help please.
 posted in Midnight Castle on Jul 10, 14 1:29 PM
am in level 27 and screen freezes at both city square (dolls and train) and at ancient park (above the door).
am forced to control/alt/delete to shut program down.
have uninstalled and re-installed several time, but no better.
have a brand new PC with top of the line graphics, lots of ram, lots of storage and Windows 7
help please!
 posted in Christmas Wonderland on Jun 10, 12 7:19 AM
thanks Tazdaffy:
Did that............uninstalled, reinstalled in December and now again in June..........still same problem...........tried to contact "help" but when get to the point in my message to "continue" (i.e. submit) even that freezes.............will try to contact BFG on Monday though their 3 hours behind me.
 posted in Christmas Wonderland on Jun 9, 12 5:29 PM
Did you ever get an answer from BFG on this?
I found the same trouble. Uninstalled the game and then reinstalled it. Now it freezes after the screen wherein you insert all the wheel cogs.
I'm going to contact 'help' right now, but do let me know.
 posted in Royal Envoy on Apr 9, 12 5:40 AM
Like Maria508, I too had left this for over a year............your solution is so simple, it makes me wonder why I found this level so difficult! It worked!! THANK YOU, THANK YOU, THANK YOU.............from Canada
 posted in Travel League: The Missing Jewels on Sep 20, 09 12:00 PM
This game is not up to Big Fish standards. Music is corny; graphics are abysmal -- doesn't line up with screen (right side of screen missing at least 1/3).
Glad I got to see it so I'll be sure NOT to purchase.
 posted in The Omega Stone: Riddle of the Sphinx II on May 30, 09 7:57 PM
complained to Big Fish Games about this game. Explained that I uninstalled and wanted by game club credit back.........and THEY DID !! Wonderful response from BFG, great way to keep customers satisfied.
 posted in The Omega Stone: Riddle of the Sphinx II on May 28, 09 1:07 PM
bought the game............BIG mistake !! Have uninstalled the game because couldn't figure out how to get out of the first room! NEVER again will buy a game before trying it...........
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator