Posts created by Tsunami60

 
 
 posted in Adelantado Trilogy: Book Two on Apr 27, 13 1:57 AM
I'm another one who, after the fantastic support for the BFG techies, couldn't not get this game to play at anything other then a snails pace.

We came to the conclusion that it must be the graphics card, as my PC meets the requirements.
So disappointed, as I really liked the first game.
 
 
 posted in Adelantado Trilogy: Book Two on Feb 16, 13 1:01 PM
lisakell wrote:
ricoblade wrote:Replying to myself again...

Got Expert on Level 3 by getting through the tasks asap and ignoring lots of Bushes and Pots once I'd got enough Gold.

Still 1 missing secret though



It might be the bottle in the water? I missed it the first time cause I wasn't looking for a bottle. I don't remember exactly where it is, but I think it's in one of the other areas. It might have been the second one. A green little bottle in the water.


Thank you, I didn't notice the little green bottle first time round!
All done now, I hope it's not too long before the game is released.
 
 
 posted in Adelantado Trilogy: Book Two on Feb 12, 13 5:04 AM
I couldn't find the last secret either.

Love the demo, so much improvement on the last game
 
 
 posted in Royal Envoy 2 on Oct 2, 12 2:59 AM
eeastrbuny wrote:I have uninstalled, redownloaded, this game a dozen times. Both from BF and **** and I can't get through the ninth level because of the dark fog that surrounds the lanterns. I can find the lanterns and when I repair the ones that are arrowed the fog doesn't dissipate at all, in fact it continues to come across until everything is covered up. Hope someone understands my complaint. I don't know any other way to describe it. Can someone please help me? I loved the first one and was so excited when this one came out. I'm really bummed.

Thanks


I don't know if you had any joy finding a solution? But I had the same problem with the fog, upgraded my graphics card and all was ok.
 
 
 posted in Royal Envoy 2 Collector's Edition on Feb 12, 12 4:14 AM
I had the same problem, turns out my graphics card was only 32MB & the game needs 128mb.
Since upgrading my graphics card, I can clear the smoke, but now get no text on the screen, so I have no idea what I'm supposed to be doing or how many I have of wood, food & money.
Give customer support their due, they've been brilliant trying to help me solve the problem, but it's very frustrating :-(

tweetyarnf wrote:On the volcano and fog levels the smoke and fog don't clear off after restoring the obelisks, etc. Tried re-installing and it didn't help. Very annoying. I can finish the level with the help of the provided walkthrough but I can't get expert. What to do?
 
 
 posted in Royal Envoy 2 on Feb 12, 12 3:56 AM
Is anyone else having the no text problem?

I've done everything support have asked me to do & still no joy.
 
 
 posted in Royal Envoy 2 on Jan 22, 12 12:06 PM
After upgrading my graphics card after problems on the collectors edition of this, I thought this game would run smoothly?

However, I'm getting no text on the screen when a level starts? I have no idea what I'm supposed to do. Shame, as I loved the first game.
 
 
 posted in Roads of Rome III on Oct 11, 11 4:39 PM
I'm also having the lagging problem, it's so frustrating
 
 
 posted in My Kingdom for the Princess III on Sep 10, 11 7:19 AM
Thank you!!
I'd been tearing my hair out over this one too. Managed to finish, but not before nightfall.....yet!
 
 
 posted in The Enchanting Islands on May 28, 09 1:31 AM
I've updated my drivers and everything's still choppy, the text looks like russian writing!!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator