Posts created by janbut

 
 
The handkerchief will not clean the ceiling, so that I can read the message. Therefore I cannot trigger the HOP in the Library. Am I permanently stuck?
 
 
I failed to do something with the snow globe, so I did not get the 2nd slate. What can I do to remedy the situation? Starting over at the beginning is not an option. I cannot advance without the slate.
 
 
 posted in Dracula's Legacy on Sep 3, 15 11:03 AM
I'm viewing the first twin, I have a syringe and a blow torch and no hint button. have been back and tried using each of them on everything I can find. Nothing happens.
I need help desperately!
 
 
 posted in Hope Lake on May 30, 14 12:09 PM
A large number of people are having problems with the HO scene in the school, we cannot get the block from the chest. I have tried changing the resolution to all available ones on my Windows 8.1 and all kinds of other things and still the chest will not open. Is this a Tech issue or a player issue? I need to know should I ditch the game or continue trying.
 
 
 posted in Hope Lake on May 30, 14 11:52 AM
If I remember correctly it opens the doll's mouth
 
 
 posted in Hope Lake on May 28, 14 2:20 PM
I have changed the resolution to every setting available (windows 8.1) with no luck. Did anyone figure out how to get the board out of the chest? Some of the problem is that the inventory covers part of the chest and I have not been able to keep this from happening. I'm ready for a spoiler!
 
 
 posted in Elven Mists 2 on Aug 9, 12 9:39 AM
I don't know what to do. How do I get rid of the blocks???
 
 
 posted in Wonderland Adventures: Mysteries of Fire Island on Jun 24, 09 12:41 PM
I am in the "Lost Lake" and cannot pick up the green key, because I cannot carry any more objects. How do I get rid of something, and what should sit be? I have a map, spyglass, gloves and several keys.
 
 
 posted in Wonderland Adventures: Mysteries of Fire Island on Jun 8, 09 8:01 AM
I have charged my green glove shot the glow plants into the water then chased the crab across the bridge..he goes straight to the water because the plants are gone. I cannot shoot the plants while I;m on the bridge, the crab is in the way, what am I doing wrong? How do I get the crab in the water close to the red gate? Help, please.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator