Posts created by ritchieprod

 
 
 posted in Spellcaster Adventure on Apr 18, 17 2:15 PM
Everything was fine in the demo but as soon as I bought the game, it froze when I defeated my opponent.
 
 
 posted in Mystery Tales: The Twilight World Collector's Edition on Jan 24, 15 5:12 AM
Froze for me in the first 2 minutes and locked up my computer. That's an immediate delete so I don't know if it would be a good game or not. This Dev needs to do some serious quality checks before posting.
 
 
 posted in Mystery Riddles on Apr 3, 14 4:24 PM
Too frustrating to get through the tutorial that won't let you click anything and move on. This feels very buggy if you can't get past the tutorial. Thumbs down Big Fish!
 
 
 posted in Cubis Creatures on Nov 19, 13 5:24 PM
I like the game but finally had to quit in frustration. The cursor jumps to the top right and continually restarts the game. There should be a "Restart?" cue to keep that from happening. The frustration isn't worth the cute factor.
 
 
 posted in Tales of Lagoona 2: Peril at Poseidon Park on Oct 13, 13 7:06 AM
I love the clever quest titles and recognize many Firefly references that make my Browncoat heart sing. The others in the series had many as well and I think it adds a very cool extra dimension - Kudos!
 
 
 posted in Tales of Lagoona 2: Peril at Poseidon Park on Oct 13, 13 6:24 AM
I'm having the freeze issue as well, but only when I play the electrical circuit game. If I try to place the final piece on the circuit to complete it, I get an error code and the game shuts down. Every time. Hope there's an update coming soon.
 
 
 posted in Nearwood Collector's Edition on Aug 11, 13 5:52 AM
Enjoyed enough to purchase and when I went back in, the game I was on (box with picture slides) won't play, won't skip and the hint says "nothing to do here" even though all tiles are in place and I was playing when the trial ended. Is there a fix? If I have to start over again, I would prefer a refund. Having problems only AFTER buying is frustrating.
 
 
 posted in 9: The Dark Side Of Notre Dame on Jun 7, 13 4:36 PM
Same problem. Just can't go into the cemetery even though I opened the gates. I tried the uninstall & re install and it did not work. Just like everyone else. Hey, Big Fish, we need a solution here besides starting all over from scratch.
 
 
 posted in Shadows: Price for Our Sins on Feb 16, 13 5:30 AM
I wanted to like this one, but there were too many irritating things about it. The story is good, but everything is very slow. The movies move slowly, the game responds slowly and makes the mini games tedious instead of fun. I liked the very nonchalant ghosts you encounter. No fright, just spirits in distress. The HO scenes had a puzzling interaction mode. Difficult to see a difference where something needs to be moved to see the object behind. It felt random and frustrating. This is a no buy for me. I didn't even finish the demo.
 
 
 posted in Dark Canvas: A Brush With Death on Feb 15, 13 4:19 PM
Seemed like a pretty good game until an item disappeared from my inventory. Got the paint brush, chopped the bristles and it disappeared. Can't move on in the game and that didn't bode well enough to start over with a new profile. Also, a pet peeve is the profile with only 8 characters. Cheesy!
 
 
 posted in The Chronicles of Emerland Solitaire on Sep 15, 12 5:24 AM
Beautiful game and I like the mini games sprinkled throughout to break things up. The cards are a lovely style, my only problem is that the J on the Jack looks so much like a 7. Overall, a very nice game.
 
 
 posted in Surface: The Noise She Couldn't Make on Sep 2, 12 5:07 AM
You can either move to the center of the spider, where you need a gear, or the TOP of the spider where there is a nasty, pinching jaw. Hope this helps!
 
 
 posted in Meum-Trail on Sep 1, 12 3:47 AM
This is a very basic game with simple drawings. Your goal is to shift road pieces to lead the Meums to the exit. It played in a small window on my computer and the graphics were difficult to read. After 10 minutes, I had to give up on this one.
 
 
 posted in The Theatre of Shadows: As You Wish on Aug 9, 12 5:27 PM
The problem here is that in full screen mode you can't see the ladybug. It's off the screen in the bottom left corner. I keep trying to change out of full screen mode in the Options, but it won't hold. How do we move on as this is an obvious bug? No pun intended.
 
 
 posted in Live Novels: Jane Austen’s Pride and Prejudice on Jul 25, 12 2:12 PM
I wanted to like it...I could forgive some of the clunky game mechanics and FROGs are usually a lot of fun. I love Pride and Prejudice and could live with a little extra dialogue since it's Jane Austen, but the developers really look liberties with the text. If you aren't going to use the iconic lines, leave out the dialogue and move the game along. Mr. Darcy refers to Jane as "the only cute girl in the room". Come on people!
 
 
 posted in Hidden Mysteries: Royal Family Secrets on Jul 8, 12 5:59 PM
Here's a curious glitch. When I launched the game, it did not prompt me to set up a profile, but just started the game. When I quit, it did not save ANYTHING. It wanted me to start a new game. Nice game, but not enough to start over again. Any fixes for that?
 
 
 posted in Spirits of Mystery: Song of the Phoenix on May 19, 12 4:58 AM
I rescued the mage and quit for the night. Now I can't get past the "thank you" dialogue. The full screen info stays frozen and I can't close it or move on. I tried a reinstall, but no luck. Any ideas? I'm not starting over. It's a good game, but not that good.
 
 
 posted in Nightfall Mysteries: Black Heart on Mar 3, 12 6:04 AM
I'm stuck Fishies. I put the head on the mannequin and took the seam ripper but the game hint keeps sending me back for something else. I can't find anything in the walkthrough and I've tried using all me objects on the darn mannequin but nothing works. The walkthrough shows a HOS scene right after the rubble crushes the musician dummies, but no idea how to get there. Related? Help!
 
 
 posted in Best in Show Solitaire on Feb 28, 12 2:14 PM
I like the game, but have found several times that the nut I need to feed the squirrel so it runs away is actually hidden behind the squirrel so there is no way to win those hands. This is a game mechanics flaw the developers should work on before introducing any more games.
 
 
 posted in Fruit Mania on Feb 25, 12 5:21 AM
This one is too slow and clunky for me. I love Match 3 games, but waiting for the tiles to stop plopping down was tedious. Just as the game would get going, a cascade of instruction windows popped up, further slowing the play. I didn't even make it through the demo. I prefer smoother movement and less waiting for the game to catch up to me. Definite no buy.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator