Posts created by jcsgame

 posted in Darkness and Flame: The Dark Side Collector's Edition on Mar 31, 18 11:36 AM

steve_san --------------- check your PM message box for possible help with this non-download problem.
Excellent mix of HOs and Mini-Games.

Thoroughly enjoyed playing this game.

The Bonus Game is a true bonus, from the standpoint is brings closure to the Black Magic King.
I was enjoying this game at the start, but puzzle-after-puzzle finally got to me.

I usually do not skip puzzles, but in this game, there are just too many. I will play this game to the end, but I will also skip all remaining puzzles, starting in Chapter 4.

The morphing objects and collectible items (they also morph) are good to search for.
The mix of the HOs is nice, search for items, by name, picture, and search/place.
Some of you seem to have a problem giving the Healing Potion to the Witch.

You must use the "Diagnostic Lens" on the Witch before you are able to give her the Healing Potion.

For some reason this game will allow you to make the Healing Potion before you even have the Recipe. When you do that, you must still use the Diagnostic Lens or you cannot give the Healing Potion to her.

I hope this helps those of you that are having the problem.
Rabbit's House Chip Game

"Chip Game"
Started to play the mini-game.
Got booted out of the game with some kind of "time error".
Went back into the game, the "chip" is gone and there is no way to recover it.
The only way to play this game now, is to start over.

Looks like others have had problems with the "chip" game also.
Maybe the best way is to "skip" that mini-game.

WIn 10, desktop PC

I am not a happy camper about this. Sent Big Fish Customer Support an email about this "error" situation.

Restarted the game (from the begining) and SKIPPED the Rabbit House Chip Game.
I was able to play to the end of the game without any problems.
 posted in Phantasmat: Curse of the Mist Collector's Edition on Dec 24, 17 11:33 AM
Thanks Daxadillon for all of your work.

Merry Christmas to you and your family.

I sent you a PM, go and read it. I'm going on the assumption that you are getting an Error 1404 when you try and download. There is also an Error 5 that I also have a resolution for, but have not written it in the PM.

It should get you past the download problem.

PM me and I'll work with you the best that I can.
Hi sonofstar;

I had silimar problems; listed below are the steps necessary to change the Big Fish Game Manager to have Administrative Authority.

You do not want to change the "game" to have Administrative Authority, you want to change the Big Fish Game Manager. Doing this eliminated quite a few problems for me.

From your desktop, right-click on the Big Fish Game Mgr Icon
Click on Properties
Click the Compatibility tab at the top of the Properties window
Under Application, CHECK the Run this program as Administrator
Click OK
You're done, go ahead and open the Big Fish Game Mgr and run your game.

I hope this helps you.
murphy1018 is right, exit the game enitrely and restart the game.
You will be able to access the Amulet and save Dupene.

Thanks murphy for the info.
 posted in Jewel Match: Snowscapes on Dec 9, 17 6:04 PM
Thanks SynthpopAddict, the one key I did not try was the Delete......using the Delete key worked.
 posted in Jewel Match: Snowscapes on Dec 9, 17 2:46 PM
I woold like to purchase this game, but NOT unless I can enter "my name" in the Player area.

Please let me know what you had to do to enter your name in the Player area.

 posted in Solitaire Jack Frost: Winter Adventures 2 on Dec 4, 17 5:18 PM
This is the standard "Higher/Lower" solitaire game.
If the base card is a "5" you play a "6" or a "4".

The purpose of the game is to clear all of the "gold cards". Clearing of all of the Gold Cards gives you a "perfect game". You do not have to clear all cards in order to get a perfect just have to clear the gold cards.

Hope this helps those of you that are confused.

I have not gotten past the first level yet, so I don't know if the "standard higher/lower" changes.

Did you give the Shield (that you created) to the Chieftain?

You need to do that before you can place the Cheetah and get Fact card.
Hi jibsail1:

Read the PM message that I sent will get you around your problem.
Hi ppasolver:

I think your problem is that you did not give the Shield to the Shaman.

Once you give the Shield to the Shaman, you should be able to place the "Golden Cheetah" (looks like a monkey) on the right chair and the Elephant on the left chair.

Once that is done, the Shaman will respond to you.

Any other problems/questions, feel free to contact me via a PM.

Hi pat14222

You must be a WIN 10 user. I to had the same "non-save on exit" issue until I changed the Big Fish Game Manager to have "Administrator" authority.
Listed below are the steps you have to do in order to change the Game Manager Authority.

According to the Big Fish Instructions
From your desktop right-click on the Big Fish Game Mgr Icon
Click on Properties
Click the Compatibility tab at the top of the Properties window
Under Application, check the Run this program as Administrator
Click OK
You're done, go ahead and open the Big Fish Game Mgr and run your game.

You only have to do these steps one time, unless you reload the Big Fish Game Mgr program again for some reason.

Hope this helps you

 posted in Living Legends: Uninvited Guests Collector's Edition on Nov 12, 17 9:54 AM
Thoroughly enjoyed playing this nice relaxing game.

You have to deal with flying candle holders, blocking sprinkling cans, angry shields and a few other things. Made the game very interesting.

There are 2 owls and 1 morphing object to find in every scene. Not easily spotted, but not so difficult that you are pulling your hair out trying to find them.

Graphics are very clear and colorful. HOs are varied and sometimes interactive.

Thanks to the Developer (4Friends) for a great game.

 posted in Halloween Stories: Invitation Collector's Edition on Oct 14, 17 9:11 AM

I am having the same Error code 5 problem as you both are. I have found a way around is a little strange, but it works.
I am running on WIN 10.

Purchase the game, before you start the following steps.
Once you get the Error code 5, do the following.
Delete the game's Icon from your desktop, if you haven't already done so.
Click on the Windows Icon and Restart your computer (do NOT close the Big Fish Game Manager screen)
Once your computer is back up, bring up the Big Fish Game Mgr. screen.
Click on the game queue
Click on the little blue arrow that is next to the Trash Can for the game that you want to download and install
the game will start to download and you can continue with the install

Hope this helps you
 posted in Ghost Files: The Face of Guilt Collector's Edition on Jul 28, 17 7:23 PM
I thoroughly enjoyed playing this game. It was interesting and more up-to-date.

I like murder mysteries that do not have bodies all over the place.

Wish there were more games like this.

The HOs had nice variations; not a constant list, after, list setup.

Some people did not like doing the DNA (blood matching). That only happens once in the entire game. Same applies to the fingerprints and the bullet casings matching. One time for each in the game.
 posted in Ghost Files: The Face of Guilt Collector's Edition on Jul 28, 17 11:50 AM
Hi grandjam57:

Welcome to the Pond

--------SPOILER ALERT-----------

unplug the sign
For the drill, you need to open the top left drawer and take the "drill chuck" and rag.
You also need to use the oil and rag on the metal box that is towards the right side of the table; in there you will get the screwdriver.
Be sure you have opened the top right drawer and used the tape on the drill cord.
Click on the drill, place the drill chuck and the screwdriver.
Plug in the drill and you will be able to use it.

Hope this helps.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator