Posts created by shawnsgrammy

 
 
 posted in Amanda Rose: The Game of Time on Jul 17, 11 7:38 PM
Did anyone out there have trouble with the feathers in the dream catcher in the Indian Village? The game won't let me pick them up.
Good game otherwise.
 
 
 posted in Super Granny 5 on May 5, 11 11:52 AM
lv2dance92 wrote:I am stuck on level 14 in Super Granny 5 "Tellporter Troubles" anyone can help..

I know there was a sequence in the older Granny games!


All the moves granny will make are to the right....
 
 
 posted in Super Granny 5 on May 5, 11 11:50 AM
I am on SG 5 and in level 24 in the sandbox, I have tried everything to make the crates fall. I have dug and bombed (which I assume is supposed to be the way to do it) and a small enough piece of grass remains to keep the box from falling. If/when I move closer, it keeps moving the box and soon there is no more room for me to get on the other side of it to push it off the platform.
Help
 
 
 posted in Super Granny 6 on May 3, 11 2:02 PM
I am finding Super Granny 6 so hard that it is not fun. I like a challenge but not when it becomes overwhelming and stressful. I like to figure things out not be running for my life every minute like in the last level of the first board. Too many 'bad guys' and not enough ways to protect granny. Discouraged. I wish there was a level cheat.
 
 
 posted in Dream Chronicles: The Book of Air on Jul 13, 10 8:23 PM
What happens if you make a mistake? In the 'birthplace f all music', I stamped all the blue plates without setting the correct symbols in place. Isn't there any kind of reset or something? I tried going back to the previous location on the map and coming back and that did nothing. Am I stuck? They don't really expect people to start all over again if they make an error, do they?
 
 
 posted in Pahelika: Secret Legends on May 31, 09 5:46 PM
I have barely started a free trial of the game -and it is just the kind of game I love- but I'm only in the 2nd challenge, I think, and I cannot proceed. I went down the ladder and made the potion, cast the spell and put the lantern in its place to 'dispell illusions' but then when I went up the ladder to get the magic dust, it isn't there to bring back down and sprinkle on the runes. (and, yes, I did the hidden puzzle on the wall, too).
Seems like this game needs more testing to get some of the glitches out. I'll put off buying it for a while til it gets squared away. So frustrating to be going through a game and then get stuck from a glitch. I had hoped that exiting and restarting it would repair it but it did not. Perhaps deleting and reinstalling, I don't know but I see your complaints and issues, so I am not hopeful.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator