Posts created by eabrad

 
 
 posted in Awakening: The Redleaf Forest Collector's Edition on Jun 16, 14 12:35 AM
I'm sorry but that didn't help me. I still do nit know what to do. I even used the strategy
guide and that did not help. I usually love puzzles but these are very strange
 
 
 posted in Awakening: The Redleaf Forest Collector's Edition on Jun 15, 14 11:27 PM
Keep trying.the lamp shade goes over the light, I think I put it towards the base of the lamp
 
 
 posted in Emberwing: Lost Legacy on Apr 19, 14 3:23 AM
Go outside, across the moat and use the shovel to dig up the bears paw, then use the signet ring and the gates will open
 
 
 posted in Nevertales: The Beauty Within on Feb 16, 14 11:12 PM
I have tried that but it still won't work, I really don't want to skip but I may have to!
Just tried again and it worked.
 
 
 posted in Spirits of Mystery: Song of the Phoenix on Jun 1, 13 3:53 AM
Please, help, I have been through the walkthrough a number of times but I cannot find the mouse for the final chapter. I've played this game before so I must have found it at some time but I can't now
 
 
 posted in Mystery Legends: Beauty and the Beast on Jun 16, 12 12:25 AM
Thank you! I only smashed it once
 
 
 posted in DragonStone on May 8, 12 2:59 PM
I also love Dragonstone and have replayed it many times.
So I repeat your question are there any similar games??
 
 
 posted in Otherworld: Spring of Shadows Collector's Edition on Apr 24, 12 2:18 AM
Thank you so much, tapping did the trick. so many clever people around, wish I was one.
 
 
 posted in Sherlock Holmes and the Hound of the Baskervilles on Mar 25, 12 8:14 PM
Thak you..helped me also
 
 
 posted in Syberia on Jan 28, 12 11:33 PM
I wish some one had answered this. I am having the same problem. None of the walkthroughs i have seen even mention that the panel is jammed.
 
 
 posted in Syberia on May 21, 11 2:18 AM
Vernete, did you get an answer as i am having the same problem, I have collected the voice cylinder and test tube, have been to the lecture and got to the wall, then had to go back and still I am told i do not need that when I try to pick up the powder. I DO need it to put in the Captains wine!
 
 
 posted in Brain Challenge on Feb 5, 11 10:38 PM
Call me slow but after reading these 2 entries I realised that the game is supposed to have sound!!! My sound is on however I do not have sound. I notice there was no reply to your questions does that mean there is no remedy or just that no one else is bothered??????
 
 
Found it, thank you! I missed that hidden object scene.
 
 
Please where did you find the oil. The strategy guide says to click on the leaning mirror but the game won't let me . Can anyone help???
 
 
Strange, I was thinking how much I enjoyed the game, yes there is a lot of tooing and froing but I was managing without any help until now, I need a knob to turn up the lantern and how to find a way to the next floor. But I think this is a definite buy!
 
 
 posted in Love Chronicles: The Spell Collector's Edition on Apr 25, 10 12:24 AM
I have searched but cannot find the flint either. Where is it????
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator