Posts created by Janice100

 
 
 posted in Nightmare Realm Collector's Edition on Jul 9, 11 1:55 PM
I'm having the same problem--I've tried to catch the fish a number of times, and when it's in a number of places re: the hook and worm--Any suggestions?
 
 
As I understand it, by uninstalling and reinstalling, I will have to start the game over on my Mac? Really?!
 
 
 posted in The Secrets of Da Vinci on Nov 9, 09 3:37 PM
Hi--I could really use help. I've turned the bridge and taken the boat towards the dovecote as the walkthrough states. I've tried everything I can think of to get back to the other side of the river again where the bridge is. I've tried the ladder across where it will let me, but nothing gets me to the bridge side. I know this is probably obvious, but not to me!
 
 
 posted in The Secrets of Da Vinci on Oct 31, 09 4:20 PM
I backtracked and found it.
 
 
 posted in The Secrets of Da Vinci on Oct 31, 09 3:47 PM
Where do I get the gold to use at the mill after taking the medallion from Alkahest's neck? I couldn't pick up the gold coins in Santurnin's room and I can't remember getting gold anywhere else? Thanks!
 
 
 posted in Kuros on Sep 11, 09 5:08 PM
Was going crazy with the same problem. I went to another walkthrough and it shows it on the fire glyph when you look through the telescope. Hope this helps.
 
 
 posted in Jewel Match on Aug 24, 09 9:44 AM
Thank you all so much! I'm going to try it with your advice later today.
 
 
 posted in Jewel Match on Aug 23, 09 10:55 AM
I'm blushing as I write this, and do feel brainless--but I can't get the hang of this game. I've read the "Help" instructions, but when I try to switch the neighboring jewels they just switch places, but then go back to their original positions. I've tried a variety of clicking solutions, but obviously not the right one. The board itself has a function that is putting outlines around two jewels not matching in color, and I have no idea what that is about. Then, when I try to create my own line around jewels, nothing happens. Is this intuitive play for the rest of you and I'm missing some genetic make-up that would make this clearer?! Please help! And, explain in small words and great detail!
 
 
 posted in Syberia II on Jun 26, 09 11:28 AM
I can't figure out what I'm doing wrong, but I can't find/get a poster to rip away to show the hole in the fence. Is it the poster with the man pasting it up? I've tried that one as well as all the others. I've checked a walk-through to make sure I've completed all the previous steps--ie/ have the gas can, talked to Malka, the brothers, been to Cabaret, etc. Would appreciate any and all help!
 
 
 posted in The Omega Stone: Riddle of the Sphinx II on Jun 3, 09 1:11 PM
Thanks so much for your help. I know I sound like an idiot, but I can't find a "Saved Games Area?" The saved game icon has disappeared from across the bottom inventory, and I only had the one game saved. I've pushed a lot of buttons trying to find the Area, but must be missing something?
 
 
 posted in The Omega Stone: Riddle of the Sphinx II on Jun 3, 09 7:36 AM
I have been playing Omega Stone for days--and was stuck in the underground maze at Chichen Itza forever--I carefully saved the game last night as always and this morning it's no longer there. All I get is the new game opening. Has this happened to anyone else? Is there any way to recover my game? HELP!!!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator