Posts created by Novella2

 
 
 posted in Bad Dream: Coma on Nov 22, 17 8:31 AM
I went back there, the "baby" is gone and you can't get into the house. All of a sudden am back at apartment and can't get into mine or the one across the hall. Completely stuck. BTW: I'm not good, but not bad either.

Thanks for any help.
 
 
 posted in Phantasmat: Insidious Dreams Collector's Edition on Sep 20, 17 11:17 AM
I'm playing this game and the w/t regarding the maze is wrong. Keep getting caught by villan. Tried using my own way through and when I go left, the map shows me going right.

Any help would be appreciated. Thanks.
 
 
 posted in Agatha Christie: The ABC Murders on Aug 15, 17 10:44 AM
jwj0806: Regarding the cash register code. If you use the examine feature, you will find 3 numbers. I just played the demo and if I remember correctly, you enter the numbers and the drawer opens. I believe he mentions he hears a click.

Hope this helps.
 
 
 posted in Dark Dimensions: Vengeful Beauty Collector's Edition on May 7, 17 2:05 PM
I've looked at the in game w/t and tried to follow the steps. However, I get the key and can't get away from the "nurse," and keep getting put at the beginning.

Any help? Thanks.
 
 
 posted in Enchanted Kingdom: A Dark Seed Collector's Edition on Apr 9, 17 11:07 AM
Has anybody else noticed the hint button is good for nothing? I usually use it to know where to go next. All this button does is say something like "I shouldn't need help, just proceed?"

Thanks.
 
 
 posted in Secret of the Royal Throne on Feb 15, 17 9:53 AM
Can't find last peacock feather. Have 2. Thanks for any help. Found it (as if anyone cares).
 
 
 posted in Vermillion Watch: Fleshbound Collector's Edition on Jan 1, 17 9:03 PM
This is close to the beginning of the game. The w/t says push 2, 4 and 6. This doesn't work. I then went to a video w/t and saw someone just experimenting. I did this also and found it to be 1, 3 and 4. If the solution is random, it should be stated as such.

Signed, just trying to be helpful.
 
 
 posted in Surface: Virtual Detective Collector's Edition on Dec 1, 16 5:02 PM
Am supposed to find all 4 decorations for the box near the little girl. Hint keeps putting me back to the astral sign globe - I have NONE of them. The map tells me nothing. Do not know what to do to proceed. Can't find 2 of the decorations.

I know, most of the time, questions do not get answered. It would be nice if somebody would help, otherwise, what good is a forum?

Thank you.
 
 
 posted in Harrowed Halls: Lakeview Lane Collector's Edition on Nov 22, 16 11:57 AM
If I can't get an answer here, please let me know where I can. Thank you.
 
 
 posted in Harrowed Halls: Lakeview Lane Collector's Edition on Nov 16, 16 11:14 AM
Customer service told me to come here for an answer to my question. I'm having the problem with only 1 fuse and 4 tubes. Can't go anywhere, hint won't help, and map doesn't tell me anything. My question was: do you happen to know if there will be an update for this glitch in the not too distant future?

Thank you.

P.S. Playing on Windows7.
 
 
 posted in Harrowed Halls: Lakeview Lane Collector's Edition on Nov 13, 16 10:01 AM
Same thing with me. Hint keeps saying I've done everything here and to check my inventory. The map won't tell you anything. I'm just plain stuck.

What is with these games lately? You're almost finished and then a glitch happens and you can't do anything.
 
 
 posted in Grim Facade: The Red Cat Collector's Edition on Oct 25, 16 1:32 PM
Same problem. Won't somebody help?
 
 
 posted in Dark Realm: Lord of the Winds Collector's Edition on Sep 10, 16 4:16 PM
Cheryl: Thank you. For now, I've given up on this game. I found it tedious and repetitious and now, when I'm almost done, they come up with this dumb idea.

I do mean thank you, but, for now, I've had it with this game.

Hope you're liking it.
 
 
 posted in Dark Realm: Lord of the Winds Collector's Edition on Sep 10, 16 10:31 AM
I'm almost finished with this game and, somehow, just noticed the leaf. Thought I'd click on it to see what it does, and... nothing! You can't even get rid of it! There are no notes or help whatsoever with this. Therefore, it appears I can't even finish this game.

Help, please!
 
 
 posted in Occultus: Mediterranean Cabal on Aug 2, 16 3:18 PM
Am at the part with the tweezers in the ship bottle. Tweezers are in the bottle, but nothing moves them - up, down, sideways, etc.

Help, please.
 
 
 posted in 7 Roses: A Darkness Rises on Jun 24, 16 1:43 PM
I finally found a w/t for this game, but it doesn't help me. It says to throw crystals down the well. And, to first use the spade. The game won't let me do either. Help, please!
 
 
 posted in 7 Roses: A Darkness Rises on Jun 24, 16 1:40 PM
Re: getting the necklace. You have to move all the objects so that none of them are directly on the necklace. Sort of like fitting objects correctly into a box or shelf. She will say something like: "I've got it."
 
 
 posted in Green Moon 2 on May 13, 16 10:15 AM
Maybe I'm dumb, but can't find where to click to get where you don't need oxygen, except to go back home.

Thanks.
 
 
 posted in Green Moon 2 on May 10, 16 4:04 PM
Thanks, Audrey.
 
 
 posted in Green Moon 2 on May 10, 16 1:36 PM
Is there a w/t anywhere for this?

Thanks.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator