Posts created by 2MuchCoffeeGirl

 
 
 posted in Dragon Keeper on Sep 5, 12 12:59 PM
Oh well....I guess I failed the game and have to start over. Making jewelry to empty the chest requires gold, or something like that, and I ran out of that feeding the dragons. No wonder I don't like TMs....I can't even do the one's that people say are "perfect for children" and "easy". It would have been nice to have had a better tutorial that told you you need to make the jewelry.
 
 
 posted in Atlantis on Aug 19, 12 2:48 PM
What's this about a clock? Is there a clock in this game somewhere?
 
 
 posted in Atlantis on Aug 19, 12 1:58 PM
Hmmm...I haven't had that issue, but I did notice that the menu button placement interferes with shooting the balls sometimes. It would be useful to get an update to the game that would allow hiding of the menu button.
 
 
 posted in Atlantis on Aug 19, 12 1:51 PM
Yep, I agree with the last poster. Check to see what programs are running in the background, as these can adversely affect game performance. If you don't know how to do this get a tech savy friend to help. It could be a legitimate program causing the problem or something that isn't supposed to be on your machine.

Also, you should never have to repurchase the game. Re-installing is the option you should be using, although, if you haven't changed your machine hardware, that shouldn't be necessary either unless the game stops working altogether. ONe thing you will want to check is that your video card drivers are up to date.
 
 
 posted in Atlantis on Aug 19, 12 1:45 PM
There isn't a windowed mode for this game. I believe the sequel does have windowed mode though.
 
 
 posted in Atlantis on Aug 19, 12 1:42 PM
It's a bug...if you buy the color bomb, but exit the game before starting the next level it loses the bonus, or something like that.
 
 
 posted in Atlantis on Aug 19, 12 12:58 PM
Does anyone know what the "Soul of Atlantis" bonus does? I am trying to figure out whether I should buy it instead of the "Color Bomb" bonus.
 
 
 posted in Atlantis on Aug 19, 12 12:56 PM
Try "The Rise of Atlantis" forum. this forum is for the marble popper game Atlantis.
 
 
 posted in Atlantis on Aug 19, 12 12:53 PM
Umm...I think you might have the wrong forum...this is for the marble popper game Atlantis. I haven't seen any Carthage in the game.
 
 
 posted in AGON: The Lost Sword of Toledo on Jul 10, 12 5:39 PM
Just not my kind of game, I don't think. IMHO, they need to break the monologues into smaller bits...otherwise, I'd rather read a book. I read books when I want a long story.
 
 
 posted in AGON: The Lost Sword of Toledo on Jul 10, 12 4:17 PM
I finally figured out how to do things from the "technical difficulties" thread, but I don't think I will be buying this one. The game does not pause its "conversations" when I switch to Windows, and it doesn't seem to have any mechanism to pause the game when a character is speaking, which is quite often, it appears. I am guessing that if I miss hearing something I will have to listen to all of a rather lengthy monologue over again. I wonder how much of the game time is actual game playing.
 
 
 posted in AGON: The Lost Sword of Toledo on Jul 10, 12 3:56 PM
Hmmm....on the trial/sample version, I can't do anything. If I click anywhere where an arrow goes, it shows me the map, and then, if I click the one place there that is clickable, it takes me back to the previous scene where I'm staring at an archway with nowhere to go. I can't figure out how to navigate. There are no instructions and no tutorial.
 
 
 posted in Azada ™ on Jul 1, 12 4:07 PM
That didn't help. I had already tried the fish in the mirror trick but only two matches would stay where I put them and only one of those made that distincitve sound and glowed like it says : "You are correct." It says I have to move at least 3 matches, but at most two will move, so...

I did the previous puzzles and didn't have this problem, so if it happens again I will conclude my game is glitched, although I really do hate having to start such difficult games over again.
 
 
 posted in Azada ™ on Jun 28, 12 4:21 AM
On the one I'm doing it says to move matches so a fish is facing right instead of left, but I can only get two matches to stay where I drop them and only one makes the sound like it succeeded in snapping in place. Is my game glitched or what? I have been to this point or past this point in the chapter about 4 times so far. I have no idea what I'm doing wrong, given I've succeeded on doing this type of puzzle in the game at least twice before. So, basically, I just wasted 15 minutes trying to get more than 2 matches to move.
 
 
 posted in Green Moon on Apr 19, 12 11:48 AM
Hmmm.....I tried this game for an hour...collected stuff but didn't get anywhere. When does the "book" in the upper right-hand corner show up? It's the only game I've played for an hour and got absolutely nowhere. What am I doing wrong? BTW, this is the second time I have tried an hour trial of this game with no idea what to do next. I also ran out of room in inventory and haven't figured out how to open the basement door.

And, I made the copper shot, but I have no idea what that is for either. I'm not even sure that I can get to a point in this game to make the walkthrough of use. Who was the fool psychologist back in 8th grade who told me I was a genius?...tests lie, I guess...they all lie.

I'm thinking there is something wrong with the clock in my game...no key.

Finally got that key and that gives me the book....now maybe I can get somewhere insteady of collecting about 25 items with inventory for only 14. Too bad the trial period is ended. The first part of the game is not very aesthetically appealing.
 
 
 posted in Lost Chronicles: Salem on Dec 4, 11 8:11 PM
I got the black screen of no escape on the model town puzzle and I installed the game fairly recently. I will try a different game to take a break, uninstall and re-install this one and try again. Please get someone to fix this one bug and 90% of the complaints in this discussion would go away.
 
 
 posted in Zuma's Revenge - Adventure on Aug 22, 11 6:44 PM
Same here....disappointed. The whole game took roughly 3 hours.
 
 
 posted in Atlantis Sky Patrol™ on Jul 25, 11 2:33 AM
JessF wrote:I'm amazed at how different we all are.

I played Atlantis Sky Patrol for about 10 minutes and decided it would be way to hard for me - but I loved Sparkle! And believe I finished it.

I do not own it - I played it on one of those other sites that let you download and play forever if you paid a monthly fee. Most of the games I was happy to let go, but Sparkle and the Cosmic/Water bug games I still think about buying sometimes.



JessF, did you finish all three difficulties on Sparkle?
 
 
 posted in Atlantis Sky Patrol™ on Jul 25, 11 2:29 AM
I think it's the game, as Atlantis Sky Patrol is the only game I have this problem with. On mine, the graphics are totally broken up and jerky, and the game is unplayable. I have played it through all the way on Windows Vista Home Premium 64-bit. I am currently running Windows 7 Home Premium 64-bit, 8 GB RAM, EVGA nVidia GTX460 SC graphics card. I have tried various compatibility modes with no success. BTW, Atlantis, the other similar marble popper game, works fine on my computer.

What video cards is everyone using? I think it might be a problem that only affects nVidia based cards. I have the latest Win7 compatible drivers, but, alas, the game is still unplayable.
 
 
 posted in Sparkle on Jun 9, 10 10:44 AM
I copied the bfgstate.xml file for this game over to my new drive in the hopes of keeping my game progress. I bought the game in 2008. I don't see any difficulty levels in quest mode on my new install of the game, so, can someone tell me if the game has been revised since original release.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator