Posts created by kaitlinn

 
 
 posted in The Mirror Mysteries on Dec 19, 11 1:32 PM
I experienced some technical issues when I tried to play the game a second time using a new player profile; all of the puzzle games (the fuses, the safe, etc.) were already solved. I have never had this issue with any other game. It kind of made it no fun to replay.
 
 
 posted in Nemo's Secret: Vulcania on Dec 10, 11 7:46 PM
Well, I got it, but I guess it was simply color alone. I was expecting something more difficult.
 
 
 posted in Nemo's Secret: Vulcania on Dec 10, 11 7:40 PM
I can't seem to figure out the tile puzzle in the fireplace. it says to arrange the tiles so that identical ties do not appear in same [line]...which "ties" are identical?
 
 
 posted in Azada® : In Libro Collector's Edition on Nov 22, 11 7:09 AM
I loved the first two Azada games, and I purchased this one thinking it would be similar. It is very different, but I still liked it, as I personally prefer puzzles to hidden objects. However, I was very disappointed in the length of the real game, as well as the bonus game. Two hours for the real game and twenty minutes for the bonus? Come on..
 
 
 posted in Scratches Director's Cut on Oct 27, 11 5:45 PM
I disagree with everyone who hates this game. I think it is a very refreshing departure from the typical HOGS. This is truly an adventure game, and for once it is very challenging. I had trouble with the screen darkness until I found the "gamma" settings in the setup; I had no idea what that meant but it lightened up the screen so I could actually see objects.

It does take awhile to get used to the 360 degree screen, but once you start playing, it gets easier. I say, slow down the speed if you are feeling "dizzy"!

I am stuck in the middle of the game now, but I am really enjoying the challenge. That is so much better than back to back boring hidden object searches. This one is definitely not mindless.

Thank you BFG. It is OK with me, if you throw these types of games in every once in a while!
 
 
 posted in Drawn™: Trail of Shadows Collector's Edition on Oct 22, 11 5:36 PM
Thanks for the suggestion, but I do not know how to "cancel" the download. I went to my control panel to completely uninstall the game. Then I went to the BFG website and went from my account to purchase history to reinstall the game. That didn't work and I repeated the uninstall and this time went to the game page and downloaded the trial version, to see if that was where the new update was located. that still didn't work. Any ideas?
 
 
 posted in Drawn™: Trail of Shadows Collector's Edition on Oct 22, 11 11:53 AM
I thought I did, but I am having the same old problem - takes forever to download. Oh well, I guess BFG is simply telling me to get my BFB (big fat bum) out of the computer chair. I got a 30 minute workout done before I got to the play screen, but it has been over an hour and it is still only 20% loaded after I hit the play button. THIS IS RIDICULOUS!
 
 
 posted in Drawn™: Trail of Shadows Collector's Edition on Oct 22, 11 8:01 AM
I loved the other two Drawn games, so I bought the CE rather than playing the trial version. I downloaded and activated the game, but when I tried to play it, it wouldn't load at all. I am going to uninstall and reinstall, but this is frustrating!
 
 
 posted in Enigmatis: The Ghosts of Maple Creek on Oct 9, 11 10:08 AM
has anyone else had trouble getting the telescope button to move into Max position? I don't want to skip this puzzle, but the button seems to be frozen and I cannot find the rock.
 
 
 posted in Urban Legends: The Maze on Sep 19, 11 8:38 AM
I downloaded and played fine up until the aquarium puzzle. I tried to skip the puzzle, but then the game froze and I couldn't continue. The only button that would work was the menu button, so I could actually leave the game without using ctrl-alt-delete, but when I restarted my computer and the game, it is still stuck in the same place.
 
 
Where is the cross in the hidden object scene in the shed after you escape from the bathroon? the hint button is circling something on the cardboard box, but I can't see it at all, and I am stuck on the preview. Frickin' clickin' doesn't do anything!
 
 
 posted in Sacra Terra: Angelic Night on Sep 8, 11 7:41 PM
I loved this game, and I bought the CE. However, I think for this game if you are only interested in the bonus gameplay, it is not worth it. The bonus game is very short, and doesn't really add to the story. Not to mention, they didn't include the only wallpaper I would have liked to have: the demon from the house in the garden. Yum...
 
 
At the risk of sounding "too IT", "have you tried turning it off and on again?" I had problems with the program freezing every time I tried to change the options (i.e. full screen off), and I literally had to turn my PC off and then on again to continue the game.
 
 
I didn't have any trouble at all. I did have a little trouble getting all of the symbols to appear on the paper, though.
 
 
 posted in Grim Tales: The Bride Collector's Edition on Aug 7, 11 10:08 AM
Mine also froze on opening the strategy guide...I guess that's what I get for "cheating"...but I couldn't even get out of it with CtrlAltDelete- I had to turn off my PC. Now I can't open the game at all...
 
 
 posted in AGON: The Lost Sword of Toledo on Jun 12, 11 3:15 PM
That's what I get for working in a lab in the real world: we NEVER use tap water!
 
 
 posted in AGON: The Lost Sword of Toledo on Jun 12, 11 2:04 PM
I just realized I have been using distilled water instead of regular water. I wonder if that makes a difference, although I can't imagine that regular water would be better for developing photos than distilled (???) Let's see if that workks..............
 
 
 posted in AGON: The Lost Sword of Toledo on Jun 12, 11 1:57 PM
I went back and started all over. I prepared the solutions and turned off the light to remove the negative from the cassette, but when I tried to put it into the developing solution, it was told it was not the right solution. I remixed, but nothing happens when I try to put the negative into the new solution (and no timer). Thanks!
 
 
 posted in Tearstone on Jun 12, 11 12:54 PM
Oops, talk about obvious! (I was just oblivious...)
 
 
 posted in AGON: The Lost Sword of Toledo on Jun 12, 11 12:52 PM
I can't get anything to happen when I place the negative into the developing solution. I have remixed the solutions several times now to make sure I had the correct formulae, but I am at a complete standstill. Please help, if there is a trick I am missing. Thanks!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator