Posts created by Jorie10

 
 
Totally agree. Was told we'd find out the fate of the grandfather, but there was no resolution in any way regarding that in the bonus.

Very glad I bought this CE during the CE sale. I would have been very disappointed in the bonus content length and what it added to the story if I'd paid full price for this CE.

Good game, but I'm glad it is over. Not a fan of this sort of FROG game. I really felt I was searching for the same sort of pieces over and over and over.
 
 
 posted in Vampire Saga - Welcome To Hell Lock on Aug 8, 11 8:32 AM
Ditto.

Cannot complete the game as a result.

I also posted in the Update thread about this issue. Just wanted to add my 'ditto' here.
 
 
 posted in Vampire Saga - Welcome To Hell Lock on Aug 3, 11 10:13 AM
I'm with the others. Game stopped at the same place. Have fuse and handcuffs. Nothing more to do in the game. No gears/sparkles on any of the photos. I revisited every scene - nothing to do.

Restarted multiple times. No change.
Uninstalled/reinstalled. No change.

Bummer not to be able to finish the game. Per the walkthrough, I am so close to the end.

Other than this glitch, I thoroughly enjoyed this game. I just cannot recommend it due to having run into this issue.

[Issue reported in the Update thread.]

 
 
 posted in Vampire Saga - Welcome To Hell Lock on Aug 3, 11 10:09 AM
Uninstalled previous version and installed the updated version. All worked well until the end of the game. Game abruptly closed near the end. Restarted but could not complete the game. Uninstalled and reinstalled. No difference. As mentioned in another thread by others, I had a fuse and handcuffs but no H0G scene to continue on (per the walkthrough). No gears or sparkles on any of the photos. Checked all the scenes and there was nothing to do on any of them.

Very disappointed to not be able to finish the game. It's a wonderful game and was definitely one I was going to keep to play again in the future. Now, I'm not so sure I want to play again.

I was glad to read that others were able to play the game without glitches. Just sorry, I wasn't one of them.
 
 
 posted in Dark Dimensions: City of Fog on Jul 23, 11 3:37 PM
Just finished. Loved this game!

I like the adventure/interactive parts of games much more than the H0G scenes, but the interactive H0G scenes in this game were actually enjoyable. Very clever.

Have noted in my Games notebook to definitely play this game again.
 
 
 posted in Dark Dimensions: City of Fog on Jul 23, 11 3:30 PM
I got caught by this, too! I rode that elevator up and down a couple of times until I noticed a bit of movement at the lower right. Then had an aha moment.
 
 
 posted in Dark Dimensions: City of Fog on Jul 23, 11 3:27 PM
Same thing for me, too, had a hot spot indicated in the upper-left of the screen. I ended up ignoring it and was able to finish the game.
 
 
 posted in Vampire Saga - Welcome To Hell Lock on Jul 9, 11 5:42 AM

To crazy8club --- Sorry to hear you had problems with this game. Just wanted to let you know that the game works great on my 24" monitor -- most every BFG game does. The only issue I occasionally run into is that my graphics card cannot support the game. You might want to log your complaint under the Technical thread. Personally, I find the BFG suppport/customer service folks to be among the best.

And since this is a review thread...
I liked the game despite all the hand-holding. I like the 'adventure' side of these games and appreciate that I don't have to spend a lot of time in the H0G scenes. The 'hot/cold' hint lets me get through those scenes a lot quicker. I also thank the first person who mentioned the candle indicator for completed areas. Very helpful! I played the entire hour demo and will likely buy this game later today when I am ready to dig into a new game.

 
 
 posted in Golden Trails 2: The Lost Legacy on Jul 3, 11 7:38 AM
arthurC wrote:Personally, I don't which is greater ... my delight at being able to buy a Collectors Edition on the day of release; my disappointment (three weeks later) on dashing here first thing on morning and finding said game (in the SE) is 'Tomorrows Game Today'; OR my self-satisfaction that a Collectors Edition I couldn't afford, has been released as a Standard Edition.

It's all roundabouts and swings really.



I smiled when I read your posting, ArthurC. My feelings exactly.
 
 
 posted in Mystery Chronicles: Betrayals of Love on Jun 12, 11 12:41 PM
To borrow someone else's word: Tedious. I was so glad it was finally over. (I have trouble abandoning games, so always finish them.)

On the Sneaker Scale, for me, this was 10 out of 10. And it was not good Sneaker action. For the second half of the game, too often I had no idea where to go next (I blame poor game construction), so I was revisiting locations over and over just to find where I needed to be. I disliked using the hint because it told me exactly where to go and what to get there. (Too much info! The hint should have been something like "Visit the Boathouse." One thing about H0G scenes is that you don't always know what will end up in inventory once you finish the scene. Having the hint tell me took something away from the hunt.)



 
 
 posted in Voodoo Whisperer: Curse of a Legend on Jun 11, 11 1:55 PM
Like others, I finished the game and came to see if others found the ending less than fulfilling. Great game up until that 'no resolution' ending. I'm feeling quite let down by it.
 
 
 posted in Hidden Mysteries: The Fateful Voyage - Titanic on Jun 4, 11 3:50 AM
Just a warning since it probably will not happen to everyone...
I bought this when it first was released. Quite a while into the game, the game froze and I could not continue. I started over and the game froze in the same place. Never tried it again.
 
 
 posted in CreaVures on May 31, 11 4:11 AM
Lovely game. (Reminds me of the Commander Keen games from years ago.) Gorgeous scenery. I found the music very peaceful while I moved about.

You can use your keyboard to play. Arrows to move. Spacebar to jump. Take running jumps to jump higher and farther. Gather 'essence' as you go. Etc.

I may buy this one. If I hook up my old joystick, I can sit back and really enjoy it.

(To demo it, on the Configuration's Graphics tab, I set it to Fantastic graphics, deselected Windows mode, set it to 1920x1080 resolution to match my monitor's recommended setting, and made no choice on the Input tab.)
 
 
 posted in Tearstone on May 30, 11 12:21 PM
Hi, Chris,
One thing that would have allowed me to play this game on my Win7 setup is if you allowed the user to resize the game window. Another player (Duke216) discovered that this game worked great on his/her system if s/he worked in Windowed mode. Same for me. Only the window is too small to make playing enjoyable.

As reported in the Technical thread, in Full screen mode, the cursor has trails, the screen flickers every so often, and I couldn't pick up the saw during the tutorial. All worked fine in windowed mode.

Since another user (Kelvarda) had no issue on her Win7x64, I suspect my graphics card may be the issue.

Thanks for considering this for future games.
Any suggestions for getting this game to work properly?

BTW - I'll still be buying Tearstone -- to play on an XP setup. Looks like a great game.

Best,
Jorie
 
 
 posted in Tearstone on May 30, 11 11:03 AM
duke216 wrote:
Jorie10 wrote:Also having a problem with Win7 (x64). But, I also see that Win7 is not officially supported.

The custom cursor has trails. The screen flickers every so often. Took about 10 clicks to pick up the knife in the opening tutorial. Could not pick up the saw at all. Screen froze when I tried to exit. I had to use TaskMgr to end the game.

Will try on my old XP machine later. Sounds like too intriguing of a game to miss.

-Jorie


Same thing for me! I did restart my computer and still had cursor trails, screen flickers, but finally got to pick up the saw and knife. Then it tells me to cut some elastic (rope, something, ?) with the knife which I did. THEN I couldn't pick up the elastic. Was looking forward to this game and I very rarely have any problems with BFgames. I will send a report and hope they have a fix soon.

The game works perfectly (so far) in windowed mode but NOT with full screen. Makes it a little tough to find the objects you need, but it does work.


-------------------------

Hmmm, my response didn't take when I clicked Post Reply. Had to re-confirm my email with Big Fish. Odd. Trying again...

Thanks to duke216 for writing. Good thinking! Works in Windows Mode for me, too, but the window is too small for me to enjoy playing the game. Now, if we could resize the window... (Developers, please note!)

Thanks also to kelvarda. Glad to hear that the game does work on some Win7x64 setups. Perhaps my graphics card is the culprit. (ATI Radeon HD 5970)

I tested the game on my old XP setup and it works great. But, I still hope that the Devs will include window resizing if they do put out a fix. Would much prefer to play on my Win7 setup.

- Jorie

 
 
 posted in Tearstone on May 30, 11 5:04 AM
Also having a problem with Win7 (x64). But, I also see that Win7 is not officially supported.

The custom cursor has trails. The screen flickers every so often. Took about 10 clicks to pick up the knife in the opening tutorial. Could not pick up the saw at all. Screen froze when I tried to exit. I had to use TaskMgr to end the game.

Will try on my old XP machine later. Sounds like too intriguing of a game to miss.

-Jorie
 
 
 posted in Mystery Trackers: Raincliff Collector's Edition on May 20, 11 9:05 AM
Peter, I appreciate that you are reading the forums.

My one big request is to officially support Windows 7. Neither Void nor Raincliff work well on my Win7x64 machine with ATI Radeon HD 5970 graphics card. The flickering that cursor movement caused made both games unplayable. (Perhaps the issue is due to my graphics card rather than Win7. I did read that some Win7 users had no issue with flickering.)

Void worked great on my old XP machine. Fantastic game!

Best,
Jorie
 
 
 posted in Faded Reality on May 20, 11 8:14 AM
(Win7x64 computer)
Would have bought it except it did not save my progress. I got to the second level and exited the game. I went back in later, using the same profile, and was back at the beginning of the game. Closed/reopened again to be sure I had my profile selected...still at the beginning. [I have an old note from when I previously demo'd the game (on my old XP PC) that Save only occurred at the end of a level, so I would not have been surprised to be back at the beginning of the second level, but that was not the case.]

I am going by what another poster said -- that each level is 2 areas. If this is incorrect, I would appreciate someone letting me know and I will give the game another chance.

BTW also had a screen flicker every so often. Not bad enough to not play the game. Due to the Save issue, I didn't bother to try a different monitor refresh rate.
 
 
 posted in Snark Busters: All Revved up on May 11, 11 4:04 AM
bfgHondo wrote:Hi maggotUK!

Click <a href="http://blog-assets.bigfishgames.com/Walkthroughs/Snark-Busters-2-All-Revved-Up/snark-busters-all-revved-up018.jpg">HERE</a> to see a helpful screenshot from our <a href="http://www.bigfishgames.com/blog/snark-busters-2-all-revved-up-walkthrough/">Snark Busters: All Revved up Walkthrough</a> that reveals the location of all 4 fireflies.

Jorie10 - which of the 4 fireflies in the above screenshot isn't showing up for you?

If you think there might be a glitch with the game, I'd definitely encourage you to contact our <a href="http://forums.bigfishgames.com/posts/list/144284.page">Technical Support</a> team. They're always happy to help!

Happy gaming!

-bfgHondo


Hi, bfgHondo!

After seeing someone else's post on this issue in the Technical thread, I think I did find all 4 fireflies. (The locations in the WT were familiar). Only 3 went into inventory, apparently. Or perhaps I missed when I tried to place one in a lantern and the firefly didn't go back into inventory. Not sure. I will do what SnappyPeas did --- start again with another profile to see if I can get past this part. IMO, there is definitely a glitch in this part of the game. Per what I've read, three of us ran into it.

Thanks!
Jorie

FYI
Didn't have enough time left in the demo to re-try this game with a different profile. Won't bother to buy the game unless a fixed version is released. Too bad. I really enjoyed the first Snarkbusters and was looking forward to this one.
 
 
 posted in Snark Busters: All Revved up on May 9, 11 3:57 PM
SnappyPeas wrote:Catching all the fireflies...

I caught them all then one disappeared from inventory before I could place it in the jar. It is also no longer anywhere to be found and the game is stuck at this point. It isn't there... so how can I progress?


Also having the same issue as SnappyPeas, though I'm not sure I had all four... It seems that I cannot progress without that last firefly. I checked the Walkthrough for the location of the four fireflies and none at any of the spots on my screen. Hint does not appear to be working either or it's just as stymied as I am. (SnappyPeas, please post if you find a solution and I will do the same.) - Jorie
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator