Posts created by MaryD1215

 
 
 posted in Delicious: Emily's Moms vs Dads Collector's Edition on Apr 8, 18 12:33 PM
I bought this game before playing the demo as I love every Emily game and own them all. I wish I hadn't bothered. I really don't like this game. Don't like all the clicking and rubbing, etc. Don't like that Emily wasn't front and center. This is the first Emily game that I can definitely say I won't play again. Actually I had no interest in completing all the challenges. Just wanted to get to the end and be done with it. Total waste of money in my opinion. I really hope the developers are listening.
 
 
 posted in Solitaire Blocks: Royal Rescue on Nov 4, 17 1:24 PM
I like the premise of saving the royals but intensely dislike the waste of time for the "battles". Just because of that, I'm deleting after just 15 minutes of play. Too bad, the actual solitaire part was unique and fun but not enough to sit through those stupid battles.
 
 
 posted in Adam Wolfe: Flames of Time on Jan 24, 17 3:21 PM
Same here. I hadn't bought it yet but can't even get in to play the demo. What a crock.
 
 
I have to say, I really enjoyed the story in this game. It was such a nice change from the monster/ghost/dark asylum/etc. that we see in so many games. I thought it was funny that they used all the games with the authors, very amusing. A nice, straightforward murder mystery. A bit too much back and forth, but that's true of most games. Definite yes for me.
 
 
 posted in Black Swan on Jun 4, 16 4:12 PM
This game feels like a first effort, and if it was the first game I ever played, it would probably be ok, but I just couldn't keep playing. too bad. It looked good but the grammar and game play was awful - it just frustrated me.
 
 
 posted in Beyond: Light Advent Collector's Edition on Jul 28, 15 3:41 PM
I have to say I was pleasantly surprised at the story. Really nice change. However, there were WAY to many cut scenes, they were WAY too long and many of them had no skip option. I got so bored waiting for those scenes to finish, I was watching tv while I waited. I never do that. So all in all, though I was really pleased with the story, this is a definite no buy for me.
 
 
 posted in Holiday Solitaire Easter on Apr 12, 15 8:51 AM
I like this game. It's nothing exciting but a nice way to while away some time without thinking much. However, I'm running into a problem that's really frustrating me. More and more frequently, when I click on the deck, it's throwing two sets of cards so I miss one set (make sense?). Without spending to get the undo option, I can't see a way to avoid this. Any suggestions? I'm really sorry I bought the game now.
 
 
 posted in The Other Side: Tower of Souls on Jul 31, 14 9:18 AM
I started out really liking this game but after a bit I had to force myself to finish the demo. The cat is awful. I don't want to be spoon fed EVERY move. If I want help I'll click the hint button. I didn't have a chance to figure out anything on my own because the cat told me what to do before I could even try. It seems that a lot of the reviewers had no problem with this, but I did. And no way to turn him off. Also the inventory had no lock. I hate the popping thing. I always keep my inventory open because the constant open/close thing makes me nuts. No interactive map is also a downer for me. It looks like the game has promise but as it is, it's definitely a no buy for me.
 
 
 posted in The House on Usher on Jul 30, 14 9:58 AM
As soon as the screen locks up for over clicking I end the game. The very first HOG was impossible. I couldn't find most of the objects. Too small and too dark. Maybe it gets better but the click penalty is so old school. Not for me.
 
 
 posted in Sable Maze: Forbidden Garden Collector's Edition on Jul 28, 14 1:02 PM
j62janet wrote:I tried to play this game twice, and in the same place each time, the game stopped playing, so unless BFG resolve this glitch, I'm not buying, every game BFG sell, should be tested before it's released to the members, this is not on, good luck to others who try to play it

28/7/2014
I use Windows 7[u]


Same thing happened to me. Stopped in the same place each time I tried.
 
 
 posted in Antique Shop: Journey of the Lost Souls on Jun 22, 14 8:42 AM
Really disliked this game. Uninstalled after 10 minutes. Even with the magnifying glass I couldn't see the objects. When I did find one it was only because i was clicking randomly. Very frustrating. Don't play for frustration. So definitely a NO for me.
 
 
 posted in Bluebeard's Castle: Son of the Heartless on Feb 17, 14 1:23 PM
I was really disappointed in this game. It is completely unintuitive. I couldn't find a "skip" for the puzzles, couldn't exit out of several scenes...had to restart the game-not a freeze, just the inability to exit before completing a goal. When a game frustrates me this much I just delete it. Don't need the aggravation. It's supposed to be fun.
 
 
 posted in Amazing Adventures Riddle of the Two Knights ™ on Jun 28, 12 4:51 AM
When I tried to load this game my virus program warned me that this program was trying to monitor activity on my computer such as key strokes or passwords. Has anyone else received this message? I 'm afraid to continue even though I trust Big Fish.
 
 
 posted in Mystery Case Files®: Escape from Ravenhearst™ on Jan 17, 12 2:56 PM
I really, REALLY disliked this game. I hate morphing objects even in small doses and in this game every "HOG" (and I use the term loosely) scene was morph. Whoever thought that was a good idea should be fired. Ugh. A definite thumbs down on this one for me.
 
 
 posted in Relics: Dark Hours on Nov 25, 11 11:11 AM
This was the worst game I've played in a long time. I couldn't figure out how to do anything. Knew what I SHOULD do but with those stupid arrows and blank walls, I couldn't figure out HOW to do it. UGH!!! Don't waste your time unless you like going in circles.
 
 
 posted in Bluebeard's Castle on Nov 18, 11 7:01 AM
I had a real problem with the HOGs. The words didn't show up on my list. I could run my mouse over the area and the shadow would appear in the box on the left, and when I found the item from the shadow a blue line would appear in the list box but no words. This was so frustrating. Anyone else have this problem?
 
 
 posted in Silent Evil: Kate's Rescue on Aug 17, 11 9:07 AM
I have to admit that after reading some of the reviews on the review thread, I went back and tried again. It wasn't great but not the worst. Some of it was really interesting. I won't buy this game but hopefully the developers will gain some experience (and better editors for the language) for their next offerings.
 
 
 posted in Silent Evil: Kate's Rescue on Aug 17, 11 8:05 AM
Boy you lasted longer than I did. Five minutes was all I could deal with. This has to be the absolutely WORST game I've played in a very long time. Does anyone at Big Fish screen these games before offering them to us??? If so, that person should be demoted!
 
 
 posted in Dark Dimensions: City of Fog on Jun 19, 11 6:15 AM
Am I the only one who had problems with the tools? Almost every time I had to use a tool, the box would show empty. If there was a hint available (some scenes there was no hint button) I could hit the hint button and all the tools would show up and I could use them. On the puzzles where there was no hint button, I couldn't access any of the tools. Really irritated me because this was a real possible buy for me but....
 
 
 posted in Mystery Agency: A Vampire's Kiss on May 11, 11 5:21 AM
This is one of the worst games I've ever played. I almost always, at least, finish the demo but after a bit on this one I had to stop. First of all I couldn't play it full screen because the screen kept rolling, then the items were so tiny there was no way I could find them without many hints. The final straw, though, was the "find the differences" puzzle where I clicked on several obvious differences and it wouldn't "find" them. I was so annoyed I came right here to put in my 2 cents.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator