Posts created by HonInBalto

Hmmm... thought it was the curse of the month. Oh well
 posted in Wandering Willows on Aug 12, 10 9:30 PM
Rats! I know where the last pet lives, I'm hanging out with the animal that's strength is encoraging eggs, yet all I do is dig up gold, etc., etc., ad nauseum. Phoo. (And no I don't have Adobe 10, drivers updated yada, yada) Big fat phooey!
 posted in Elixir of Immortality on Aug 6, 10 6:59 PM
It is a freeze point; sometimes it allows me to go back to the game, but of course there's nothing else to do; usually I have to Ctrl, Alt, Del. Good luck e1; I'm deleting my remaining time.
 posted in Hotel on Jul 30, 10 5:55 PM
I'm getting the dreaded "your computer has encountered a serious error" because both times that I tried to walk up the steps to the right of the reception area, my computer shut down completely and restarted. Microsoft error reporting refers to it as a "stop" or "blank screen" error and advises removing the software altogether. Will do! (And I'm not risking my computer on some "fix" update that obviously has problems as well.)
 posted in Elixir of Immortality on Jul 30, 10 4:13 PM
Shiba_Inu_luvr wrote:
waguhs123 wrote:I only played this game for 10 minutes, and while having to try to pick the lock to the door, the game would not function correctly. It would not let you skip or exit the puzzle, so when I tried ctrl alt del, my computer froze up and I had to turn my computer off manually.

I am Having the same problem. Anyone know how to fix this?

Same here, picked the lock 5X, but nothing happens. Sometimes it lets me exit, sometimes I have to Ctrl, Alt, Del. But no matter what the door stays locked. And more buggy gameplay to come? No thanks.
 posted in Potion Bar on Mar 21, 10 2:10 PM
Obviously this game shouldn't have been released when there is no fullscreen option, and it only plays in a window while the desktop that is visible constantly strobes. And yes, my drivers, Adobe, etc. are up to date.
 posted in Time Riddles: The Mansion on Mar 21, 10 2:00 PM
I can't even get past the loading bar. The hand cursor just sits there until I exit with task manager, so I never played more than 2 minutes of the demo.
 posted in Atlantis Quest on Feb 26, 10 8:32 PM
YOU guys finished!

If there's a level after the 2nd Rome, let me know, 'cause I'm going to have to start over. Wow, this one' a tough s.o.b.!!
 posted in Escape from Lost Island on Feb 26, 10 8:24 PM
I'm still running XP(Pro), and have almost never had tech problems. Except for ONE time with video card incompatibility>

Blame Microsoft!!!!!!!!!!!!!!
 posted in Big City Adventure: Vancouver Collector's Edition on Jan 29, 10 6:30 AM
I just received the beta test for this one Tues. night (2:20pm their time), and now I realize why it ran smoothly as glass; it was already ready to go!

Personally, I liked the new mini-games, even just as a change of pace, particularly the bobsled game, which is one of those where you have to connect the track from start to finish, similar to ones in other games where you nave to rotate pieces in order to connect electrical circuits. They also didn't get rid of the one that seems to frustrate so many people in the harder levels (there's always the skip game option!). That's the one where you have to clear the board by clicking on groups of two or more objects in order to clear the board, and that bottom row can be a real pain, as well as the occasional corner. I liked the challenge of that one. Other than that, the only change in the game itself is the addition of 2 items (marked in blue), that you have to find by zooming in on a certain area, which eventually sparkles at some point, but seemed to take longer and longer to do so as I went along. A little too easy at first when it sparkled right away.

Can't really say anything about the CE from the beta test, so I will defer to laflamme on that. But if you did like the other three, this one is by far the best, IMOP.
 posted in Mystery Age: The Imperial Staff on Jan 7, 10 7:22 PM
I was wondering, esp. when I got all the way to the wizard's home during the demo. Don't feel like getting burned like I did on Pahelika, no matter how much I was enjoying playing it. Thanks
 posted in Mystery Age: The Imperial Staff on Jan 7, 10 7:18 PM
the jewel
 posted in Mystery Age: The Imperial Staff on Jan 7, 10 7:15 PM
The tip of the wing isn't in the basement; find every thing else you need to cool down what you pulled out of the fire.
 posted in Feeders on Dec 20, 09 4:31 AM
Thank you Dancing cat; I was just going to create a thread asking if this was a tetris style game, since it said that you had to match the algae pieces to the creatures that eat them. But the screenshots looked very much like Tetris. Your info was really helpful.
 posted in Righteous Kill on Dec 14, 09 12:59 AM
I enjoyed this game when I played it at another site (the one where you can play certain games all the way through for free if you can stand the constant ad interruptions ), but it was very short.
 posted in Redrum ™ on Dec 6, 09 2:13 AM
It's just soo-oo-oo freakin' cool
 posted in Escape the Museum 2 on Nov 22, 09 11:00 PM
Thanks so much all of you! Just started playing the demo, and am enjoying it a lot. I'm sure it will take me much longer to finish than others; I have more fun when I don't race through it.
 posted in I SPY ™ Spooky Mansion Deluxe on Nov 21, 09 8:38 PM
I hear what you're all saying, but finishing the game AND going back in to do the same puzzles over again to make dinner for my skeleton friend, just didn't interest me. Glad the rest of you are feeding him, I couldn't take any more, so deleted the demo.
 posted in Escape the Museum 2 on Nov 19, 09 12:24 PM
Thanks so much you two. I also like to wander around, take my time, not skip puzzles, and desperately try to never use hints. I feel much better now, guess I jumped the gun a bit. (Mine's still downloading; 163MB takes forever when you have a slow ISP.)
 posted in Escape the Museum 2 on Nov 19, 09 12:41 AM
I think in the first EftM there was the possibility of 100% accuracy. How about this one?
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator