Posts created by Halotop

I bought... agree... fascinating.... BUT why no in game strategy ???

And..when will there be one on the forums????
 posted in King Arthur on Sep 26, 10 2:53 PM
found all except the weight... in second **** play...

help!!!!! Please!!!!!
 posted in King Arthur on Sep 26, 10 2:47 PM
WolfenRaindancer wrote:I just finished my third twelve and I am finding this game quite relaxing. I actually enjoy Merlin's voice, and haven't yet been tempted to hurry him along...on the contrary, I found myself getting into the spirit of the game. I feel as if I am starting out on a magical adventure, and only stopped to go ahead and buy the game. I guess you just have to be in the right mood for something that is not quite as frenzied. It kind of reminds me of the voice in Drawn...just draws you in...if you are willing to let it I haven't tried the hint system yet, and am just starting out in the forest, so I am going to go back to it. I may change my mind, but at the moment, I think I am really going to enjoy this one.

I am wanting to buy this one...BUT I can't find the weight... last item for me on the second **** play... since you played it alrready...please tell me.....

I also found that I can click on crowns... and collect them... anyone else find this?? and/or know why???
 posted in King Arthur on Sep 26, 10 2:10 PM
Bless you!!!!!!! I was going nuts..
 posted in Mystic Gateways: The Celestial Quest on Sep 11, 10 3:08 AM
I had to turn green lights to red... suceeded by just playing around.. didn't have the patience to work out the sequence ...the door then opened...
 posted in Mystic Gateways: The Celestial Quest on Sep 11, 10 3:06 AM
The opening scene ...the lamp...did appear AFTER I exited and restarted... after that all works well...

I think it's a keeper.. IF it continues to work well :-)
 posted in Exorcist on Aug 17, 10 1:22 AM
The game looks promising.. BUT.. I like walkthroughs just in case.. of anything.. and I cannot find a link anywhere/// Anybody know why???

Thanks to all who agree with the nbecessity of a walkthrough.. has nothing to do with easy or hard.. BUT every game I have purchased has one thing or another (that vary for individuals) that drives them nuts.. and a walkthrough saves time..

I also used to buy without wt's but no longer.... Has to be fun, right :-))

 posted in Mystic Diary: Haunted Island on Aug 14, 10 1:45 AM
tuttepeever wrote:Just playing but find myself somewhat frustrated as to what and where to go next. Hints are only helpful in the hog scenes and take too long to reload. Thank god for the walkthrough but I resent having to use it so early in the game and will deny myself until I become totally frustrated. However it looks like a game with lots of potential even if it only has 5 chapters. Will keep you posted as I continue to play. Other's please do the same.

where did you find the walkthrough??? If I can find it I'll buy the game...

Was in the room with the giant bear and rabbit doing the 300ad scene....
I finished the 'supposed' hog and found all the items whereupon I was supposed to get a goat... I didn't... of course.. this is the last animal needed before proceeding to the main clock and finishing another puerile game before being able to continue...
So... now (after checking strategy with a fine tooth comb) and realizing i had done all as supposed to... I cannot go forward...

Anybody have this problem??

I am hoping to find answers instead of playing again with another profle :-))

Thanks fishies
ranmoor33 wrote:tried all ways to open the safe but cant 4 clockwise 1 anti 7 clockwise and 2anti clockwise can anyone help or is there something wrong with the game ? thanks

another thread excplained.. there is an error.. you have to do the first COUNTERCLOCKWISE..and the following numbers as explained... worked for me
Jinnare wrote:
lvfao wrote:btw is there an intervention for this stuff????

Intervention?? Sign me up!! Do you suppose we could get a reality TV show? The Big Fish Intervention Hour.

Oh we do need our own reality show.. I'm with you... I DEFINITELY need an HOGS intervention :rofl:
Is anyone else having problems with the second puzzle within the safe?

I have (finally) placed all the balls in the right place... cheated and checked guide to make sure they were right... and nothing happens...I cannot go forward.. and cannot skip this one...


and thanks!!!!!!!!!!!!!!!!!!
counterclockwise worked like a charm... once you start in the corrected direction.. there is no need to worry about the mouse.. it will stop jumping back to 0.. evidently it does this only when you are working in wrong direction.

The problem I have is with the second puzzle within it.. I (finally) got all the balls in the right direction ...and nothing happens...

what gives???
 posted in Immortal Lovers on Jul 24, 10 7:20 PM
I agree.. items are way too small to identify... frustrating.. not worth the time.. won't even finish the hour!!!!
 posted in Midnight Mysteries: Salem Witch Trials on Jun 12, 10 7:36 PM
jah1941 wrote:
luvthsun wrote:I cant figure out the right time on the clock so I can get the key!!! Help someone!

Look at the books to the right of the door. There should be some that are glowing. That's the time you move the hands to on the clock. 2:11

For me.. the correct time was 1:05.. where the tunes met and became a key :-))
 posted in Midnight Mysteries: Salem Witch Trials on Jun 12, 10 7:30 PM
biggr wrote:
Krissy41 wrote:Hi can someone help me. I used the stethoscope on the safe but I don't know the combo on the book? inside the safe. Does anyone know the combo?

Did you find the code?

If you're still stuck... the combo number varies from one to the other program. You get yours once you've used the charcoal over the paper.. the resulting dots and dashes are the answer.. get the morse book and put it into the same scene.. it will open and the lines uncovered by the charcoal will correlate to the numbers in the book. Seems hard, but once a kind fishie (one told me :-)) lets you in on it.. it's a breeze. Good luck
 posted in Midnight Mysteries: Salem Witch Trials on Jun 12, 10 1:32 PM
Once you explained it.. I couldn't believe how simple it is...

Fishies... look at the smudges after you rub the charcoal, and after you have found the morse book... each rub line corresponds to a line in the book.. mine worked out to 1592... after an experienced kind fishie told me how it works.. I was brilliant!!!!

Thanks a heap.. it was driving me crazy
 posted in AGON: From Lapland to Madagascar on Jun 1, 10 5:34 PM
For me, my dear little fishies... it's quite simple... no walkthrough... no purchase...
 posted in Magic Encyclopedia: Illusions on May 8, 10 12:04 AM
BinLA wrote:All five of the pieces of the silkworm are outlined in the walkthrough, on the picture showing all 5 locations in one panel. If you don't see the silkworm piece in those locations with the glasses off, look at those same locations again again with the glasses on. If you still don't see it, use a hint. I can't remember which location holds the body, so I can't be more specific than that. The one I had trouble with was on the edge of the roof eave, but it was there. I just had to use a hint because I couldn't see it with glasses on or off!

When I use the hint all the 5 spots tell me to look elsewhere.... achhhhhh!!!!!!

BUT the body is still not in my inventory...

Thanks tho
 posted in Magic Encyclopedia: Illusions on May 6, 10 7:05 PM
Hi all,

I'm stuck.. after checking the walkthru and reading posts.. I still cannot find the fifth piece (body) of the moth.. when I checked the walkthru.. three pieces have triple squares around them to highlight where to find them.. I'm wondering if this means either a combination of exiting and reentering using the magic glasses (or not) or something to that effect is needed in order to find it...

HELP... please.. I like the graphic s, etc. of the game BUT the running hither and yon with and without the glasses can become quite irritating..

Any help really appreciated!!!!!!!!!!!!!!!!!!!!!

Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator