Posts created by silvergirl_quest

 
 
 posted in Time Dreamer: Temporal Betrayal on Jan 24, 14 8:53 PM
Yup. The exact same thing happened to me. From looking over the previously reported technical problems, it seems to me that this game isn't Windows 8 compatible.
 
 
 posted in Elementary My Dear Majesty on Mar 22, 12 1:26 AM
Oh man, I really feel for you, tbannieVa. I was grinding my teeth over this one.

After a whole lot of frustrating searching, I finally found the Eskimo's stupid binoculars. To see them, you have to turn the scene to the extreme left side: the binoculars are on the left side of the bottom tier (two tiers right below the Santa), behind a tree (which is beside a book).
 
 
 posted in Turtix on Feb 25, 12 9:22 AM
Thank you so much, ShortTaz! Man, I was getting incredibly frustrated futilely trying to jump OVER activated portals without going through them!
 
 
 posted in The Witch and The Warrior on Jan 12, 12 3:54 AM
Try looking in the town of Nethina.
 
 
 posted in 4 Elements on Sep 26, 11 2:02 AM
LizzieK wrote:The new game, 4 Elements 2, can be played in untimed mode, which is a welcomed change. I think they will sell more games because players will have the choice of timed or untimed.

Why would I ever buy the sequel to this sadistic game? I even downloaded the "new, easier version" update, and I still can't get through level 63: I can't even figure out what I'm supposed to be aiming for when I'm ripping through above the exploding arrows. I love match-3 games and I love doing them in timed mode. Obviously, I'm not fast enough to get through even their "easier version" and that's very disappointing to me.

Maybe sometime I'll try to finish this game, but I can't see rewarding the developers by buying the second game, especially at a CE price. (Come to think of it, I don't think I'd buy the second 4 Elements game even at a COW price, and that's a good sign as to how angry the first one made me.)
 
 
 posted in Lilly and Sasha: Curse of the Immortals on Sep 23, 11 6:30 AM
Nope, you're definitely not stupid! The placement of this next puzzle is a little misleading. The second puzzle is the purple vortex, not the red vortex, so you have to go north of the red walls to the purple walls.

Just past and to the right of the purple vortex-stone, there's a door (in the house with the beer sign) on the north side of the terrace, and here's where you'll find the purple vortex challenge.

(Btw, the "Fox Chronicles: Chapter 2" isn't by this puzzle for the purple vortex, but by the next puzzle for the orange vortex.)
 
 
 posted in Nick Chase: A Detective Story ™ on Dec 23, 10 8:53 PM
Welcome, bluedun!

Try to make sure that you've cleaned the entire bowl, including the very top and bottom edges. When the entire bowl is clean, the next sequence happens automatically.
 
 
 posted in Kaptain Brawe - Episode I on Dec 6, 10 10:21 PM
I shouldn't be so cryptic about this! What I mean to say is that Canadians should be sure that they're paying in US dollars instead of the default Canadian dollars.

If you pay in Canadian dollars, you'll be paying $7.49 Canadian dollars. But if you pay in US dollars, you'll pay $6.99 US, which equals $7.03 Canadian based on today's exchange rate posted by the Bank of Canada at closing today ($1 USD = $1.0053 CAD).

That means that if you pay in Canadian dollars, you'll be paying $0.46 more than if you pay in Canadian dollars.

Strange but true.
 
 
 posted in Kaptain Brawe - Episode I on Dec 6, 10 9:21 PM
Btw, the "Message to overseas customers" also pertains to Canadian customers that are paying in Canadian dollars instead of US dollars.

Thank you for trying to spread the word to be careful of how much you pay, kelvy.
 
 
 posted in Reincarnations: Awakening on Dec 2, 10 9:29 PM
Thank you so much, superchevyguy!

I was getting reeeeelly frustrated with trying to put the vegetable bowl on the counter, so like you I looked up the walkthrough and THAT didn't help at all.

After I read your post, I uninstalled and reinstalled the game and, like you, it worked on the first try.
 
 
You go into Options and they have the three Attitude buttons that you can choose. But like WilJul and ChesterPepper79 I didn't notice any difference between Southern and Normal modes.

(In Dire Grove, they had Normal, Snarky and Motivational attitudes that you could choose. I loved the comments the game would give you when you had the Motivational attitude setting on! Hilarious!!!)
 
 
 posted in Super Granny 5 on Nov 24, 10 12:42 AM
Thanks, RubyAnn57!

I absolutely adore the Super Granny games (I think 3 and 4 are my favorites) and I keep on playing them. So because of your recommendation I've downloaded Panda Craze and I'll give it a try.
 
 
 posted in The Lost City of Gold on Nov 17, 10 1:24 AM
Good catch, LilyCat! (Although I haven't seen any prices in pounds sterling or euros, just in dollars!)

I wonder if BFG has started to update the pages to a higher price but forgot the New Releases page?
 
 
 posted in The Lost City of Gold on Nov 17, 10 12:52 AM
I think they must have increased all their prices: the DD and regular SE prices by $0.50 because the price for SE games is $7.49 (non-member price now $10.49), and the price for CEs is now $14.99 (non-member price now $20.99, so the price for a CE is still double that of an SE).
 
 
 posted in The Island: Castaway on Nov 2, 10 2:50 AM
I think you could lose your trap if you are "killed" by boars. It looks as if the items that you lose may be random. That's what I think happened to me, anyways!
 
 
 posted in Druids - Battle of Magic on Oct 30, 10 3:30 PM
Ah! Now I see the spot you mean! I apologize for misunderstanding your very clear description!

Yes, that tile never populates, but you don't have to worry about it because it's already cleared. So just clear the rest of the level and you'll be able to start level 33.

Happy gaming, jkjmd03!
 
 
 posted in Druids - Battle of Magic on Oct 30, 10 2:36 PM
I'm looking at that level now, and I can't figure out what tile you mean (since I haven't found any problems with that level myself).

Could you tell me the exact spot on the grid, describing the spot with X, Y coordinates?
 
 
 posted in Druids - Battle of Magic on Oct 30, 10 1:36 PM
I can't see any locked tiles in the upper right corner of level 32 (which does look sorta like a map of the US). The closest ones to the upper right are three grey tiles at 7 left/3 down, 8L/3D and 8L/4D (maybe more like Michigan than Vermont?)

If this is the level you mean, the two tiles at 8L/3D and 8L/4D are usually okay to unlock, while the tile at 7L/3D is usually more difficult because the rarer medallion-type tile(s) get in the way. (It's harder to manipulate the tiles so that you can move out the medallion out to make a match-3.) By far the easiest way is to just use any of the spells (power-ups) which will remove one layer of the lock as well as nuking the medallion(s). Now it should be no problem!
 
 
 posted in Druids - Battle of Magic on Oct 27, 10 12:50 PM
You're very welcome, AbleBabel!

Before I bought the game, I'd noticed that there were several people having trouble with this level but that several others had finished the game so that level was doable. (I only got to level 18 during the demo, so I never got to see it for myself before buying.) Oh boy, I got really stuck on level 20, too! But I slept on it, and when I tried again I was shocked to find the answer pretty quickly. I immediately wanted to post the answer for anyone else having trouble with this level.

Happy gaming, AbleBabel!
 
 
 posted in Druids - Battle of Magic on Oct 27, 10 12:01 AM
Yup, it's the frozen block in the middle that needs to be thawed before all the empty blocks below can be filled and then cleared. The only way to thaw the block is to use any of the power-ups on it. So you have to get any of the power-ups (by matching one of the four types of elements) which will thaw that pesky isolated frozen block.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator