Posts created by Beronika1954

 
 
 posted in Danger Next Door: Miss Teri Tale's Adventure on Feb 28, 11 11:07 AM
Problems
I bought this full price and loved it until I made one error and they would not let me undo it. It is a very unforgiving game. It will stay stuck at that level and you have wasted all that time. I advice not getting coaxed by the "cute" voices and humor, it is not amusing when you have to start a game from the beginning for one wrong click.
 
 
 posted in Renovate & Relocate: Boston on Nov 3, 10 4:19 PM
Antique Road trip and Fabulous Finds
 
 
 posted in Fabulous Finds on Oct 13, 10 2:25 PM
I played thru and it said I can now just decorate. But I only have $35. How can I earn more money from yard sales if they are not presenting me with the chance? Is there a way to generate more yard sales?
 
 
 posted in Secrets of Great Art on Jul 17, 10 4:47 PM
I hate when you get a reprimand for too much clicking! How is that relaxing? I quit after fifteen minutes. I do not need a game that takes time off for the clicks! And I like Art so I wanted to like this.It's a no for me.
 
 
 posted in Agatha Christie: Peril at End House on Jul 1, 10 1:08 PM
I PMed you.
 
 
 posted in Mystery Cruise on Jun 30, 10 2:41 PM
I give up on this game. I cannot get to that room 12, cannot get enough light bulbs. Someone PM me what the answer to the story is. Whats with the boat? why is she there, etc. TU.
 
 
 posted in Agatha Christie: Peril at End House on Jun 28, 10 7:48 PM
Maggie was just murdered during the fireworks and they gave me a new room (where her body is). I am out of hints and I cannot locate the feather. Please help!
 
 
 posted in Mystery Cruise on Jun 22, 10 12:05 PM
I cannot reach it. I do not have enough bulbs.
 
 
 posted in Mystery Cruise on Jun 18, 10 9:22 AM
I have the exact same problem! I am now regretting buying this game. I already can only do it with the walkthru, and now the walkthru is useless. If anyone can get us thru this- please answer or pm! I am thinking about asking for my game credit back. There seem to be many people who have had this issue.
 
 
 posted in Mystery Cruise on Jun 17, 10 9:49 PM
If anyone solved this- please message me. I am stuck, tried a new player name, tried everything; cannot reach that room that is on the walkthrough.
 
 
 posted in Dr. Lynch: Grave Secrets on Jun 13, 10 1:37 PM
You DO lose time for the clicking too much which makes me not want this game (combined with the timer.)
 
 
 posted in Hidden Expedition: Amazon ™ on May 6, 10 3:14 PM
Just wanted to share- I have Windows xp, my computer never crashed before and I just played into the second scene and "The Blue Screen of Death!" Wanted to warn people. I am uninstalling it.
 
 
dd
 posted in Age of Emerald on May 1, 10 9:15 PM
This game is pretty old. When do you all think it will be a Daily Deal? I would get it for that price but I am hesitating for 6.99. It;s fun, quick, but I am not sure if it will hold my interest. Is there any pattern to the daily deals?
 
 
 posted in Age of Emerald on May 1, 10 6:03 PM
Have you done Fishdom? It has an untimed mode and it is very addictive and relaxing.
 
 
 posted in Nick Chase: A Detective Story ™ on Jan 31, 10 6:55 AM
is at
jayisgamesdotcom search for nick chase a detective story walkthrough
 
 
 posted in Word Zen on Dec 7, 09 1:21 PM
Is this a defect or glitch? Is there a way to skip this level altogether?
The time is too short to make the words!
 
 
 posted in Redrum ™ on Dec 7, 09 1:20 PM
I just finished it, playing the relaxed mode. It was very fun, not too scary, and no penalty for clicking in that mode.
It was a little short but my time is short anyway. Sometimes you want a game that you can win!
 
 
 posted in Word Zen on Nov 28, 09 8:13 PM
I was loving this game, but have been stuck in student 5 for a long time. Is there a way to get the timer longer or is there some sort of trick to it? It was rolling along and now it is not fun to play.
 
 
 posted in National Geographic ™ presents: Herod's Lost Tomb on Nov 21, 09 8:40 AM
I hate to buy HOGS with no blog thru, I have been burned before. Is there one planned for this game?
 
 
 posted in National Geographic ™ presents: Herod's Lost Tomb on Nov 21, 09 8:29 AM
You have to use the brush- it is under the tools and you click the brush on the mounds of sand. The manuscript is under the sand mound on the right toward the top. But without brushing away the sand it will not show.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator