Posts created by ktk514

 
 
 posted in Ball-Buster Collection on Jun 25, 13 11:22 AM
I have to say I am surprised by how much I like it. It's got so many to choose from, or you can play radomly selected games, I've played for several hours total and am nowhere near tired of it. The one complaint I have is that there is no "replay" button. If you want to replay one you have to go back and choose it. Not a BIG deal, but it breaks up the flow of play, and choosing from a small picture it's easy to choose the wrong one since there are similar ones.
 
 
 posted in Jigsaw Boom on Oct 2, 12 9:39 AM
Mine will play fine for a while then it freezes up. Few seconds later the screen goes black. I have to manually turn the computer off and then back on. It just gets stuck that way. Unfortunately, it appears there have been known problems for quite a while - which I did not know of until I bought it today. BF, why are you still selling games with known issues?
 
 
 posted in Curse of the Pharaoh: The Quest for Nefertiti on Jun 28, 12 1:23 PM
I finally got it to work. They go in the right side of the case, were there is a gap. I had to try several times. It's finicky.
 
 
 posted in Curse of the Pharaoh: The Quest for Nefertiti on Jun 28, 12 11:36 AM
I have that same problem. It won't let me place them in the glass cabinet.
 
 
 posted in Solitaire Pop on May 30, 12 7:02 AM
Ok. Mine is completely hosed now. I tried starting a new game, I un-installed and re-installed the game, and still, as soon as I start to play, all but 2 tiles freeze up, and the 2 that are not frozen, are not together, so I cannot use them. I had to just remove the game. Dangit. Any ideas of how to make it work again would be MUCH appreciated.
 
 
 posted in Solitaire Pop on May 29, 12 4:50 PM
I really like it too. It's addictive. I'm on the Birka expedition dig 10, and all but 2 tiles are frozen, and 2 not frozen aren't close together, so I can't play. Does anyone know if it unfreezes, or is this the end of the game for me?
 
 
I'm on one scene where I've been looking for the last hidden object (an hourglass) for 2 dang days. Knowing what it looks like is not helping me at all. WE...NEED...A...WALKTHROUGH.
 
 
 posted in Big City Adventure: London Classic on Feb 13, 12 6:15 PM
bfgCimarron wrote:Hi mplatt,

If you're having trouble with the safe, it looks like one player found a way around it in this thread here: RE: SAFE

LizzieK wrote:Post removed by user


However if you're still having trouble after that I'd definitely get in touch with our Customer Support team (if you click that link it will take you to more information about getting in touch with them) and one of our reps would be happy to help out.

Hope that helps!

bfgCimarron




I did the first safe game, but I'm on the second, and can't get it to work.
 
 
 posted in Renovate & Relocate: Boston on Jan 25, 12 8:38 AM
so far I'm undecided after playing the demo. I like the straight up HOGs, and the decorating - there was not even 1 combo I would ever choose for my own home, so that made that part tedious. Plus, going from one screen to another takes too long. sloooww..
 
 
 posted in Million Dollar Quest on Nov 11, 11 3:26 PM
It already was bad enough that I wouldn't have been buying it, but then I got the part where you're suppose to fit all the luggage in the overhead bins. It did some, but then there came a point where it just stopped. No more 'shadow areas' showing where the rest of the bags went. Certainly not worth buying. Funny they called it the MILLION dollar quest.
 
 
 posted in Them: The Summoning on Sep 26, 11 5:55 PM
It froze up on me too. After the second time (where I had to shut down my computer to get out of the game) I just uninstalled it. Disappointed too. I would have bought this one - and anymore, finding one I want is very rare.
 
 
 posted in Chronicles of Albian: The Magic Convention on Sep 23, 11 12:01 PM
I have the same problem, where the game just freezes. I can move the cursor, but it won't react when I click on an object, and I had to shut my computer down to even be able to exit from it. Seems this has been going on since it came out, and still not fixed. hmmmm..not good. Glad I tried before buying.
 
 
 posted in Amazing Adventures: The Forgotten Dynasty on Jun 15, 11 7:45 AM
I'm in the yurt, and all I have left to do is fix the tear. I see the tear on the 'ceiling' (unless that's what I'm suppose to use to fix the tear). I can't find either a fabric patch or needle or whatever I am suppose to be finding.
 
 
 posted in Public Enemies: Bonnie and Clyde on May 9, 11 8:01 AM
I tried to play the trial version, and after setting the sound, I couldn't get it to leave that page. I finally had to go to window mode just so I could shut it down. After reading some of the reviews, maybe it's not a totally bad thing that I couldn't actually play it.
 
 
 posted in The Dracula Files on Nov 21, 10 1:50 PM
Because it was the $2.99 game, I decided to try it - but as others have said, you can't fast forward, so after 4 minutes (seemed much longer), I deleted it. Never did get to the actual game part. I don't know why some game developers don't understand that some of us just do not care (at all) about the story.
 
 
 posted in King Arthur on Sep 26, 10 7:43 AM
Me too. No hints, no buy. What were they thinking?
 
 
 posted in Cruise Clues: Caribbean Adventure on Apr 29, 10 10:40 AM
biomix wrote:Oh Come on BF! Give us a break! The music is annoying, too easy,
and when I got to the picture puzzles, well, I've been doing them for years and I could not flip the pieces. No instructions or skip, just pause.

Someone didn't put enough effort into this one.



I agree completely about the picture puzzle. If it's something this simple that they didn't catch, what else did they miss (or mess up)? MAYBE if it was $2.99 and even then it would be doubtful.
 
 
 posted in I SPY Mystery on Apr 12, 10 2:41 PM
I also wish I'd tried before I bought it - I wouldn't have bought it. Since it's not just me that doesn't like it, why don't you offer us a credit so we can maybe get one that's not so BAD.
 
 
 posted in Deep Blue Sea on Dec 31, 09 4:14 PM
I'll have to try thaat. Unfortunately, I probably don't have the time right now.
 
 
 posted in Deep Blue Sea on Dec 31, 09 8:42 AM
What is the trick to be able to clear level 29? It's divided into 2 sections. The right side has a small number of things to clear, but the whole bottom row is locked up. I do get that you have to fill the lower right side so that they come up to the locked ones (at least I guess that's how it's done), but I've played this level over and over, and can't make that happen. What's the secret?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator