Posts created by jannicke

 
 
I have my game play set to the casual mode, yet I can't get the hints or the information button for the minigames to work. Has anyone else had this issue or am I doing something wrong?
 
 
 posted in PuppetShow: Lost Town Collector's Edition on Mar 24, 11 10:06 PM
I am near the completion of PuppetShow: Lost Town Collector's Edition. I gave the brooch to the puppet on the bridge which triggered a puzzle. I didn't hit skip but did back out of the puzzle for a minute. When I came back, I was told to give the puppet something to distract it and I can't reactivate the puzzle. The brooch isn't in my inventory and it's not where I picked it up originally . I don't have a piece of crystal to pick up either. Have I gone wrong somewhere or is this a glitch?
 
 
 posted in Drawn: Dark Flight ® Collector's Edition on Sep 6, 10 3:32 PM
I completed the children's wing...put the flower, butterfly, leaf and snowflake into the pop-up book. Went through the violin door, did the scrolls, etc. I backed out temporarily and now I can get find my way back. I keep going to the popup book where I placed the items from the children's wing, but I can't go down the steps, I can't do anything but go in circles. Is there something I am doing wrong or is there a glitch in the game?

Your help would really be appreciated.
jannicke
 
 
I've tried over and over again to get the sealed envelope after restoring the will, but to no avail. I have been dragging the envelope over the paper and nothing happens.
Any suggestions?
 
 
 posted in Drawn: The Painted Tower ™ on Sep 27, 09 1:01 PM
Can someone please tell me how to retrieve the wooden tree that fits in over the mantle. When I go to the treehouse I don't have anything that sparkles, don't see anything that can be picked up. I filled in the clouds, it is raining. I have the hourglass, the birdcage, the teddy bear and the "old letter" left in inventory. I can't push the items off the rug. Where am I going wrong?
 
 
 posted in Drawn: The Painted Tower ™ on Sep 26, 09 5:45 PM
Laura,

My game crashed in the witch doctor painting. I was able to mix some of the potion and then it would die. It also died at the first window shard puzzle. I have traced my crashes to bad memory. Had nothing to do with the game
 
 
 posted in Drawn: The Painted Tower ™ on Sep 17, 09 3:07 PM
Played this game and loved it, but every time I reached the witchdoctor painting, my system would crash. I tried all the recommended fixits, but to no avail. This game simply will not play on my computer. Even spent one whole afternoon online with technical support for my computer to see if it was causing the problem. Has anyone else had this happen? It's a shame because it's a great game with super graphics.
 
 
 posted in Mystery Age: The Imperial Staff on Aug 29, 09 5:22 PM
I have collected the beaker and leaves but still do not find a stand for the beaker or a cauldron. Can someone please help me through this?
 
 
 posted in Mystery Masterpiece: The Moonstone on Aug 2, 09 12:36 PM
Help, I am in Drusilla's room and have found the pamphlet but can't find the ring. Can someone help?
 
 
 posted in Department 42: The Mystery of the Nine on Jul 12, 09 7:29 PM
Help! Mixed blook and saliva and can't seem to finish the cure. Does it have to boil? Argh!!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator