Posts created by Talloulah

 
 
 posted in Pahelika: Revelations on Jul 13, 12 9:36 AM
I've got the hammer, rock and rod but there was no sword.

Have I done something wrong?
 
 
 posted in Pahelika: Revelations on Jul 10, 12 5:09 AM
I've entered the room and taken the hammer but there was no sword, so I can't go any further.

Any ideas?
 
 
 posted in Surface: Mystery of Another World on Mar 19, 12 6:14 AM
I've moved the lenses about to light up the projector but nothing happens. I checked on the walk though and it shows that an Eagle shows up. I checked that I had the lenses the same as the walk through, I did but nothing happens and unless I use the map, I cannot move back from the lenses.

Help!!!
 
 
Where can I find the 8 of spades please?
 
 
 posted in Victorian Mysteries: Woman in White on Oct 18, 10 9:32 AM
I have tried three times to uninstall and install this game and it still isn't working. Help!!!
 
 
 posted in Redrum ™ on Oct 14, 10 5:43 AM
I've got Redrum and Redrum Lies, I would like to know if there are anymore games like this?
 
 
I've gone back to the bedroom but cannot get the hidden object game to start in the wardrobe. What am I doing wrong?
 
 
 posted in Dream Chronicles: The Chosen Child on Jan 26, 10 11:27 AM
sorry, I don't know what you mean by the word puzzles. I'm in the forge but can't reset the planets. Keep looking at the book but it doesn't help. I got this game ages ago but could not go very far, so try other games. Have now gone back to it and I'm still stuck!! Help!!
 
 
 posted in Dream Chronicles: The Chosen Child on Jan 26, 10 6:06 AM
I've tried the combination for the planets at the forge but how do I reset after making a mistake. Even if I quit the game and go back in, it has saved and therefore will not reset.
 
 
 posted in The Fall Trilogy: Chapter 1 on Jan 15, 10 2:59 AM
ansisera wrote:whenever I try to pick up the statuette, I get the message "I'm not a tomb raider" and it wont' let me pick up the statuette. What didn't I do?


Have you had an answer to this yet? I'm stuck there as well, keep trying to get the statue and get the same quote.
 
 
 posted in Dream Chronicles: The Chosen Child on Jan 11, 10 5:22 AM
I've collected the jewels and have placed them in the opening but cannot get the colours to match to open the 3rd nexus gate.

Any ideas?
 
 
 posted in Pahelika: Secret Legends on Jul 18, 09 2:47 PM
What if the fire in the first room has gone out?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator