Posts created by Metamorph

 
 
 posted in Spirit of the Ancient Forest on Jul 6, 17 11:30 PM
That didn't work at all for me. Any other ideas? Might the creator do a fix for this?
 
 
 posted in Kingdom of Aurelia: Mystery of the Poisoned Dagger on Sep 7, 16 7:17 PM
Game keeps freezing and I've only been in two rooms.

To many bugs to bother with. Shame though. The graphics are good and it could be a good game.

Running Windows 10.
 
 
 posted in Sliders and Other Square Jigsaw Puzzles on Apr 5, 16 6:14 PM
I played the "Quest" until time ran out and then I bought it. Great fun! But it seems there are only 5 or 6 different backgrounds. The sales pitch said there were 200.

Where do they hide them? How long does the intro "Quest" last?

Thanks!

Metamorph
 
 
 posted in Fantasy Mosaics 5 on May 23, 15 4:48 PM
I would like to contact the developer to ask about the gorgeous background art.

Thank you!


Metamorph@cox.net
 
 
 posted in Fantasy Mosaics 5 on May 23, 15 4:38 PM
The computer generates random numbers and they don't make a picture. It just keeps going until you get bored or a new game comes out.
 
 
 posted in Mystery Castle: The Mirror's Secret on Nov 27, 14 8:07 PM
I think I'm at the last scene and there is nothing there to help or do. I have medal looking part & no place to put it. The skull on the floor wants something but there are no other somethings to use. Clicking on all the pictures on the wall does nothing. I have the two side skulls lit up, I can't get back to the box on the table, I can't interact with groc or anything else.

Problem? Or extremely rude ending?
 
 
 posted in Jewel Match IV on Aug 14, 14 10:11 PM
When the screen does the flashing like a neon sign gone mad, do Alt Escape and the game will minimize. Then click on the game icon on your taskbar and the flashing will be gone and the game will resume.
This happens randomly and frequently at the mid to higher levels.
 
 
 posted in Amaranthine Voyage: The Tree of Life on Feb 15, 14 12:32 PM
Thank you for posting it so quick. Your walkthroughs are much better than the Collectors Edition guides by far.
 
 
 posted in Amaranthine Voyage: The Living Mountain on Feb 14, 14 7:41 PM
Will there be a fantastic Big Fish walkthrough for this game soon? You do better guides than the games come with.
 
 
 posted in Xango Tango on Dec 21, 13 9:48 AM
Will there ever be a walkthrough for this game? I have been stuck on a level for years now. I'm 2/3 of the way down the path, so my skills aren't to bad, but I even made paper pieces to try to solve it without success. It would really be nice to be able to move on down the road.
 
 
 posted in Imperial Island: Birth of an Empire on Sep 11, 13 7:40 PM
It didn't help at all. I made it to level 104 before I did the reinstall. The first screen I see after the reinstall is a puzzle screen spelling out The End. And the game is still dragging along horridly slow. I understand that there are at least 300 levels. Not much good if it takes a minute for every click. When will this actually be fixed?
 
 
 posted in Eternal Night: Realm of Souls on Jan 19, 11 5:26 PM
It took ten to 15 minutes for every new scene to load. What a shame. It looked like a nice game. Weird, with the movie screens it worked just fine.
 
 
 posted in Jodie Drake and the World in Peril on Jan 19, 11 5:23 PM
My problem is a bit different. It loads and plays fine, but the photos at the top are black. I got tired of clicking on everything possible after 3 HOG screens and uninstalled. At least there wasn't a penalty for random clicking.

 
 
 posted in Haunted Legends: The Queen of Spades on Jan 15, 11 4:35 PM
Ditto. I had less trouble with the unfixed version of the CE. This appears to be a hack out of the CE. They didn't even change the menu pages. I didn't get to try the third fix on the CE as even though I had 10 minutes left, it reinstalled as time expired. It's a shame as it looks like a fun game, but I still have 359 games to get through. Maybe the sloppy game releases is a sign that I need to cancel my membership and give up on any new games.


4mybirds4 wrote:This game is playing sooo S L O W......and freezes constantly. I don't remember having this problem when I played the demo for the CE. Shame, cause I really wanted to get this game.
 
 
 posted in Broken Sword: The Shadow of the Templars on Jan 13, 11 10:37 PM
I downloaded the game and it says my time is up and I haven't even launched it yet. What do I do now?
 
 
 posted in Crossworlds: The Flying City on Jan 8, 11 1:29 PM
Yes please.
 
 
 posted in Tamara the 13th on Jan 4, 11 10:40 AM
MarpleLover wrote:Any problems saving your game?


When I ran out of time on the demo, everything I had done in the second chapter was gone, but the first chapter stayed.
 
 
 posted in Tamara the 13th on Jan 4, 11 9:45 AM
The King asks you for stuff. Use your magic.
 
 
 posted in Tamara the 13th on Jan 4, 11 9:44 AM
I used the hint button a lot. But I thought that the graphics and game play were worth it. There was a lot of back and forth, but being able to "see" the parts that made up the hidden item helped.
 
 
 posted in Once Upon a Farm on Jan 2, 11 10:36 AM
I took one look at the middle sample picture on the download page and felt a warning sign to not even download. Then I looked at the third image and headed straight over here to the forum.

It sounds like I am not the only one offended. Sometimes I think that Big Fish's goal to have a new game every single day is leading to lower standards and less quality control.

Maybe I expect to much, but I've been buying these games since before Big Fish went smart with the prices. (RA was were I started in June of 2007). I can adapt to foreign language conversion errors, but not to obvious stereotyping. I don't ever want to see the Frito Bandito again even if the song was catchy. Yes, we have become overly PC, but getting rid of stereotypes and racism takes determination and follow through to change mindsets.

Big Fish is an International company and should be aware of the games they promote. Maybe we don't need a new game every single day if there aren't quality games to offer.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator