Posts created by STL531

 
 
 posted in Nightmare Adventures: The Witch's Prison on Sep 5, 10 1:19 PM
Cursor problem as well... to me it's pretty obvious that when you have three pages of complaints and multiple other threads about the cursor problems less than a day after releasing a game, it's the game, not the users' computers.

Just to be 100% sure, I updated DirectX and my graphics driver. Didn't help. I tried playing without the custom cursor. I tried playing in full screen vs. wide screen. No matter what I tried, the cursor lags and jumps, particularly when zooming in on interactive screens or when accessing the inventory.

I'm hoping BF will address this and the game creator will come out with some sort of patch or updated version. Otherwise I have no problems asking for a credit refund. But I'm disappointed nonetheless.

(Running on Windows XP Pro, 2.80GHz CPU, 2.5 GB RAM, Direct X 9.0c with NVIDIA 8400 GS graphics card... all well above minimum requirements.)
 
 
 posted in Nightfall Mysteries: Asylum Conspiracy on Jul 30, 10 7:50 PM
Catghost wrote:I couldn't agree more. Totally loved the game. One little point, though: it seems that Curse of the Opera is a sequel to this game. Funny CotO came out much earlier on BFG.... But who cares, I'm going to play CotO right now, I too forgot I got it.


I look at it more like this was a prequel... and I think you're supposed to play it after CotO, because otherwise you would already know the plot twist in CotO.
 
 
 posted in A Gypsy's Tale: The Tower of Secrets on Jul 2, 10 11:35 AM
I completed the game, but I am pretty sure that on the top of the screen at the exterior of the haunted forest cottage it said I still needed to complete a task on that screen. Did anyone else notice that?
 
 
 posted in Cleopatra: A Queen's Destiny on Jun 24, 10 6:54 PM
Okay if you have the tabs in the right place (which you should be able to tell from the walkthrough), the only thing I can think of that might be happening is that you haven't pressed the tab thing a little to the right of the coded rod after you wind the heliolab up. I was confused when I played at first because I thought all you had to do was wind it and when I did nothing happened, but then I randomly clicked on that tab thing and it worked.
 
 
 posted in Cleopatra: A Queen's Destiny on Jun 23, 10 3:04 PM
Okay I'm a bit confused as to what you are trying to do... the calendar in Akkad's workshop isn't in itself a puzzle and you don't need to move any of it (and in fact if you do, you'll have to move it back to its original position to solve the actual puzzle). It's there to help you solve the puzzle of creating the signaling rod for the heliolab (which is on the roof). The Big Fish blog walkthrough has more detailed information and images to help you understand the heliolab puzzle.
 
 
 posted in Cleopatra: A Queen's Destiny on Jun 23, 10 3:01 PM
Some potential mistakes you could make:

1) You have to press the letters in the order they appear in the word (ex: Arrow is Beta, Epsilon, Lambda, Omicron and Sigma... click them in that order).

2) Once the arrow lights up, move on to the first signs it points to... first Pegasus and then Pisces. Don't try to unselect the letters that you used to highlight the arrow--just start spelling the Pegasus word (again, hitting the letters in the correct order) and then Pisces.

3) If you have already used a letter, do NOT click it again... just skip it and move on to the next unique letter.

4) And finally, some of the letters look really similar (such as Alpha and Lambda, which look like an A and an A without the middle line/upside down V, respectively)... make sure you're getting the right letters (and note that the Iota in Pisces has an apostrophe).

Good luck!
 
 
 posted in Cleopatra: A Queen's Destiny on Jun 23, 10 2:50 PM
I just finished the game... overall I thought it was a decent LFG and definitely worth the price.

PROS:
- Nice graphics and cut scenes
- Music (Egypt-themed, I guess, and not too overwhelming)
- Interesting, history-related story-line
- Several unique puzzles that were specific to the genre
- (Specific to Big Fish) Great walkthrough for when you get stuck (and you probably will at least once)

CONS:
- Voice acting (some of it was okay, but Iris's whiny voice was awful and the main character's voice just didn't seem to fit with him for some reason); you can click to skip through most of the dialogue if you read faster than they talk, though
- A few puzzles are repeated more than once during the game

Also, compared to other games from these developers (Mysterious Island games, for example), this one seemed shorter and didn't have as many locations to explore. I also think I would have been confused about the game interface if I hadn't played games by these developers before. But again, I still think it was a game worthy of my time and money.
 
 
 posted in Cleopatra: A Queen's Destiny on Jun 23, 10 2:38 PM
Icky_Etardo wrote:Has anyone successfully installed and played this game? The only reviews are from people who rushed in to say "360 games make me nauseous, I don't play them," so the reviews are from people who haven't actually played the game


I just finished the game... I had two glitches along the way (most of the time the icons on the map wouldn't show up--but I could still click on where they should have been to get around, and once I got some sort of error code that minimized but didn't crash my game and didn't happen again after that), but nothing ridiculous. I have an NVIDIA graphics card, but I haven't downloaded new drivers in at least several months, so if there is a problem with the newest ones I wouldn't know. I'm also running Windows XP Pro if that matters to anyone.
 
 
 posted in Atlantis Evolution on Jun 4, 10 11:09 PM
I've played dozens of large file games from Big Fish, and I have to say this was by far the worst game I think I've ever purchased from BFG. The story line was actually okay, but the controls were confusing and there was waaaaaay too much wandering around in the game's maze-like atmosphere.

The puzzles ranged from either ridiculously easy (Towers of Hanoi "move the disks to the other post" puzzles) to ones that really needed better instructions about what was going on (one mini-game has you flying through the air in some random contraption... apparently you are supposed to collect health crystals and there are a couple different ways to shoot... but I only figured that out by trial and error after dying several times).

The dialogue, while okay, was also frustrating because it isn't always clear if you've finished talking to any particular character. The way you talk to a character basic requires you to click on images/icons that are supposed to represent various topics of conversation. Once you've completed talking about that thing, the icon is grayed out (but I could barely tell the difference). And you can't assume once you've clicked on an icon that you've heard all there is to say on that topic... some of the icons need to be clicked on multiple times to finish the dialogue, which is super annoying.

I got so frustrated after playing for an hour that I quit for about a month. I finally decided to finish it because it was taking up space on my hard drive. And that's my final complaint about this game... it takes up bizarrely massive amounts of hard drive space--like 4 GB. I think it is twice the size of Syberia, which is a superior game in every respect (graphics, music, dialogue, puzzles, etc.).

So basically, if you have lots of extra hard drive space and the patience of a saint, this game might be worth it. Otherwise, I'd say it's a complete waste.
 
 
 posted in Hotel on May 25, 10 8:05 PM
LizzieK wrote:I started having exactly the same problems with games and so i bought a video card on Amazon for $50 with 256MB of memory and installed it in my computer. Before I only have a video chip set on my mother board and it only had 64MB of memory. Now with the new $50 video card all of the new games that I could not play before work great.


Same here... all I had for years was the video chip set that came standard on my 2004 desktop. There were a few games (Lost in the City, for example) that I couldn't play even though I met the listed requirements on the Big Fish site. I eventually got a $50 graphics card at Best Buy with 512MB of memory, and those "unplayable" games work fine now. That's not to say that I haven't ever purchased games with serious glitches before, and I do understand the frustration when something major comes along that you expect testers to have discovered. But if you're having consistent problems with games that many people have no problems with--this game never crashed or did anything weird for me--then if you don't already have a dedicated graphics card, that might be the problem.
 
 
 posted in Hotel on May 24, 10 9:55 PM
Let me start by saying I have played a lot of adventure games (Syberia I and II, pretty much all the Nancy Drews, Return to Mysterious Island I and II, Agatha Christie games... really almost every LFG on Big Fish). Some people have mentioned that this game has the feel of a large file game but note the much smaller file size. That is because it is a smaller game... there are only voice overs in the first minute, the graphics are not state-of-the-art, and the game is much shorter than the ones I mentioned (fewer places to explore, fewer puzzles, fewer objects and people to interact with...). If you buy this game expecting another Syberia, you'll be disappointed.

That being said, this game is still fun, has an interesting story line, and has some great features that will be particularly appreciated by those who are new to adventure games. The optional hints to find interactive areas are very helpful, as is the ability to double-click and walk quickly to places you have already been. The game is pretty user friendly and the tutorial tells you everything you need to know to get around. The puzzles are pretty straightforward and mildly to moderately challenging. For people who get frustrated about having to keep lots of notes during adventure games, you'll enjoy that (except for just one puzzle, I think) all the info is right in the same room as the puzzle.

Basically, this isn't one of the best adventure games I have played, but it was certainly a fun way to spend a few hours, and I don't regret the purchase.
 
 
 posted in Lilly and Sasha: Curse of the Immortals on May 18, 10 8:38 PM
I defeated him without destroying them... I don't know what their purpose was. If I did try to attack them, nothing happened and it just said "Immune." However, I had tried one battle before the time I defeated him and that time I was able to destroy the yellow orb, although attacking the others said "Immune." It was weird. I thought they might be related to when he did the move called "Force of Zahhak" (?) because whatever that did gave him x5 power or something and there were 5 orbs. But I am really not sure.
 
 
 posted in Lilly and Sasha: Curse of the Immortals on May 18, 10 12:11 PM
So I have 13/14 of the runes (the ones you equip, not pictures). I have levels 1 and 2 of everything but Stun (I only have level 1 of that). I really want to finish the game with everything completed, and I'm bummed that I can't figure out where to get that last rune. I've completed every quest except for the last battle and I've returned all the photos, dragon eggs, and souvenirs, so I don't know what I'm missing unless it's rewarded at the last battle.

Also... where can I sell python scales? I looked everywhere in python village and nobody seems to be buying.
 
 
 posted in Lilly and Sasha: Curse of the Immortals on May 17, 10 8:11 PM
Great! I was wondering if I needed to explore the caves some more but I was getting lazy...
 
 
 posted in Lilly and Sasha: Curse of the Immortals on May 17, 10 6:51 PM
So I am pretty sure I am on the last step in the "Find Granny" quest. It says she's somewhere hot, and there was some discussion of a volcano. I searched the town in the volcano (Mt. B something) and Milnerton ("Milnerton is actually a volcano.") but didn't find her, so now I'm stuck. Anyone know what I'm missing?
 
 
 posted in Lilly and Sasha: Curse of the Immortals on May 17, 10 6:41 PM
I had the same problem... fortunately I had a save right before then, so I reloaded the game to reset the puzzle, but it was definitely weird.
 
 
 posted in Chronicles of Mystery: The Scorpio Ritual on Apr 5, 10 10:58 PM
I was pretty disappointed with this game... while visually it was reasonably nice, it lacked in almost every other respect. I would say at least 75% of the game time was dialogue. The rest was mostly inventory-related stuff, with just a few real puzzles thrown in (and none of them are especially difficult or unique). I generally like a much greater ratio of puzzles to dialogue (Nancy Drew games are a great example of balancing the two), but am willing to forgive lots of dialogue if the story is really good. In this case, I didn't think it was nearly good enough to make up for the excessive talking. While it started out somewhat promising, the ending is pretty horrible in terms of explaining/wrapping up several different aspects of the story, and I was thoroughly confused about the motives of many of the main characters. I watched the closing "movie" again to see if I had missed something, but no... the developers just give you a baffling minute to close a game that included hours of dialogue. Not cool.
 
 
 posted in Chronicles of Mystery: The Scorpio Ritual on Apr 5, 10 10:46 PM
ChrisKon wrote:What happened? Anderson is a priest and james is a good guy but gives sylvie a stone from the ark. How is this proof of her theory? I was really confused and somewhat disappointed. Any explanations! Thanks.


James Anderson is one person, so I think you're even more confused than you think. It seems to me that he was a priest that the Vatican had asked to help retrieve the thing so he was lying to Sylvie all along. The guy who gives her the stone is, I think, the archaeologist Henri Simon. Although that means he's the one who tells her to use the keys and release the thing and she seems to respond by saying "Yes, James." But maybe she wasn't saying "Yes, I will" to the speaker but explaining "Yes, this is what needs to be done" to James.

But still, I found it incredibly confusing. I have no idea what she released and whether or not it was a good idea to do so... and if it was a good idea, I don't understand the motives of the church not wanting to be rid of an evil presence or whatever. And since you don't see the tablet that she gets at the end you have no idea what its significance is. I think Henri (?) says it best when he hands Sylvie the tablet... "Who knows????"
 
 
 posted in Island: The Lost Medallion on Mar 31, 10 10:50 PM
I just finished and it took me less than two hours... and I didn't skip any minigames or dialogue or anything, so I find that really short. Also, I thought the storyline was pretty abysmal at times--the dialogue was bland and the characters frequently did things that made no sense to me. Also, I wound up with an extra inventory item somehow that never got used, which was weird. On the plus side, the minigames were relatively unique and the hidden object scenes were above average as well.
 
 
 posted in Vampireville on Mar 15, 10 12:18 PM
I also had this white block appear... I could see three of the four items needed, but the other one (the towel, I think) was just a white block. But since I had already picked up the towel so I knew it was something I needed, I just put it there and it worked. Glad to know it wasn't a problem with my computer, though.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator