Posts created by A1psyko

 
 
 posted in Queen's Quest III: End of Dawn Collector's Edition on Apr 11, 17 1:30 PM
I also agree with some of dancemoms comments. I play expert levels and usually custom options in my games. This is a slow game, sometimes not intuitive and sort of a "herky jerky" scene. Sometimes you can move on from some of the dialog and sometimes not. I do not turn on my speakers so don't know about sound. May be a game for regular purchase but in my opinion, not necessarily worth a collectors price. Sorry not a purchase for me.
 
 
 posted in Nostradamus: The Four Horseman of the Apocalypse on Mar 28, 17 6:59 AM
still looking for the mirror
 
 
 posted in The Legacy: Forgotten Gates Collector's Edition on Mar 11, 17 7:53 AM
I agree with the other posts. This is a fun game (based on demo only). I like the colorful scenes, some new takes on mini challenges. I will purchase.
 
 
 posted in The Legacy: Forgotten Gates Collector's Edition on Mar 11, 17 7:50 AM
[Removed by Moderator]
 
 
 posted in The Legacy: Forgotten Gates Collector's Edition on Mar 11, 17 7:48 AM
[Removed by Moderator]
 
 
 posted in Lost Grimoires: Stolen Kingdom on Mar 6, 17 5:55 AM
Same here, Windows 10 - PC - Access Violation, blank screen. Tried your recommendations, no help.
 
 
 posted in Subliminal Realms: Call of Atis Collector's Edition on Feb 20, 17 8:21 AM
I have the same issues, PC, Windows 10. I have deleted 3 times, taken all steps recommended by others and still locks up computer and have to restart.
 
 
 posted in Subliminal Realms: Call of Atis Collector's Edition on Feb 19, 17 9:01 PM
Thank you for your response. I tried the steps you recommended. Uninstalled and reinstalled, etc. This time however it locked my computer up and had to reboot. Sadly I will have to delete this game and move on.
 
 
 posted in Subliminal Realms: Call of Atis Collector's Edition on Feb 19, 17 5:45 AM
I am having the same issues as the others in this post. Was this game not tested before putting it out there? I am using a PC-Windows 10. Also had to use task manager to get out of the game. Game is also very slow to respond to selections, can't pick up the little square things during the game. Disappointing that these issues were ignored during any testing before presenting to BFG users.
 
 
 posted in Redemption Cemetery: Night Terrors Collector's Edition on Feb 14, 17 9:50 AM
Where is the Grave Racer game? I saw a post that says it is for your phone. I didn't purchase this for my phone, I purchased for the computer. Is that the only option? If so it is very disappointing.
 
 
 posted in Redemption Cemetery: Night Terrors Collector's Edition on Feb 14, 17 9:46 AM
I agree with the comments posted so far. Only thing I will add is the Grave Racer. I can't find it on the game I just purchased so I went to the forum to find out it is on your phone. I didn't purchase the game for my phone and am very disappointed if this is the only option. I don't link my games to my phone for a reason and do not like feeling forced to put it there to finish a game. Is this the only option for the Grave Racer portion?
 
 
 posted in Redemption Cemetery: Night Terrors Collector's Edition on Feb 14, 17 9:42 AM
I don't want to play it on my phone, is there not an option inside the game I just purchased?

NEW NOTE: Thank you for the clarification, my mistake. As soon as I opened the game and selected the phone I found the grave racer part of the game.
 
 
 posted in PuppetShow: Bloody Rosie Collector's Edition on Nov 17, 16 7:26 AM
I am having the same issue. When restoring the book the doll is sitting on some of the items. The Scroll that contains the items is not along the bottom of the frame it is shortened to the middle with no way to scroll across.
 
 
I am running Windows 10. I purchased the game. There are issues I ran into while playing. Collecting fruit in baskets. I could only play and select fruit in the middle or top if the screen. The bottom 3 rows and columns to the right and left were frozen. Lighting the candle in the beginning, could light it but could not move it through the requested motions. Candle would not move but a small bit and it would drop from my "hand" if I moved it to the place where needed. These are glitches within the game. Please fix and send a patch. I really like this game, hate that it is having problems.
 
 
Why are there skin care advertisements on the forum pages?
 
 
 posted in Grim Legends 3: The Dark City Collector's Edition on Jul 17, 16 3:45 AM
Running windows 10. Same tech error for me too. I removed and reloaded, restarted my computer, same error.
 
 
 posted in Puzzle Galaxies on Jul 15, 16 6:19 AM
Same here. I can download the game, set up my name. It goes to the first screen where it explains how to play the game. I select OK, get to the third instructions screen and the game locks up. I can't select OK, Main Menu, Close etc. I go to my task manager to close the game and the game keeps popping up but it is locked up. Not my computer, using windows 10, it is the game. I uninstalled. Would be nice if the game would play, was interested but now it is a no go for me. Won't play or even retry games that are not properly tested which seems to be the case when they lock up from the get go. Seems lot of others are having the same problem. Very disappointing.
 
 
magmitch wrote:
juttawalker wrote:
wildthing_57 wrote:got to a level its froze cant go any further shut it down started it back up same issues cant continue game at all
Dear friend had the same problem then you and started a new profile and it works give it a try
I started a new profile and I am able to move on. Somehow I came back to the point where I should not have been able to progress to the ship with the octopus and was better equipped to move on.


I tried uninstalling, reinstalled and still frozen. Can't move on. Also tried a new profile. Still locked up. Any other suggestions. this is frustrating.
 
 
 posted in World's Greatest Places Mosaics on Jun 29, 16 8:42 AM
I play these games over and over and over. I like the challenge. However, after playing the game twice I find I can play it the third time under a different player name and deleting all previous player names and starting over that it is not saving my game and starts over every time. It was working fine, now it is messing up. Very frustrating. I have all the World's Greatest and Fantasy Mosaics and this is the first time I have run into this problem. Please tell me how to fix so I can keep playing
 
 
A1psyko wrote:I played the entire game without any issues. I am playing for a second time. Got to the bonus section and trying to go into the office but it is locked up. I shut down, tried rebooting, same issue-still locked. I reopened the game-went to the main menu and changed to easy and still locked. Not my computer, not my software.


Ok an addition to my earlier issue. I deleted the game, reinstalled and tried again. Still locked in the same spot on the bonus round. Please send a fix. This is frustrating.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator