Posts created by paco12348

 
 
 posted in Heroes of Hellas 3: Athens on Mar 13, 12 6:30 PM
I purchased Deep blue Sea and loved so invested in other match 3 games. I abolutely hate games that give the hint and one can click until one is blind and not hit the spot. THAT is what happens in this game. The hint goes to the head of the Octopus. I've covered the head, around the head and extended the circle with clicks and can't find one frigging thing.
I HATE GAMES LIKE THIS. I will never purchased from this game maker again. Would love to have more like Deep Blue Sea.
 
 
 posted in Midnight Mysteries: Haunted Houdini Deluxe on Feb 14, 12 10:10 AM
I'm in the house, upstairs searching the scene where one is wishing to see a Houdini performance. The raven only flies across the scene when one uses a hint to find the paintbrush. Can anyone tell me where to find the paintbrush. The raven hint is useless.
 
 
 posted in Midnight Mysteries: Haunted Houdini Deluxe on Feb 14, 12 10:05 AM
I'm in the beginning, searching the scene upstairs in the house where I supposedly will get to see Houdini do a trick. The paint brush is the only item I can't find. Used the raven hint twice and all it does is fly across the room and exit the scene, then fly back. I've clicked and searched all along it's route and can't find the paint brush. I hate so called hints like that which are no hint at all. Can anyone tell me where the paintbrush is before I dump the game?
 
 
 posted in Echoes of the Past: The Citadels of Time on Feb 3, 12 4:56 PM
The solution is in the journal from the scrap but it's not working. I've tried dozens of times and it still won't work.
 
 
 posted in Christmasville on Dec 21, 11 4:05 PM
This puzzle is horrible. I've worked it 4 times and everything matches but it won't take it. There no way to skip it. I HATE THIS TYPE OF GAME. Just another one to unistall and swear to never purchase another one from that game maker.
 
 
 posted in Mushroom Age on Nov 25, 11 7:43 AM
I purchased this game when it first came out and loved it. I would like to have more like it. Seeing i come up again I just wanted to say it's well worth the purchase and I think I'll just go play it again for the pleasure I received the first time.
I know it's been a long time since I played the game but sure don't recall some of the things I've been reading about it. Don't let children play it? My Grandson played it with me and I've very careful about what he plays and sees on TV. I'll play it again to see if I can determine what in the world some are referring to.
 
 
 posted in The Agency of Anomalies: Mystic Hospital on May 14, 11 9:16 AM
I'd like to see games made from some of the great fantasy books.
 
 
 posted in Empress of the Deep 2: Song of the Blue Whale on May 9, 11 7:29 PM
I hate this game. I should have listened to some of the reviews.
The graphics are gorgeous. The hint system makes me want to throw the computer out the window. You can run your legs off trying take the next step in the process and all the hint is good for is to run you some more. It's ridiculous.
 
 
 posted in The Fool on Apr 3, 11 1:47 PM
That's exactly where it was. Thanks so much. I had worn out my shoes looking for it.
 
 
 posted in The Fool on Apr 3, 11 7:38 AM
The walkthrough says there are 8 iron letters to find. I already have 11 and it says I still don't have enough. There's no place to else to look. Any suggestions?
 
 
 posted in Sarah Maribu and the Lost World on Mar 13, 11 5:49 AM
I loved this game and had no issues with it during play. It was challenging but not too hard. I had to use my noodle. I appreciated it because it was logical. I could see what needed to be done, just had to figure out how to do it. It's certainly worth the DD and in my humble opinion worth what I paid for it which was more than the DD.
 
 
 posted in Lost Realms: The Curse of Babylon on Feb 2, 11 9:24 AM
I have the headless statue, the pendant with the blue stone in it and a lit torch. I have no head for the statue and the curtains won't catch fire from the torch. This is the only active spot left and I can't finish it. Any suggestions?
 
 
 posted in Awakening: Moonfell Wood on Dec 29, 10 5:04 PM
I put the moon/sun emblem on the door and finally had to go to the blog. No matter where I push the door will not open. Is this a glitch?
 
 
 posted in Mystery Age: The Dark Priests on Nov 13, 10 3:24 PM
This is a wonderful game. I just completed and have had hours of enjoyment. Graphics are beautiful and I won't even complain about the few objects hard to find. Very few. I enjoy finding items to be used in other scenes. Kudos to the game makers.
 
 
 posted in Haunted Hotel: Lonely Dream on Sep 30, 10 6:12 AM
satexasgirl wrote: I've encountered thunder storms in the winter-where I live it doesn't always get that cold, but to my knowledge thunder and snow don't coexist.
============
Couldn't pass this up. Here in OK we occasionally have what we call thunder snow in the winter because it truly does thunder while snowing. To my way of thinking, it's simply a thunderstorm but the lower air is just the right temp to make snow.

Now I have to download the game just to see how they handled the thunder snow. )
 
 
 posted in The Seawise Chronicles: Untamed Legacy on Sep 16, 10 6:43 PM
I'm sick and tired of hunting. The walkthrough says use a shovel and tells where but the shovel is not available to me at the place the walkthrough says. This is one game I wish I'd never bought. Thumbs down to the gamemakers. Can't find all the pieces. They are either too small or it's a wild goose chase. The *&^&* clue keeps pointing to the pieces in the water a blind person could see but can't get too. Dump, dump, this game goes to the dump.
 
 
 posted in Shaolin Mystery: Tale of the Jade Dragon Staff on Aug 22, 10 3:59 PM
I seldom write in about a game but just had to give my input on this one. It was a tremendous game and I wish there were more like it. It wasn't too easy or too hard. Just right.
 
 
 posted in Skymist - The Lost Spirit Stones on Jul 6, 10 3:46 AM
The strangest thing happened. I used the barrel tap to get the half full mug. Took it off with the wench. Hadn't read the walkthrough. Finally put it back on the same barrel but now, after looking at the walkthrough, there's no wrench to take it off. It's not back in the scene where I found it and I can't progress without using the tap on the other barrel. The walkthrough doesn't speak to this so is it a technical issue?
 
 
 posted in Journey of Hope on Jun 28, 10 6:45 AM
Nice game for kids, unless they become bored easily. Graphics are great. I don't like the pulsing item before it's removed, that delays clicking on another easily found item. Games are solved for you. There's no challenge for adults.
 
 
 posted in Kate Arrow: Deserted Wood on Jun 26, 10 7:04 AM
I might like this game but right off the bat I can't back out of a scene even though it says I should look elsewhere. I'm putting in numbers on the computer to open the email. The first time i back out fine then I found the scrap of paper and returned. Now, I can't back out at all. One glitch is enough for me.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator