Posts created by Sablesshadow

 
 
 posted in Fatal Passion: Art Prison Collector's Edition on Feb 1, 14 9:46 AM
Thank you, ganonsbane, I also copied your reply so I can refer to it in future.
 
 
I just realized that once you push a button, you have to click on the lock button to see if the number on the button is correct. If it's correct it'll turn green. If not correct, try the next number, click on the lock button above, and repeat until each # turns green.
 
 
 posted in The Far Kingdoms on Nov 19, 13 8:19 AM
thistle809 wrote:Yet another game with no walkthrough. If BFG is trying to alienate people, this is a great strategy. I still use my philosophy of: No walkthrough = No purchase. I refuse to even play the demo, if a game has no walkthrough at any of our "usual and safe sites" (including the one with the orange cube logo). A walkthrough can be helpful for a lot of reasons. Sometimes the hint system is not as clear as it should be and we just need a nudge in the right direction to get back on the right path; even if we post a problem in a forum, we may not get an answer (after the first week or so following the release of a game, not too many people are checking the forums); it may help us determine if we have a technical issue or are simply stuck; many of us like to see how far we are after we finish the demo because we cannot afford to spend the money for a game if we are nearly finished. If it is too much trouble for to provide a walkthrough, it is too much trouble for me to spend the very little money I have with them.


 
 
 posted in Nevertales: The Beauty Within Collector's Edition on Nov 2, 13 5:30 PM
What a terrific game this is! As a matter of fact, it's the only game where I actually went out of my way to find all the hidden roses and collectibles. Although I know I played for hours, the time just flew right by.

I plan to play this game as soon as I can forget about it, just for the sheer enjoyment!
 
 
 posted in Nevertales: The Beauty Within Collector's Edition on Oct 26, 13 7:56 AM
Followed the instructions in the Salary Guide and it didn't work. Came out of the game and reentered, and it worked perfectly.

Thank goodness I didn't have to unload and then reload!

Try coming out of the game and going right back in.
 
 
 posted in Jane Austen's: Estate of Affairs on Sep 11, 13 9:16 AM
LizzieK wrote:
Giliraz wrote:in fact there is no need for a WT, the hint button works fine...

Some players like to take a look at the walkthrough to judge how long a game may be before they purchase it. They play the demo and then see how far they have gotten in the game by looking at the WT.


Thanks, LizzieK, cause there are some players, like me, who can't find their way out of a paper bag, and need a walkthrough. I can get turned around in a closet, lol.
 
 
 posted in House of 1000 Doors: Serpent Flame on Jul 25, 13 7:01 AM
Don't know if this is a technical glitch or not, but I was happily playing this game, and abruptly got thrown out and my laptop closed down. Had to go back in "safe" mode and when I got back to the game, got the message (something like the game was corrupted and the player would be discontinued).

Going in again under a different name, luckily wasn't too far into the game.

Figured I should post this here in case anyone else experiences this.
 
 
 posted in Haunted Legends: The Curse of Vox on Jul 23, 13 10:40 AM
Crystaj, found the elusive M.

It's in the sack in front of the two statues near the water. Walk down one from the crypt/carriage area, and you'll see the sack.

Slash the sack with the sickle and the M ring will fall out,

Good luck,
Sable
 
 
 posted in Haunted Legends: The Curse of Vox on Jul 23, 13 10:34 AM
Thank you, BFGJunkie. I didn't realize you had to access the ring, and then look over to the right of the glowing characters. Was pulling out my hair, lol.

Now I'm on the track of the elusive M. Loving this game.
 
 
 posted in Dreamscapes: The Sandman on Mar 13, 13 12:52 PM
OMG, never mind! Again, I was sucked into a site where I thought the walkthrough would be present.

Not so. I guess I'll just have to wait until there's a walkthrough, or wait until all the puzzles are solved.
 
 
 posted in Dreamscapes: The Sandman on Mar 13, 13 12:46 PM
For those who are game-challenged as I am, there is a walkthrough available if you Google " Dreamscapes: the Sandman."

That's a happy thing for me!
 
 
 posted in The Lake House: Children of Silence on Jan 23, 13 7:20 AM
I found a walkthrough for this game by typing "Walkthrough: (then the name of the game) into my search engine (Google) and found a walkthrough that will help.

Otherwise, no buy for me. Been stuck too often, lol.
 
 
 posted in Fallen: The Flowers of Evil on Jan 7, 13 8:14 AM
If you Google the word "walkthrough:" and "Fallen: The Flowers of Evil" you can find a walkthrough.

Good thing, otherwise I wouldn't buy this game, lol.
 
 
 posted in King Oddball on Dec 31, 12 7:28 AM
I'm thinking Santa and his merry elves have left the building, and the TGT is from Scrooge - or the Grinch who's stealing New Year's, lol.
 
 
 posted in Cruel Games: Red Riding Hood on Nov 22, 12 7:33 AM
Not sure you can change the difficulty in this game. The Options screen only shows the following:

Music Volume
Sound FX Volume
Full Screen
Wide Screen
Custom Cursors.

However, the walkthrough is really good in case you get stuck.

Sorry,
Sable
 
 
 posted in Botanica: Into the Unknown Collector's Edition on Nov 1, 12 7:04 AM
Thanks, avsutton, but I guess patience isn't my strong point. I did finish the game and enjoyed it; maybe I'll go back at some later date and see if I can wrestle with that puzzle using your excellent directions.

Purplesweet, hope you've had more luck than I.
 
 
 posted in Botanica: Into the Unknown Collector's Edition on Oct 29, 12 11:33 AM
Uninstall and reinstall didn't work for me. The colors on the top row aren't correct, no matter how many times I hit the outer button.

Guess this puzzle's a skip for me.
 
 
 posted in Botanica: Into the Unknown Collector's Edition on Oct 29, 12 10:59 AM
I'm also stuck, purplesweet. No matter how often I click the outer button on the top row, it won't change to the correct colors. The bottom row changes fine.

Think I'll uninstall and reinstall and see if that helps. If it does, I'll come back here and tell you.
 
 
 posted in Paris 1925 on Oct 11, 12 1:02 PM
So glad I didn't buy this game.

And many thanks to those who gave it a very critical review. A magnifying glass would not be enough to save this dismal game!
 
 
 posted in Where Angels Cry on Oct 8, 12 11:32 AM
Minesita,

Sorry, I was referring to the wrong puzzle.

I usually love slider puzzles, but this one has me stumped also.

If I ever get the answer, I'll post it here. Sorry for the confusion.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator