Posts created by gladysschmuck

 
 
I'm playing casual also. Interesting what you said about the dream catcher net vanishing. It hasn't for me. The only item remaining on my list is the base. I've picked up the bead. And no cursor turning into a hand.

I've tried changing modes but same problem. Now I'm thinking this is some type of glitch unique to my computer...........which makes no sense at all. What a mystery.

I think I'm forced to give up on this game. Just can't think of anything else to do.
 
 
Thanks again. Yep, that's what I keep trying to pick up. It's brown colored and has rather faint black markings and looks just like the other discs on the box. It's right above the rim of the dream catcher and, as you said, under the clay vase. It just will not pick up. I've clicked on every part of it and have clicked on every disc behind the dream catcher. Like you, I've clicked on all those other items to no avail. Must not be a general game error or it would have been a problem for more than just me. But it's really frustrating.
 
 
Thanks so much ganonsbane. The one in the dream catcher is the one I'm having problems with. I clicked on it repeatedly but couldn't pick it up. That's why I figured it wasn't one of the discs. It seems pretty obvious that it's a disc because of the markings on it. But I still can't pick it up. Have clicked all over the thing. It won't budge. Is there any secret to picking it up? Sheeeesssssshhhhhhhhh. Ridiculous.
 
 
...last disc to open the drawer. Hint says go back to room. I go back and hint says to go to the HOP. SG is no help because it doesn't show where HOP items are. Anyone know where the last danged disc is?
 
 
 posted in Crafting Story on Jan 5, 15 8:26 AM
2 minutes of my life I'll never get back. What a waste of time and effort this "game" is. Everyone else said it too - lousy graphics, no instructions, no obvious goals. Bad and boring.
 
 
 posted in Clover Tale: The Magic Valley on Dec 31, 14 6:35 AM
Maybe it's just me but the game keeps claiming I'm out of moves when there are clearly moves available. I quit when the message came up 3 times in a row after I made a move when there were "no more moves". Only played about 6 minutes. Couple the "no more moves" messages ad nauseum with the fact that this appears to be just another match 3 with no frills and I'm done.

I do not recommend this game.
 
 
 posted in Manor Memoirs Collector's Edition on Aug 23, 14 7:37 AM
Yes, I'm still running XP on the drive I use for games so that may be the problem but the sound is skritchy and skippy and totally unacceptable. I've uninstalled and reinstalled to no avail. Do I need to submit a Dr. Felix analysis?
 
 
 posted in Haunted Manor: Painted Beauties Collector's Edition on May 29, 14 1:50 PM
I bought this before I realized the map is just that, a map. No assistance at all. That makes this game a big time loser in my book. So sorry I bought the game because I do not want to encourage lazy developers to take a step back in game technology.

I dislike morphing objects but that's just me.

Turned the volume almost all the way down so I didn't hear that stupid giggle. I like cutsie things but am not much a fan of monotony.
 
 
 posted in Chronicles of Albian 2: The Wizbury School of Magic on May 26, 13 9:20 AM
Same issue here. Play a short while then serial lockups. Tried everything including installing and uninstalling. Only way out of the game is the three finger salute. Developers have screwed up on this one. Hope there is a fix soon.
 
 
 posted in Criminal Minds on May 7, 13 9:49 AM
Never mind. I finally got it to work. I do not like objects that are recalcitrant. The developers of this game have certainly not impressed me. I bought it because I had a spare credit and was out of things to play.
 
 
 posted in Criminal Minds on May 6, 13 10:07 AM
Have clicked the stupid screwdriver all over the grate, the scarf, & each of the 4 screws and can't get it to function. Anyone have any hints on this? Thanks.
 
 
 posted in Christmas Stories: Nutcracker Collector's Edition on Dec 4, 12 2:50 PM
This is bar none the VERY BEST Big Fish game I have ever played!!!

Love, love, love the ability to adjust the screen brightness!!! Most games are far too dark for my already rather dark monitor. Wish all games did this.

Love the map that not only takes you to a location but indicates which locations have something to be done!

Love the colors and artwork!

Thanks so much, developers. This one is a huge 2 thumbs up for me.
 
 
 posted in Murder, She Wrote 2: Return to Cabot Cove on Nov 27, 12 7:49 AM
Thanks for your response. I printed out how you dealt with it, tried it over and over and over - leaving then coming back and posing as you did - and still can't get the box to open. Grrrrrrrrrrrrrrrrrrrrrrrrrr. I do not understand why it doesn't work for me. I'm thinking this is a glitch in the game but why it seems to perform differently for differing gamers I cannot fathom. Guess I'm on to another game.
 
 
 posted in Murder, She Wrote 2: Return to Cabot Cove on Nov 26, 12 1:33 PM
I've tried everything ya'll have suggested about a hundred times but still can't get into that box. This is beyond frustrating. Guess I'll have to abandon this game. Have I mentioned this is beyond frustrating?? Shame on you, developers.
 
 
 posted in Lost in Night on Oct 20, 12 8:51 AM
I too deleted and reinstalled the game to no avail. Still can't get full window screen. Makes the game unplayable.
 
 
 posted in Lost in Night on Oct 20, 12 8:23 AM
Like another poster I have found that once one has reduced screen size it can't be returned to full window mode. I too tried alt-F to no avail.

Is there an update to fix this issue?

Thanks
 
 
 posted in Awakening: The Skyward Castle Collector's Edition on Sep 6, 12 3:32 PM
I bought this game without even sampling it because I've played and enjoyed the other Awakening games.

Maybe everyone else loved this game but I found it the most illogical and irritating game I've ever played. Puzzles made no sense, goals were obscure, things were to be put together or used in ways that made absolutely no sense at all. This game is just plain stupid and frustrating.
 
 
 posted in Big Kahuna Reef 3 on Aug 1, 12 2:32 PM
Despite having updated my video card, and downloaded the suggested Microsoft update (can't remember what it was now but I did it based on the tech fixes for crashing) this game has crashed over and over and over and over and over. I am not impressed. Interesting when a program locks up so badly that cntl-alt-del won't fix it. I'm having to use a combination of esc and cnt-alt-del repeatedly to get out of the program.

This developer needs to go back to the virtual drawing board before bringing out another game.
 
 
 posted in Grim Tales: The Wishes Collector's Edition on Jul 17, 12 7:06 AM
Guess I'm in the minority. I've found this to be a frustratingly difficult game with a number of totally illogical solutions to puzzles. I usually like Elephant Games - not this one.
 
 
 posted in Grim Tales: The Wishes Collector's Edition on Jul 17, 12 7:02 AM
Never mind. After not being in my inventory it suddenly appeared there when I revisited the bathroom............where there was nothing to do because I had already taken everything from under the tub. Weird.

I've found this to be a frustrating game with a number of illogical solutions to puzzles.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator