Posts created by walkswithdogs

 
 
I may be doing something wrong or it just may be a glitch, but I earned the 12 stars by doing the bonus HOP's and mini-games, I watched the 4 available movies but I still cannot access the "?" for additional character dossiers. When I press the "?" I am told I need 12 stars (which I have) to open it and an additional 6 stars which I can't seem to find out how to earn. Thanks for any help.
 
 
 posted in Phantasmat: The Endless Night Collector's Edition on Jan 12, 15 12:53 PM
Yeah, I think this is a glitch. I've also clicked all over the car and it won't cough up the ball. Thanks.
 
 
 posted in Phantasmat: The Endless Night Collector's Edition on Jan 12, 15 2:26 AM
I also found all the souvenirs except one, and unfortunately its not any of the ones already posted. I cannot find the brown soccer ball that's supposed to be located outside the amusement park where the fire truck is parked. I had my cursor all over that page and got no gears nor grabby little hands. Also, I cannot see the tell tale sparkle that leads one to the hidden souvenir. Can anybody help me?
 
 
 posted in Grim Tales: Color of Fright Collector's Edition on Nov 19, 14 7:59 AM
You may have a glitch. I know I had to break it using the lighter colored links. If you've tried that already, I don't know. Good luck.
 
 
 posted in Evil Pumpkin: The Lost Halloween on Nov 7, 14 11:51 PM
You have to keep trying colors until game won't let you change the color any more then it is correct color. You have to get all the torches. I wandered around a bit before I found one I missed. When all torches are made the right color game will go to a cut scene where you meet your father.
 
 
 posted in Queen's Quest: Tower of Darkness on Nov 6, 14 9:49 PM
It's been a little while since I played but I remember a few things. First, you should have picked up a before you got to the bush with the box. You need to find all the stained glass pieces and you will get a metal rod to open the box on the bench and use one of the fire amulets to burn the door with the broken key. Sorry, that's all I can remember but it might get you going again.
 
 
If you just place the planets according to the SG, it won't work. You have to move them all over the place. It's not easy to do. Some stars need the movement of multiple planets to get them in place. Then you have to figure out which planets can then be moved to move other stars without disrupting the stars already in place. This puzzle was a big pain but it can be done. It just takes a long time. Hope they don't do another one like this again. Now when you're done, the planets will be in the positions indicated by the SG.
 
 
 posted in Mystery Trackers: Silent Hollow Collector's Edition on Jul 23, 13 4:42 PM
Hi. I'm back. I was hitting an extra star, that's why it wasn't working. Working from left to right, when you reach the top of the hump there are two stars close together. After you connect them, skip the next star and go to the one after it and continue.
 
 
 posted in Mystery Trackers: Silent Hollow Collector's Edition on Jul 23, 13 4:35 PM
I'm having the same trouble with the same constellation. Tried connecting the stars many different ways but it always stopped before I could connect the last line. A bit frustrating.
 
 
 posted in Namariel Legends: Iron Lord on Jun 5, 13 5:42 AM
I went back and tried again and finally figured it out. I had already collected the clamp when I traveled across the top of the tank to the far end. When my bathysphere traveled the distance, it picked up the clamp. After that, you have to travel across the bottom of the tank to place the clamp on the hose. Then across the top once again. You will drop to the bottom when you reach the clamped aerator and reach your destination. I am greatly enjoying this game. I hope everyone else is also.
 
 
 posted in Namariel Legends: Iron Lord on Jun 5, 13 5:19 AM
I'm in the third section of the aquarium attempting to get the key card. I need to punch off the air supply to the last aerator with a red clamp but I can't seem to find it.
 
 
 posted in Dreamland on Jun 9, 11 4:48 AM
Finally! A great game. I loved this game and couldn't wait for my one hour trial to end so I could buy it. This game steps out of the predictable formula seen in most Adventure/Hidden Object games. The HOGS were nice and the scenes were varied. There was a lot of jumping around to the different areas but I loved the way you could use the hint button to get to the scene you needed to do next. I would highly recommend this game. Just finished the game, and after I do some greatly needed housework, will be playing it again. Innovative and wonderfully executed.
 
 
Thank you all for the heads-up. I only played the demo and thought there was little challenge but hoped it might get better past the demo point. From your posts, I see there is little to recommend this game so I won't be purchasing it. Loved most of the others, though. It's sad when developers think they can ride on the coat tails of previous successes.
 
 
 posted in Fallen Shadows on Apr 23, 11 4:51 AM
I didn't like this game at all. It seems the developers are too enamored with their graphics and didn't put much thought into the game. Far too much time on unwanted cut scenes that didn't add anything to the story. Didn't get to play much because it just stopped and took me back to the main menu but one thing happened that I didn't like. At the beginning of the game, I was in the bedroom and tried to go back downstairs and was told all the downstairs doors were locked. This came as a surprise. Usually an action like the doors locking is made known to the player at the time of the action. I also thought it was very slow. Wish I had been able to play longer to make a more adequate judgement of this game. As it stands, from what I was able to see, I am not going to purchase it.
 
 
 posted in Epic Adventures: Cursed Onboard on Mar 12, 11 12:39 AM
I didn't like this game at all. Sorry I bought it. Too simplistic. I am used to the newer games where there is more interaction per scene. This one just had one or two actions per "room". I rather enjoy exploring a scene and finding numerous items or places to interact with. And this may be just me, but I had trouble locating objects in the **** scenes. I did like that there were many **** scenes, though.
 
 
 posted in Epic Adventures: Cursed Onboard on Mar 12, 11 12:29 AM
I couldn't move the dials in the telescope. Again, they would just move a little bit at a time then jump around.
 
 
 posted in Lost City of Z: Special Edition on Sep 18, 09 7:15 AM
Im in the cave trying to pick up keys. I can see the last two but cannot pick them up. I tried clicking slow, then fast (and get the random clicking warning), I've used hints but still cannot pick them up. I thought these games were tested before being marketed. Very disappointed.
 
 
 posted in Lost City of Z: Special Edition on Sep 18, 09 7:13 AM
cesse47 wrote:The game had good potential. But, I won't be purchasing this one. I find the "don't grab random things" message highly annoying ... mainly because I'm clicking on the right thing and it just won't pickup. If it was infrequent, I could ignore it ... much, much too frequent.
 
 
 posted in Delaware St. John - The Curse of Midnight Manor on Aug 9, 09 2:38 AM
I was disappointed with this game. I felt I was held captive to the credits and long intro. Most games let you skip the intros and hold the credits until the end of the game where you can skip over them. Seemed it took 10 minutes to actually get to the game. And there is no menu bar (at least to the point in the game I got to) to exit.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator