Posts created by giddiup101

 
 
Merry for CE's. It's a BOGO. Still good.. just used it. 12/25 @ 8:32pm EST.


Merry Christmas everyone!!!
 
 
 posted in Surface: Game of Gods Collector's Edition on Nov 20, 14 7:05 AM
Thanks for the info Catbag! I appreciate knowing how many chapters there are in a game.

Happy gaming!!
 
 
Thanks for the code.. I just used it to get $4 off. 1pm EST
 
 
 posted in Echoes of the Past: Wolf Healer Collector's Edition on Oct 19, 14 11:49 AM
I enjoyed playing the game but found it to be too short. I wish I had waited for the SE, but that's just my personal opinion.

Happy Gaming..
 
 
Poof11 wrote:All of us fish who have purchased this game have been patiently since September 04th for an update for this game. I have been checking everyday and nothing except a note that it's being worked on. We have not been given any real information as to when it can be expected or should we all just apply for a refund? It would be nice if some kind Fish from BFG would either begin a new thread about where this game stands or how much longer will we have to wait. I was really enjoying the game prior to all the freezing issues. I can't believe it is still being sold even though you are aware that the game is pretty much unplayable as is. Thank you and hope to hear something soon.


Thank you!!. This is what I want to know as well.
 
 
Did they ever fix the freezing issue? It's Sept 23rd, the game was released Sept 7th.

I REFUSE to purchase this game if the freezing is still happening.
 
 
Just used in Virginia EST 10:20 am 9/18...coupon still good !!!!
 
 
 posted in Shrouded Tales: The Spellbound Land Collector's Edition on Sep 13, 14 11:14 AM
Howatch wrote:
giddiup101 wrote:I'm disappointed because once I downloaded the game it popped up free trial is over. I never even got to play the demo to see if I like it.


Uninstall and reinstall the game - this usually fixes that error message.


Thanks for the info.. I ended up buying the game hoping I'll like it since it was on sale.

I'll take your advice next time that error pops up through.. thanks
 
 
 posted in Shrouded Tales: The Spellbound Land Collector's Edition on Sep 13, 14 10:48 AM
I'm disappointed because once I downloaded the game it popped up free trial is over. I never even got to play the demo to see if I like it.
 
 
 posted in Shrouded Tales: The Spellbound Land Collector's Edition on Sep 13, 14 10:45 AM
addictedtofish wrote:Well I've heard other members complaining of this but it's a first for me - my free trail has ended on upload, without even having a chance to try it!!


Same thing happened with me.. I never got a chance to even try it!!!
 
 
 posted in Maestro: Dark Talent Collector's Edition on Sep 11, 14 3:03 PM
Thanks for the info! I will definitely be waiting for the SE on this one. It's too much money for too short a game.

Happy Gaming,,,
 
 
Yep.. same thing happening with me. Keeps Freezing!! Too bad, I was going to buy it but too many glitches.. I'm playing with windows 8.1.
 
 
 posted in Warlock: The Curse of the Shaman on Aug 11, 14 10:04 PM
I normally just demo the game and play it as though I bought it. I put in my game name as I normally do and if I end up buying the game, I pick up where I left off. I never start over, unless the game forces me to (which I hate by the way).

It never even occurred to me to start the game from the beginning just because I bought it.
 
 
 posted in Mayan Prophecies: Blood Moon Collector's Edition on Aug 9, 14 11:00 PM
TimeKilla wrote:
bajacalla wrote:I’m stuck on the “eyes in the mask” puzzle - I have one more set of eyes to place, but the game is stuck there. the eyes won’t move, the “skip” button isn’t working, the “reset” function isn’t working, can’t go to the map, and can’t back out of the puzzle. all I can do is quit the game, but it’s saved there, and opening the game again takes me right back to the broken puzzle. do I have to start all over with a different profile?


I'm having the exact same problem. Finished the game, got all eyes where they should be and then it froze. SG is no help. Exited, went back -Still stuck. Can't back out, can't use the skip button. CAn't reset the game. This is very frustrating but I'm hoping I just overlooked something simple.

Playing on a PC, everything is updated.



I'm having the same issue. I've finished the puzzle, all the lights are green but now I am frozen.
 
 
 posted in Dead Reckoning: Silvermoon Isle Collector's Edition on Jul 15, 14 12:20 AM
Penny1942 wrote:I've already bought the game based purely on previous games from this developer. Personally I found this one boring. I've decided that I am just not into detective who dunnit games. There wasn't anything wrong with it just not my type of game. Should have demoed before purchase....LOL my mistake.



I totally agree with you Penny.. I also found it to be a little boring. I didn't care for the questioning suspects. The puzzles were good though. I'm not much into reading a lot in games, I usually skip the dialog but I wasn't able to do that here. I am kicking myself because I too did not demo and bought based on developer.. (LOL) Plus, I took advantage of sale price.

Others, I'm sure will enjoy the game, as it is a great game. It's just not my cup of tea!!

Happy Gaming!!
 
 
tookat wrote:Good News.....
the code still works, at least if you purchase the game after downloading it onto your GM.
code for CE: TICK
code for SE: TOCK

[/quote

Thanks for the code tookat! It still works, I just used it
 
 
 posted in Dark Parables: Ballad of Rapunzel Collector's Edition on Jul 1, 14 10:11 AM
shai_one wrote:For those who had trouble with the moss remover, were you able to move on. I used the moss remover on the door on the left first, when looking at the strategy guide it says to use it on the right door first. Can i get the other one or do i need to restart?


It doesn't matter which door you choose first, you will still be able to get a second moss remover.
 
 
Mac_too wrote:I reached the place where you place a wooden rose in a cabinet and it opens and you have to pull a latch (I think). All that comes up on the screen is a black square. Can't click on it and so I can't continue with the game. Uninstalled etc. didn't work. Anyone else have that problem?


I'm having the same issue and can't move on
 
 
 posted in Sea of Lies: Nemesis Collector's Edition on Jun 20, 14 9:35 AM
Alex7154 wrote:I uninstalled the game and reinstalled the game. My profile was still there and it started at the point of the glitch. I can open all the different panels (options, difficulty, whatever). But, I can't hit Ok on the "Brass notes" to proceed.

I would try another profile, but what if the glitch happens again. I guess I will never finish the story?


I started over with a different profile and a changed difficulty from custom to one of the other types just in case that was the problem and it solved it for me. Good luck
 
 
 posted in Sea of Lies: Nemesis Collector's Edition on Jun 20, 14 2:49 AM
crossstitcher01 wrote:i have the same problem with finding the spoon ,i cant find it ,or its not there ? any idea any one . thank you


It's a glitch. I had to start over and it was there the second time.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator