Posts created by VLewis138

 
 
 posted in Fright Collector's Edition on Jul 1, 14 1:18 PM
Played the basic game with no problem or glitches. In the bonus game HOS in room 2, I have a problem with the telescope "tuned focus" item. I have the telescope focused, but the guide does not show what I am to look at. This is the last HOS item and the game will not let me back out and only gives me a hint to use the top right knob on the telescope.

Anyone got a solution to this issue.
 
 
 posted in Grim Facade: Sinister Obsession on Jun 10, 14 1:16 PM
Got the screwdriver. Can't get it to turn the screw to release fire extinguisher. Playing on my iPad. Stuck
 
 
 posted in Nancy Drew: The Deadly Device on Mar 25, 14 12:50 PM
Playing the "amateur" game on a MAC- When trying to solve the "color Block" to imprint the security card, I was unable to get the green block #7 to rotate by "right clicking" I have checked my mouse on other programs and it is working!

Am I missing something here?
 
 
 posted in Corpatros: The Hidden Village on Jul 3, 13 1:33 PM
Can't find the darn branches everyone is talking about!!! Help!
 
 
 posted in Nancy Drew: Ghost Dogs of Moon Lake on Jan 26, 13 12:32 PM
Heard a click but never found the secret panel to get to the basement. Now I can no longer get to the dog statues. What am I missing? Do I have to start over?
 
 
 posted in Nancy Drew: Ghost Dogs of Moon Lake on Jan 26, 13 11:53 AM
I have turned the dog statues correctly and heard a click, but can't find the secret panel to let me in to the basement (I guess!) do I need to do something with the clock?
 
 
I clicked on the chalk on the roof and dragged it down to the chalk board. Can't get chalk to complete the "family"drawing. In fact, the chalk pops back up the the treehouse roof. This is the last item on the HOS list. Any help out there?
 
 
I am stuck in the HOS in the tree house. I can't get the chalk to complete the family. I LC on the chalk, drag it down to the slate, but it won't complete the family drawing. the chalk pops back up to the roof. Any help out there?
 
 
How do you activate the tokens? the Walkthrough indicates when you use the stork key, you will open the door to Dalimar house. I have the tokens but can't figure out how to activate and use them. Please explain in detail.
thanks
 
 
 posted in Shattered Minds: Masquerade on Jan 3, 12 8:16 AM
Can't figure out how to find what's hidden in the soup in the wedding reception hall.
 
 
I have the same problem. The top piece falls to the ground and I can't get the puzzle bar piece to get into the hospital. I've asked for help also, but so far, no replies.
 
 
I worked the spider gate puzzle that should have given me the puzzle bar but didn't.
I have left the scene, gone back and tried to click on the spider gate piece that fell to the ground, but it keeps going to the spider image on the gate. I can't seem to retrieve the bar to work the other puzzle -

Any help out there.
 
 
 posted in Haunted Manor: Lord of Mirrors on May 20, 11 3:29 PM
stuck! Made potion, found goblet, can't seem to open instrument case and find the other coin! Is anyone out there still?
 
 
 posted in Dracula 3: The Path of the Dragon on Aug 28, 10 12:46 PM
Help - Stuck- Have used Hammer & Stake , Garlic, Holy Water, Crucifix, Rowan berries, Hand has withered, but nothing has happened! What do I do?
 
 
I can't get the safe to open in Novella 2. Any suggestions (?)
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator