Posts created by KatzHome

 
 
 posted in Dark Arcana: The Carnival on Dec 1, 12 4:49 AM
OK ~ there are tons of GREAT reviews that fully explain the game ~ so I'm just gonna pop in to say that the trial hour went so fast ~ I this game ~ and I'm buying it right now!
 
 
 posted in Echoes of the Past: The Castle of Shadows on Nov 27, 12 9:29 AM
lorialcorn2006 wrote:Im finding I'm not as crazy about this game as I thought I would be -some of the things that really bug me are- First the hints are no help at all with mini game instructions -the one that really made me mad was the flower bulb game . unless you look at the walk through to find the solution their is no other way to figure this out short of spending a whole lot of time with trial and error .
I like a mini game to make sense in its solution . searching for a pattern that is really not there is annoying and the rules are basically whatever the developer wanted -you cant put certain color flowers next to others but no one tells you this through the story line you basically have to guess or keep doing it until you get it right . I think they should have had a clue to this in the story maybe a picture of how some of the flowers go into the bed or anything to give you an idea of how to start it. The other one that bugged me was the castle gate door puzzle written in Latin and in old style lettering with no clue as to what its supposed to say unless you get it right just seems like they deliberately wanted you to have to skip mini games or spend a whole lot of time fooling with it . Normally I love a good mini game but I like to have some kind of clue about how to go about solving it -telling me to swap tiles until the plaque spells out some unknown Latin verse is not really fun at all. Im so glad I waited for the reg game to come out because this game is far less entertaining than I though it would be ,and so far Redrum and the asylum conspiracy are leaps and bounds better than this one


I've only just started playing this game, 45 minutes into it, and the "Statues Placement from the scraps of paper hints" mini-game! I really liked all the mini-games in Royal House of Stone ~ and I'm hoping I like this game as much as I did that one! So far, I do!
 
 
 posted in Echoes of the Past: The Castle of Shadows on Nov 27, 12 9:21 AM
LoisMac wrote:I'm loving this game. My only dislike is that the hint button is useless in game play. I missed the quill, but the hint button just gives scenic descriptions rather than a hint of where to go. But the game is a lot of fun.


Yeah, it would be nice if the mirror gave a hint of where to go instead of just a scenic description ~ but at least I've been able, so far, to figure out where to go and what to do.

I've played a few games, that if it wasn't for the Walkthroughs, I'd NEVER be able to finish the game ~ and that's really no fun.
 
 
 posted in Echoes of the Past: The Castle of Shadows on Nov 27, 12 9:16 AM
I just downloaded this game last night ~ and got it for $2.99 ~ yeah! I the Echoes of the Past games!

Quite a while ago, on an older PowerPC Mac, I played Echoes of the Past: Royal House of Stone and loved it! I looked forward to the next game... then found I couldn't play it because the new game was made for the newer Intel Macs ~ I was so sad because I had no idea when or how I was ever going to get a new Mac...

My having to wait to play so many games is now paying off because so many of the games that I couldn't play, because of the old Mac, are now on sale ~ and I'm really saving money, which is good, because I buy a lot of games...

I've only just started playing, played 45 minutes and then purchased the game, but so far ~ Echoes of the Past: The Castle of Shadows ~ is just as great as its predecessor!

The gameplay makes sense, you find pieces of the puzzle in a timely manner so that you can easily go back, remembering what to do with the items that are found. The mini-games are great! I really like the one where you have to figure out where to place the statues from hints in the scraps of paper ~ and you CAN figure it out from the hints!

I so very much hope there are many more games made in this series ~ I will buy them all!



(And a note about gameplay from another game ~ I'm thinking of a game, that I won't mention the name of, that you had to place around 7 or 9 figurines on their correct pedestals that I couldn't figure out the rhyme or reason for where the statues were correctly placed... and when you did, by chance, happen to place one correctly, it didn't "lock" into place, so there was no game help what-so-ever in knowing you were on the right track... I had to use the Walkthrough, and I don't like using them... you're not really PLAYING the game when you have to refer to a Walkthrough for almost the entire game. Enough of this rant...)
 
 
 posted in Criminal Minds on Nov 11, 12 5:58 AM
I guess we're not getting any more technical help here.
 
 
 posted in Criminal Minds on Nov 11, 12 5:55 AM
I am trying to use the glass cutter on the door to open it, but the game never zooms in on the door and the glass cutter just goes back into my inventory when I try to use it without the zoom.

This is what it says in the walkthrough:

• Zoom in on the door and use the GLASS CUTTER to open it (S)


I can't continue on in the game without getting that door open.

I appreciate your help.
 
 
Examine and place the RAVENWOOD, UNICORN HAIR, IMBUING POTION, and the FORGING MALLET on the anvil; take the CENTAUR BOW.

Where do I get the RAVENWOOD from?
 
 
 posted in Criminal Minds on Oct 15, 12 10:23 AM
I can't get in the door with the glass cutter. The door doesn't change the cursor to a magnifying glass zoom-in and clicking on the door with the glass cutter just returns the item to my inventory.

I've tried quitting the game and restarting it and also playing it without the custom cursor.

I've already spoken to the Director of the Community Center, who wasn't very helpful, saying something like, "I don't understand why you would need to look around here," and now she only says, "Sir? How can I help you?"

I left the building and went to the Art School, did the hidden object scene in the corner, getting the ART SCHOOL ROSTER.

I went to every scene I could get to and can't find anything else to do.

I checked the walkthrough and saw that I had skipped a few things by jumping ahead to the hidden object scene in the Art School ~ but I couldn't do the things I skipped because of not being able to open the first door in the Community Center with the glass cutter.

I'm going to try emailing tech support but I can't imagine them telling me anything other than 1) try restarting the game or 2) try uninstalling the game and reinstalling it.

It seems that other people have gotten past this part before they had problems so maybe, I hope, this problem can be fixed for me.

I'm using Mac OS 10.8 and I can't go back and use OS 10.7 because it's a new computer and I never had the older operating system.

I sincerely hope all these issues can be resolved.
 
 
 posted in Criminal Minds on Oct 15, 12 7:01 AM
I tried disabling the custom cursor ~ that didn't work either.

I have a brand, brand, brand new Mac ~ running the latest OSX ~ I think it's Mountain Lion and there are two programs that I use, SnapzProX and WireTapStudio by Ambrosia, that say they have to update the programs for all the program options to work in the new operating system.

Perhaps that is what is happening with this game?
 
 
 posted in Criminal Minds on Oct 15, 12 6:50 AM
eedebeep wrote:I am unable to insert the cassette tape in the machine (for interrogation). No matter where I click, it won't let me put it in. I have tried both the single tape and the bunch of tapes.


You have to do the 'fit the tapes into the box' puzzle in the lobby to get the blank tape. Then you bring that tape into the computer room and put it into the cassette player.

I'm stuck on trying to get a door open with a glass cutter ~ the game won't zoom in on the door for me.

I really love the TV Show Criminal Minds and I was so looking forward to playing this game.... and it looks like there are so many glitches with it... And I bought it already... Bought two on the same day that won't work... Got a new Mac... thought every game would work on it.... ::sigh::
 
 
 posted in Criminal Minds on Oct 15, 12 6:44 AM
I can't zoom in on the door in the Community Center to use the glass cutter to open the door ~ and I can't go any further in the search.

Help please.
 
 
 posted in Criminal Minds on Oct 15, 12 6:39 AM
I can't zoom in on the door in the Community Center to use the glass cutter to open the door ~ and I can't go any further in the search.

Help please.
 
 
 posted in PictoWords on Sep 24, 12 7:58 AM
124 Levels ~ I just hit it...
 
 
 posted in PictoWords on Sep 16, 12 7:37 AM
I guess it wasn't all that LONG ago ~ I just saw that it was released in 2008... Only 4 years ago... I guess so much has happened in these four years that it seems so very long ago...
 
 
 posted in PictoWords on Sep 16, 12 7:33 AM
I'm on Level 106 ~ I thought I'd stop playing when I reached the 100th Level, but I like it to much to stop!

And I really enjoy the Bonus Rounds every 5 levels!
 
 
 posted in PictoWords on Sep 16, 12 7:30 AM
Yeah, I really like it too! I got this game a LONG time ago, got up to something like Level 16, then got into playing Hidden Object/Games with a Mystery to Solve...

I've played just about all of those type games available for the old PPC MAC and will soon be giving this computer to a friend who's buying me a new Intel MAC. I've been reviewing the games to see which ones he'd like to play and got hooked! on PictoWords!

In just a week I've gotten up to level 106 ~ and I really hope to play this game on my new MAC when I get it!
 
 
 posted in PictoWords on Sep 16, 12 7:23 AM
I really like this game!!! I'm playing it on an old PC MAC and, one of these days I'll be getting a new Intel MAC, so I came here looking to see if the game is available on the new MACs...

The unlimited version might be... when I clicked on the top post about the "Unlimited" version, I saw that some BF games now are playable on tablets and phones, so I guess PictoWords is one of those games... and if so, I'm guessing that I'll be able to play PictoWords on my new Mac...

Please tell me that I'm guessing correctly!
 
 
 posted in King Arthur on Aug 23, 12 7:16 AM
Thank you so much for asking where the sickle is! Now I'm trying to find the FLAIL...

All in all, I like this game a lot! I love hearing Merlin's voice, it's really well done, he speaks exactly the way that I'd expect him to. And the music is wonderful ~ very Medieval ~ it's a very "You are there" experience. I've always enjoyed the Legend of King Arthur, ever since I was a kid. I've read just about every book written on the subject in my teens, including "Le Morte D'Arthur" by Sir Thomas Malory ~ so this game is really a pleasure for me to play!

Now to find a really great game on the Hobbit and Rings Trilogy... if anyone can suggest one... Till the end of September I'll still playing games on my old PPC Mac, after that I'll have a new Intel Mac...
 
 
 posted in Dream Chronicles ™ 2: The Eternal Maze on Aug 20, 12 2:31 AM
catscat wrote:My solution to the chess game -

After you do the easy levels, it's time to get your handy dandy cell phone camera out.
Most cell phones will take short videos. Hold the camera at a good angle, click any square so it will start that sequence over. Video the computer screen, and then replay your video , (clicking one square at a time to be sure you don't mess up) as many times as it takes to get that sequence. If you mess up, delete that video and do it over again. Repeat for any more levels. I only had to do this for the last two levels.


LOL ~ I only read page one of this thread ~ and when my reply posted ~ there it was, right under the very same suggestion! Great minds think alike!
 
 
 posted in Dream Chronicles ™ 2: The Eternal Maze on Aug 20, 12 2:29 AM
Digital camera, movie sequence. Record the light sequence. Play it back in slow motion or frame by frame if necessary.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator