Posts created by ldeachus

 
 
 posted in Surface: The Pantheon Collector's Edition on Sep 22, 13 12:34 PM
I retrieved the draw handle next to the little girl outside the Train car. It is now missing so I can't attach it to the top drawer in the hut. Is there a fix or explanation?
 
 
Never got the sharpener at the hedgehog point - now can't get back to retrieve it to sharpen the sickle. ug
 
 
 posted in Living Legends: Frozen Beauty Collector's Edition on Jun 16, 13 5:01 PM
You need to have collected the mushrooms in the basket and use the mortar and pestle to mash them up. Need to collect the diamond stone stuck in the wall, the hot water in helmet melts the ice to get the snake valve and (I think the hammer) gets the stone out. The diamond crystal is inserted in the top of the camera. The powdered mushrooms go into funnel on side of camera. The lens are placed in the front of the camera and the lighter starts the flame on side of camera forward of the mushed mushrooms. The plates then get laid on the door of the camera and get magically developed.

I hope that I have remembered this correctly
 
 
 posted in The Secrets of Arcelia Island on Nov 9, 11 1:13 PM
still have crown and never did put together the (puzzle?) pieces I was collecting throughout the game. Nice game though - I liked it.
 
 
 posted in Samantha Swift and the Hidden Roses of Athena on Jul 5, 11 7:16 PM
I have the same problem - very frustrating. Afraid I have to quit the game. The only way to find "supposed" matches is to hit the Hint button. AND - no skip button.
 
 
 posted in Dark Dimensions: City of Fog Collector's Edition on May 22, 11 5:38 PM
Loved this game. I beta-tested it and have been waiting for it to come online. Best part about this game is there is not a FindObject in every scene. Thank you.
 
 
 posted in Mystery Trackers: Raincliff Collector's Edition on May 13, 11 11:06 AM
Please post when new update for this game is available with fix.
 
 
Me, too. Must be a big glitch in the bonus part of game.
 
 
 posted in Elixir of Immortality on Mar 24, 11 9:39 AM
Same with me. Each time I face the lockers, the number has changed. I enter the upstairs room, put the number in the crypt and nothing happens. A return to the lockers then shows another number. Looks like eternal loop. What should really happen????
 
 
 posted in Dream Chronicles ™ 2: The Eternal Maze on Feb 7, 11 3:45 PM
how irritating...without the skip option - this game gets jettisoned.
 
 
 posted in Murder Island: Secret of Tantalus on Feb 3, 11 10:20 AM
This game froze at the puzzle to match geese, kites, cyclones and lightning. I tried 3 times. After purchasing over 60 games that work absolutely fine - I am not about to do any troubleshooting which usually takes hours to do and can mess up my computer for other apps. My solution was to delete the program and forget about it.
 
 
Thank you - will retrace my steps
 
 
I am in the Bonus Game and have to get into a 2nd story window that has a pull down ladder. Game prompts that I need something long enough to pull the ladder down while the strategy guide just says to crawl into the 2nd story window. Have no idea where to get this item to pull the ladder down.
 
 
 posted in Atlantis Evolution on Jan 27, 11 5:11 PM
Thanks for your reply - I just kept saving as long as I was safe and finally got through it.
 
 
 posted in Atlantis Evolution on Jan 24, 11 10:49 AM
I was at it for 3 days - finally hid behind the hills and only grabbed the blue crystals. When the bad guy came out, hit him as fast and furious as I could. Pure luck I think was the answer. I was amazed when I finally made it.
 
 
 posted in Atlantis Evolution on Jan 22, 11 9:43 AM
I too an stuck in the building after throwing the distracting stones. Have gone over two different walkthroughs and still cannot avoid the guards. Is there a glitch that prompts you to send a game save to get around this point in the game?

If so, please send me the game save also - I would appreciate it.
 
 
 posted in Atlantis Evolution on Jan 19, 11 1:20 PM
I'm with you. I must have died a thousand times, now I'm lost in the forest, never found the necklace and have no idea how to get back and find it. I tried mapping the forest and found by going straight I only end up back at the start. BLAH... This is one of the more annoying games I've played. And the native girl, cheesh - buck teeth and over developed calves - don't mind me, I'm just venting on this game.
 
 
 posted in Lost in Time: The Clockwork Tower on Jan 6, 11 8:23 AM
I found the undisplayed dandelions on the table of the prep area after I had picked them. I guess that they will automatically appear when they are needed.
 
 
 posted in Lost Chronicles: Salem on Dec 23, 10 7:07 PM
Installed game today 12/23 - got to town puzzle, finished it, got the key - WHAM all inventory is lost. Now, if these glitches have supposedly been fixed - why would a new name get me past these problems. And, tedious it would be to start over. I will be deleting the game.
 
 
Thank you so much.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator