Posts created by GreenMyEyes

 
 
 posted in Riddles of Fate: Into Oblivion on Jun 14, 14 12:58 PM
I'm not sure why I bought this game, It was a while ago and then it got sidelined. But now, on my second session playing it, I find it very boring. The graphics are not that good (my usual reason for buying a game, and the voice-overs are terrible.
I'm off to a better game ..
 
 
Thanks, sha49tn1. I currently don't have the tweezers, but now I know what to look for. I'm enjoying this game, too -- especially the white rabbit :^)
 
 
I know where the drawer handle is: it's stuck in the direction sign. And I know what to do when I get it: return to the clock work room.

What I don't know is what item I need to get it out of the sign -- I've tried everything in my inventory, but nothing works. I'm at a point where I can't make further progress until I can get the (expletive deleted) drawer handle.

Badly in need of help!
 
 
I'm so enjoying this game -- best Ive played in a long time. What astonishes me are the fabulous graphics. Even when I'f found asll thereis to find in a room, I just stand there awhile enjoying the graphic details.

I thing good graphics are a large element in what makes me choose one game over another. Thanks for the notes about the credits, sheilamilo -- now I'm, really looking forward to them.

Go, developers!
 
 
 posted in Bejeweled 3 on Mar 29, 14 11:19 AM
Does anybody else name their levels in the Classic game? Like Living in the Fig Tree (level 9), or The Invisible Forest (level10)? I've got names I like for most of the levels, but I started getting a bit lost about level 15 because I'm concentrating so hard on the game i don't notice the backgrounds. I finally finished the last level. but I can't remember whether it was level 19 or level 20. And it will problably take me a long time to get that high again.
 
 
 posted in Nevertales: The Beauty Within Collector's Edition on Mar 23, 14 1:59 PM
I also have the very same problem. I do believe I have flipped every page in every book I've found including the book in the Extras Section. I am so enjoying this game and wold ike to go further, but I'm afraid I'll have to give up!

Sad, sad GreenMyEyes ...
 
 
 posted in Christmas Stories: A Christmas Carol on Dec 24, 13 2:35 PM
... the Ghost of Christmas Past swirls into Scrooge's parlor is one of the most delightful graphic I've ever seen in a game!
 
 
 posted in Fierce Tales: Marcus' Memory Collector's Edition on Nov 8, 13 12:42 PM
I'm playing the bonus game. After the moving-obstacles-away game, I enter an area with grecian-like columns. First the kraken is there; then he disappears. As I'm exploring, I examine a wall. Then "something" goes into my inventory, with a message about examining a wall. When I look in the inventory one of the slots is filled with a sign saying NO ITEM, black letters on a white background. When I put my cursor over the NO ITEM I get an endlessly looping message which says something like

WallPainting CU CE PIECE OF CROWN.

I think this means that it's GAME OVER time for me.
 
 
 posted in Calavera: Day of the Dead Collector's Edition on Oct 28, 13 10:35 AM
n the bonus game, I'm at the point where I need four hearts to get a machine working. I have two of the hearts but can't find the other two. My friendly little Guide to the World of the Dead seems to think I have them, because when I ask for help, he keeps pointing me back to the machine that needs fixing. Help???

P.S. I posted this before, but I can't find the post.
 
 
 posted in Calavera: Day of the Dead on Oct 26, 13 12:52 PM
In the bonus game, I'm at the point where I need four hearts to get a machine working. I have two of the hearts but can't find the other two. My friendly little Guide to the World of the Dead seems to think I have them, because when I ask for help, he keeps pointing me back to the machine that needs fixing. Help???

BTW, the graphics in this game are totally fabulous!
 
 
 posted in Stray Souls: Stolen Memories on Oct 5, 13 1:20 PM
I feel like I fit right in here! I'm 75, and not quite disabled, but my emphysema keeps me at home most of the time. I just finished a course of radiation treatments for lung cancer, and I still have very little energy. During the treatment, I seemed to do almost nothing but play computer games, most of them from Big Fish.

I also noticed that, during this time, I hit the Help or Skip buttons much more frequently that I used to. Has anybody else experienced this?
 
 
 posted in Legacy Tales: Mercy of the Gallows Collector's Edition on Jul 2, 13 11:01 AM
I'm in the secret corridor; I've inserted the bone handle; I've attached a piece of chain to the big wheel -- but I'm stuck. I can't more forward, and I can't move the bone handle down. There's a plank of wood propped against the big wheel, but I don't have anything to knock it away. What am I missing, or what am I not doing?
 
 
I seemed to have finished the town of Willow Ridge (reactivated the lighthose and recharged my amulet). That seemed to open the way into the next section of the game, the woods right outside of town, but I can't seem to make any progress. I read Alan's journal, and it indicated going into the townhouse to retrieve the meanings for the symbols (I have the list of symbols -- or perhaps just A list of symbols). But I realized I haven't yet found the little lighted window so that I can open the town house. Any help, please?
 
 
 posted in Enigma Agency: The Case of Shadows Collector's Edition on Jun 10, 13 7:22 PM
I seem to be hung up on the music box puzzle. I entered the numbers in the appropriate suits, and cranked the crank, but then ... nothing. I can no longer select the music box, the map shows the music box puzzle is still to be solved, and the hint button does nothing any more. Bug?
 
 
You need more than just the hearts, you need the heads, arms, and legs as well.
 
 
 posted in Princess Isabella: A Witch's Curse on May 20, 13 10:40 AM
As you get older, you start losing your hand-eye coordination skills. I'm pretty old now. I've been trying and trying and trying, but I'm never going to be able to shoot even the green marbles out of the ring, much less the red, blue, and yellow. And I can't find a Skip Button.

1. Does any body know how I can get out of this?
2. Are there any other hand-eye coordination games in the other two Isabella games which I've just bought?
 
 
 posted in Mystery Trackers: Four Aces Collector's Edition on Apr 10, 13 9:25 AM
I need a chisel (I have the mallet) so that I can save the stone man in the bonus game. I looked through the strategy guide and didn't see anything. And the walkthrough doesn't cover the bonus game. I'd hate not to be able to complete this enjoyable game.
 
 
 posted in Where Angels Cry on Mar 8, 13 4:23 PM
I thought this was a pitiful little game. It felt like it had been written about 10 years ago, before people knew how to do great graphics. And it looks like it had been written by a beginner who had just learned to model and was trying it out for the first time.

The navigation is ok, and the story is ok, but the HOGs are filled with little things like finding a dark nail against a dark wall, or some necessary tool hidden on a desk in a dark corner behind other objects. The hint system will allow you to find wee things in the HOGs, but it is useless otherwise.

I'm an intermediate level player, and I think maybe a beginner might find it interesting. But, again, those tiny little things hidden in dark corners might turn the beginner off HOG games forever.

I would regret spending my money on this, but I used a game credit to get it. Now I just regret spending my game credit.
 
 
 posted in Cruel Games: Red Riding Hood on Jan 22, 13 12:54 PM
I thought this was a very poor game. The graphics were quite poor, the story repetitive and dull, and the puzzles somewhat familiar and tedious. I would regret having spent money on this game, except that I used a free game credit to buy it. Now I regret losing a free game credit. I've played games I like from this game producer before, so I was especially disappointed in this one.

There are so many good, well designed, challenging games out there; don't waste your time on this one.
 
 
 posted in Web of Deceit: Black Widow Collector's Edition on Nov 30, 12 3:31 PM
I'm across the river in the entymologist's home. In back of the picture, I've placed the sticks of dynamite. I've attached the fuse to the dynamite. But I can't figure out how to set fire to it. I have the igniter which I thought should do the trick, but no matter where I place it, nothing happens -- no big BOOM, nothing! I've tried it in the close up view and also from a distance without any luck. I also have the blowtorch, and I've tried it in all the same ways, but again, nothing.

When I press the help button, it just annoyingly points to the dynamite again.

If I don't have what I need, could someone please tell me what I need? I suspect the igniter is exactly what I need, but I'm not using it right, or in the proper place, or something else that's frustrating. Anyone?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator