Posts created by moonweaver

 
 
 posted in Escape the Museum on May 20, 12 8:45 PM
Can anyone help me? I just got around to downloading this game; I played the sequel first. I am stuck on Level 24 in the Native American room. In order to get out, I need to get the key on the wall, but it is too hot to touch. I found the fire extinguisher and its valve, and got it working, but the walkthrough on another site says to spray it on the long orange pipe next to the key, and to grab the key when it turns silver. I have sprayed repeatedly, but the key never turns silver. When I try to grab it, or even try to spray the key, I get the message: "It's too hot to touch." I'm frustrated.
 
 
 posted in Runaway With The Circus on Apr 23, 12 10:36 PM
I played the demo and enjoyed it. As many have said, the hidden objects were tiny (sometimes) and also sometimes dark. When I used a hint, which I did often, sometimes I still couldn't see the object, so had to click around until I lucked onto it. My eyes are old, as well!

I won't spend a credit on it, but would buy it for a DD. Most of all, I loved the music. I was born in 1936, and my parents liked this kind of music, so I used to hear it at a young age. With most games, I turn the music down so far I can hardly hear it, especially if it's spooky, but this music I kept loud enough to hear, but not so loud as to distract me.
 
 
 posted in Hidden Mysteries: Royal Family Secrets on Apr 2, 12 7:40 PM
I finished the game last night, and really enjoyed it. I didn't think it was too short at all, but then, I'm not a fast player. There is a lot of to and fro, and even though I looked at the map, sometimes I went the wrong way, and had to backtrack. I'm not up on my history as much as other fishies, so overlooked anachronisms. I did think during one H. O. scene that one item was not true to the period: a match. But when I researched matches, I found out that the Chinese invented them around 400 or 500 A.D. So I was wrong, though the Chinese matches probably didn't look as modern as the one in the scene.
 
 
 posted in Crossworlds: The Flying City on Mar 30, 12 7:43 PM
Well, I finished this game last night, and I did enjoy it. I did have to refer to the walkthrough several times to figure out where to go/what to do next. It seems the trick is to remember to go back to places you have already been, and you will find another hidden object scene, which will give you something you need in order to progress. Sometimes that doesn't work until you have completed certain actions.

I found the ending rather abrupt and surprising, but it seems there will be a sequel, so I'm looking forward to it. I didn't buy the game until this week, and I gather it has been out a while, so maybe the sequel will come along soon.

The game was quite long, and had several different "worlds", so it was very diverse. Graphics good, music fine; sometimes the h.o.'s are quite small and/or dark. My old eyes can't see them sometimes, even with a hint.
 
 
 posted in Mary Kay Andrews: The Fixer Upper on Mar 25, 12 9:06 PM
Well, I solved my problem by starting the game over, which was my third new game: the second time I started over because when I met the old lady, she implied that my character had been inside the house before, and been told to leave, and I didn't remember that happening. Anyway, on the third try, I knew where a lot of the objects were, and didn't have to use many hints. So when I got to the front of the house and needed a hint to find all the needed repairs, I had hints left.

Anyway, I finished the game last night; it was an OK game, but I'm glad I didn't pay full price. I didn't so much mind the ending, like some other fishies. Just not an exciting game, though I must say the devs tried. I think the game ought to rated as an adult theme, because of the mention of prostitution, bribery, etc.
 
 
 posted in Mary Kay Andrews: The Fixer Upper on Mar 24, 12 6:55 PM
I bought this as a DD without playing the demo or checking reviews; I don't often do that. I was enjoying the game, even tho I would prefer a voice-over rather than reading so much dialogue. I don't even mind the chores like scraping wallpaper and washing the car. (Reminded me of one of the yardsale games where you had to renovate yardsale items.) But now I am stuck with trying to find the last place to repair on the front of the house, and I have run out of hints, and can't find any more house icons. Also, I have looked for a walk-through, and can't find one. On the wallpaper scraping, I finally had to click the Skip button when I had stripped 98% and just couldn't find the rest. So now I can't progress in the game without finding that last needed repair. Disappointing, even tho I only paid $2.99.
 
 
 posted in Easter Eggztravaganza on Mar 20, 12 8:54 PM
[removed by Moderator]
 
 
 posted in Azada: In Libro on Jan 12, 12 8:24 PM
I finished the game tonight, mostly on my own; I used the walkthrough a couple of times. I enjoyed the game, but thought the ending was very abrupt. It caught me completely by surprise. So that was a little disappointing.
 
 
 posted in Drawn™: Trail of Shadows Collector's Edition on Oct 20, 11 9:30 PM
I played the demo and enjoyed it. I'll have to wait a couple of weeks until I get my Nov. credit, and maybe the SE will be out by then.

I love this game; love all the Drawn games. As usual, the graphics, music and voices are wonderful. I noticed the movement of the scene, but unlike some others, it didn't make me sick, so motion sickness isn't a problem. I was just fine with the SG being right there, giving one hint at a time. No problems that I can see, other than having to wait till I can afford it.
 
 
 posted in Fairway ™ Collector's Edition on Oct 4, 11 8:16 PM
Thanks, Solice, for the info. That decided me: I will not pay extra for the CE. I might get it as an SE.
 
 
 posted in Fairway ™ Collector's Edition on Oct 3, 11 9:50 PM
Hi, all...

I was about to say that I agreed with others that I would wait for the SE version because I don't want to pay the money for the CE. The original is also MY DH's favorite. I have it on the desktop so he can find it easily, and he is addicted to it. He's still working through the first time; I'm now playing it for the third time (under separate user names).

But after reading Solice's comment, I might change my mind. Have to think about it. I've already used my Sept. credit for the new Awakening. By the time Fairway comes out with the SE, I should have my Oct. credit.
 
 
 posted in Spirit Soup: The Queensbury Curse on Aug 26, 11 7:07 PM
GingerGal: Thanks for the tip; I finished the game last night. I didn't know there was a walkthrough till you mentioned it in your last post. But I got through the game without any more help.
 
 
 posted in Spirit Soup: The Queensbury Curse on Aug 24, 11 10:07 PM
OK, I cleaned the stained glass window, and have proceeded to making the Spirit Soup. Now I have to take it to every cursed place to undo all the curses. Grandma said to start with the one at the temple, which I did. But I don't know how to light up the skull, and though I found one of the little disks, I can't find the other one. And the game won't let me leave this scene. So now what?
 
 
 posted in Spirit Soup: The Queensbury Curse on Aug 24, 11 8:56 PM
PrettyBlueEyes78 wrote:
moonweaver wrote:I'm in the temple and have replaced the tile pieces in the mosaic. I'm supposed to change the colors of the parts, using the stained glass window as a guide, but it is grimy. I have the wet rag, but that won't clean it. Any suggestions? I still haven't found a walkthrough, even on other sites.


Have you actually wet the rag in the fountain? If not, do so. If you have, then try holding the rag by the center of the stained glass window, and slightly to the right and click. That's where it worked for me. Kinda in the middle of the grime. For some reason you have to click on a specific spot or it doesn't work. Hope this helps.


Thanks, PrettyBlueEyes; I'll try it. And yes, I had already wet the rag in the fountain, but I was trying to rub it all over the window, instead of clicking in one place.
 
 
 posted in Spirit Soup: The Queensbury Curse on Aug 24, 11 12:42 AM
I'm in the temple and have replaced the tile pieces in the mosaic. I'm supposed to change the colors of the parts, using the stained glass window as a guide, but it is grimy. I have the wet rag, but that won't clean it. Any suggestions? I still haven't found a walkthrough, even on other sites.
 
 
 posted in Nancy Drew: Treasure in the Royal Tower on Jul 24, 11 8:52 PM
I don't remember her commenting on it.
 
 
 posted in Nancy Drew: Treasure in the Royal Tower on Jul 24, 11 2:54 AM
Thanks again for the tips. I made it back out of the tower. I love ND games, but I get lost a lot while trying to navigate. I have the same trouble with similar games, where you have to walk back and forth to locations. I printed out maps of all three floors from a walkthrough, but didn't find a map for the path to the tower, of course. Anyway, I talked to the prof, so now the game can continue.
 
 
 posted in Nancy Drew: Treasure in the Royal Tower on Jul 24, 11 2:19 AM
Thanks, DutchJames. Yes, I did push that button, several times, in fact. So I will go back and try again. I assume you mean the big square, and it tells you there is a sound of cement grinding?
 
 
 posted in Nancy Drew: Treasure in the Royal Tower on Jul 24, 11 12:10 AM
I can't find my way out of the tower, after solving the chain puzzle, the checker board puzzle, and the leaf puzzle. I know from reading a walkthrough that I should be able to get back to Nancy's room from here, but every time I try to go down the stairway, I can't get all the way to the bottom. I go so far, and then the forward arrow changes to a u-turn. There's nothing else I can do in the tower until I talk to the professor again. Am I just incredibly stupid? I know I'm not good with directions, but this is ridiculous!

HELP!!!
 
 
 posted in Nancy Drew: Secrets Can Kill Remastered on Jul 11, 11 7:31 PM
I bought this game on disks a couple of years ago, and never finished it. I was used to the newer, more modern ND games, and the navigating in the old version was just too "clunky". Also, I didn't like having to switch disks, which was required several times. I'm glad they remastered it, and will consider buying it at a later time. I'm using my monthly game credit for one of the newer ND games.

A note on Real Myst: I tried the demo, and found the first person view made me dizzy. That also happened to me with one of the more recent Sherlock Holmes games. Nancy Drew is first person view, but those games don't have the same effect on me.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator