Posts created by Pinkbudgie

 
 
 posted in Urban Legends: The Maze on Sep 19, 11 7:12 PM
I just finished and I just had to say how much I loved this game. I have played some fun HOGs lately, but nothing this good for a long time! When I'm looking to buy a game, I often skip to the last reviews to see if anyone has finished the game and if they still liked it to the end. So I thought I would post my review after finishing.
The puzzles were exactly the right challenge. I thought I may have to skip a few but I worked on them and solved them. I never had to skip any.
The HOG scenes had clear graphics, some were trickey to find but I never had to use a hint. I never found an item called by the wrong name. Some games ask you to find a ball but then they have several balls in the scene and you have to keep looking until you find the "right" one. This game didn't do that either.
The story or premise of the game was different and a nice relief from crazy mental hospitals. A reality tv show called "The Maze" is the perfect reason to explain why everything has puzzle locks.
The game never crashed on me and while I didn't time it, it seemed to be a pretty long game- keeping in mind that I took my time to really look for objects without hints, and to solve all the puzzles without skipping. Also, I loved the map! It served as a hint system for me. I wish all games had this! Can't wait for the another in the series!
 
 
 posted in Hotel Dash 2: Lost Luxuries on Jun 7, 11 7:50 PM
gillydi53 wrote:I'm having the same problem with bigfoot as well the first time it happened i restarted the level and it righted itself , it's just happened again on another level not sure if it's corrected yet as i'm shutting down .Hope its ok beacause I've never had a problem with any of the dash games or playfirst for that matter . Fingers crossed.


I just had the bigfoot problem too and ccame here to see if anyone else had this. I also thought it was odd because I've never had a glitch like this in a Dash game. This was my demo and I won't buy it unless I know that has been fixed.
 
 
 posted in Hotel Dash 2: Lost Luxuries on Jun 7, 11 4:33 PM
I love all Dash games too and bought the first one. But I never could finish it. It just got way too hard. I'm wondering if people think this is easier, harder, or the same compared to the first Hotel Dash.
 
 
 posted in Supermarket Management 2 on Jun 7, 11 12:57 PM
tmcarson1 wrote:A fun little game, I had part 1 and finished that so had to give 2 a try.

It must have been made in another country though, the wording is sometimes very strange lol, like the manager on duty is called an 'administrator', but it is a fun game nonetheless.



I did the beta test on this game through BF and that was one of my comments I told them. I said no one calls for an "administrator" in a store. You ask for the manager. An administrator makes you think of a school. But obviously they didn't care about little things like that. I know these things aren't a big deal but when they show up they are odd and show that they didn't really bother to take the time to find out how Americans talk. All they had to do was ask any American to proof read through the script and they could tell them what didn't make sense.

But yes, fun game. I bought it too. Sometimes I suspect that when I get a star on one level, it applies it to the next one because then I go back to try again to get the star and it is the one I just got a gold on. Something odd there, but I'm not 100 percent sure it is happening.

 
 
 posted in Voodoo Whisperer: Curse of a Legend on Jun 4, 11 7:00 PM
I downloaded the demo and the game starts in a window. And it won't even use the whole window. About a 1/4 of the picture is missing, just a black line. I tried to change the setting to full screen but it doesn't allow me to do that. Even if I did get the black line to go away, I sure wouldn't want to play the game in a small window. So far this game is a no buy for me. I didn't see anyone else with this problem.
 
 
 posted in Avalon Legends Solitaire on May 6, 11 6:38 AM
I was having the same problem with the perfect finish so I've been watching to see if there was an update available. It isn't showing up on as "update available" on the game manager like other games do. I will try reinstalling the game, but it seems like if an update was available for this rather imporant fix, there should be the update indicator on the game manager.
 
 
 posted in PuppetShow: Lost Town on Apr 30, 11 7:59 PM
Thanks for the info. I was a little afraid to update half way through the game.
 
 
 posted in PuppetShow: Lost Town on Apr 30, 11 10:28 AM
Does installing the update allow to continue with your saved game or must you start over?
 
 
 posted in Totem Tribe on Apr 3, 11 8:32 AM
Never mind. I think I have it now. The white one must work for all the colors. Last time I clicked on it, it took me to the first island. I clicked on it again out of desperation and ended up on a new island. I guess it uses whichever color is "on". Sometimes just posting a problem makes me find the answer!
 
 
 posted in Totem Tribe on Apr 3, 11 8:24 AM
I made my person travel from the first island to the second. I put the yellow crystal in the holder but cannot go anywhere else. When I click it while he is next to it nothing happens. The pink one just flashes off. The walkthrough made it sound like I should be able to click on the yellow one to travel now, but it just blinks. Is this a bug or am I doing something wrong? I have the energy sphere if that matters.

I tried looking back and I couldn't find anyone else with this problem, but I could have missed it because too many people just title their thread "stuck" without saying where and I didn't check those.
 
 
 posted in Totem Tribe on Apr 3, 11 8:15 AM
That's great! I just found out about this one and am playing it now. I hope they make hidden items slightly easier to find. I'm pretty good at that sort of thing but finding some of them is just nuts- they are way too blended in for how small they are. Also sometimes I have click several times on something to choose it.
 
 
 posted in Virtual Villagers: New Believers on Mar 26, 11 7:39 AM
Kashmiraka wrote:Well, I have finished the game, still missing 3 relics, but everything else is done, so I go back now and then to half heartedly look for the last 3 and change their outfits, **** hum, I do not think I will find the last 3 and if I do, so what?
I totally agree with the previous post, Totem Tribe was AWESOME!


Hmm... Somehow I missed Totem Tribe. I'm going to download it and give it a try! Thanks!
 
 
 posted in Virtual Villagers: New Believers on Mar 26, 11 7:22 AM
You need to use your earthquake power on them to convert red and orange. I found it easiest to do when they were all gathered at the dirty camp site. It will take many times, but slowly they will come to believe.
 
 
 posted in Virtual Villagers: New Believers on Mar 25, 11 8:04 AM
I had one game where all I needed was a horn looking thing. I had to start over due to an unrelated computer issue. The next game, that horn showed up all the time. You just never know.
 
 
 posted in Virtual Villagers: New Believers on Mar 24, 11 9:39 AM
Converting orange and reds: Hint: won't happen until you get all your powers.

The purple science master is thinking about conversion if he has a light over his head. He still needs to be convinced several more times.
Hint: you may also have figured out how to fix the aquaduct.
 
 
vv5
 posted in Virtual Villagers: New Believers on Mar 24, 11 9:35 AM
Hint: That won't happen until near the end of the game when you get all your powers.
 
 
 posted in Virtual Villagers: New Believers on Mar 24, 11 9:34 AM
Your villagers can't bury them until you have dug out the mausoleum.
 
 
 posted in Virtual Villagers: New Believers on Mar 24, 11 9:30 AM
Spoiler-


I just converted the last heathen. Everyone went over to the mud hut and fixed it up. It would have been nice if someone could have done something with the hut. Go in and find an artifact or maybe give you one last bonus puzzle to solve.


I love these games and how they can keep on going but it would be fun if you could earn something for your villagers to use everyonce in while. Like for completing trophies or finishing certain collections. Maybe something else to spend tech credits on. When I finally converted the last heathen I had over a million tech points. Sure I could buy clothes but no one had anything to work for anymore so no real reason to assign outfits to different workers.
 
 
 posted in Virtual Villagers: New Believers on Mar 17, 11 6:27 AM
Well, like it says, it needs an eye.

If you want a hint..........





Small spoiler..........






You have to clear the mausoleum first.
 
 
 posted in Virtual Villagers: New Believers on Mar 16, 11 6:56 AM
If you aren't running them at the same time, it shouldn't make a difference. We have lots of games on our pc, big and small. If your computer is completely full with no more room, that might affect how everything runs on it. I'm not a computer expert but this is what I've observed with our computers. If you have several programs running at once, that could slow things down. Like if my virus program is updating while I play a game, it slows down some until it is finished.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator