Posts created by elmira78

 
 
Did you position the point of the screwdriver over each screw? If you tried that and it didn't work, have you downloaded the updated version? I don't remember any issues with the screws in the panel.
 
 
I didn't have any trouble with that, although by the time I got there I had downloaded the new version and installed it. All I remember is that you have to position the screwdriver over each screw.
 
 
Am using the metal detector in the swamp by the cannon. I dug with the shovel where the detector went off, but all I got was one of those hidden gold pirate cards. Now it won't let me dig, even when the metal detector turns green, which it only does in one place.
 
 
 posted in Elixir of Immortality on Aug 8, 10 3:32 PM
Finally found it. I didn't realize it was different that the other bullets I put in. Now everything is progressing. Thanks much. nwl43!
 
 
 posted in Elixir of Immortality on Aug 7, 10 7:31 PM
I loaded the revolver before I put in in the clamp. Now when I try to fire it I get a message that I need to load it first, which of course I can't do because I've already done it. I can't remove the revolver from the clamp either. Is there any way to get around this without deleting the game and starting over? I did check the walkthrough and double checked the parts, it looks like all 6 parts are there.
 
 
In the Egyptian Tomb I've opened the mummy case, but now I can't find the item to break the hanging jar and open the secret room. When I click for help Uncle says that balancing the scales revealed something I should pick up, and to check the wall behind the golden dogs. When I do there's nothing there I can pick up. I've clicked on every possible location behind the dogs, but nothing comes ups. Anyone else had this problem?
 
 
 posted in A Gypsy's Tale: The Tower of Secrets on Jun 25, 10 7:37 AM
For those having trouble with small screens, try setting your display to a lower resolution before starting the game. I've had to do this with some games and it usually solves the problem.
 
 
 posted in The Inquisitor on May 31, 10 5:45 PM
FYI I am running Windows 7 64 bit, if that makes any difference.
 
 
 posted in The Inquisitor on May 31, 10 5:44 PM
Demo worked fine, so I bought the game. After I activated it I got an Access Violation error message when I tried to open it I rebooted my computer with no effect, so I uninstalled and reinstalled the game, also with no effect. I uninstalled the game and deleted both the demo file and purchase file. Then I went to my purchase history and downloaded the file again. It still won't run.
 
 
 posted in The Inquisitor on May 31, 10 8:41 AM
I was able to play the demo with no problems. However, when I bought the game and activated it I got an Access Violation error message when I tried to play it. I tried uninstalling and reinstalling the game, and even deleted the file and downloaded it again from my purchase history, and it still doesn't work.
 
 
 posted in The Heritage on May 22, 10 8:16 PM
Just downloaded the demo today and I'm having the same locket issues with Chapter 1 that everyone else is having. I uninstalled and downloaded a second time, and it still didn't work. I'm glad I didn't buy it.
 
 
 posted in Deadtime Stories on May 1, 10 1:23 PM
Finally found it - in the bottom right corner. For anyone else having this problem - it's a different kind of marble than the other two!
 
 
 posted in Deadtime Stories on May 1, 10 1:18 PM
Has anyone else had this problem? I've used the hint potion several times, and it seems to form a "V" in the top right corner of the screen. I've clicked everywhere within that area, and also in the area where the two streams crossed, but with no luck.
 
 
 posted in Curse of the Pharaoh: Tears of Sekhmet on Oct 12, 09 6:41 PM
Every time I go back to the game I find that my progress isn't saved, and neither is my profile. Any suggestions?
 
 
 posted in Angela Young 2: Escape the Dreamscape on Aug 25, 09 6:07 PM
Couldn't even get the game to open. Uninstalled and downloaded again, still same message about not being able to read some start file.
 
 
 posted in Princess Isabella: A Witch's Curse on Aug 22, 09 8:21 AM
I'm stuck in the powder room. I have a blue key, but can't find a red key anywhere. The only rooms that aren't marked as cleared are the hall with the marble door, the mirror room, and the powder room. Where do I look for the red key?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator