Posts created by psyche_

 
 
 posted in Voodoo Whisperer: Curse of a Legend on Jun 5, 11 7:07 AM
I bought the SE with the May gift credit and am glad in the end that I didn't pay for it. The graphics were great and the music / voice overs good. HOG scenes were about the right level (no junk piles nor too easy). However, as someone else stated, after the demo time, it did start to seem not quite as good - with the way the locations were listed on the map, I thought there were going to be loads....not the case!!! IMO, too short overall game play. I liked the storyline, but definately didn't like the ending, I prefer a game to be finished and have hints of a coming sequel, not a half finished game, which is what this seemed.
 
 
 posted in Voodoo Whisperer: Curse of a Legend on Jun 5, 11 6:39 AM
thanks kekis - I couldn't find the herb either! squish - if you're still having trouble with the candle, you need to inscribe it first using the mixing bowl.
 
 
 posted in Dream Chronicles: The Book of Water on May 29, 11 4:58 PM
Thanks for all the reviews, you've really helped me to make my decision on purchasing this one! I'm a massive fan of all the other DC games and have played them repeatedly, so was really looking forward to this game to come out. I demo'd the CE, but for some reason it kept crashing on me and even if I 'end tasked' the game and restarted, I was still stuck...even tried uninstall and reinstall twice and was still stuck in exactly the same place - couldn't do anything at all (and yes I tried creating a new profile and got stuck in the same place)!

I had no problems with the SE demo. However, I found nothing remotely challenging at all in what I played.... i.e. the scene in the doll house after Lillith spoke - all you had to do was pick up two measly little triangles and not exactly hard to find! I also could not skip the cut scenes (to that person that said there is a skip button - yes I know, but clicking on it did nothing for me!), which totally sucked when I had to start a new profile in the demo time. I also don't see a walk-through, which means I can't see how close I was to finishing it at the end of the demo time (which is probably the point!!)

So although I love the graphics and storyline so far, I will not be wasting even my free voucher on this...I will be cheeky and use demo time on other sites that don't use BFG as a publisher to find out the end to the story!
 
 
 posted in The Agency of Anomalies: Mystic Hospital on May 13, 11 2:34 PM
I played the CE demo and liked it.... the subject matter didn't bother me - it's just fiction! I liked how interactive it was and the HOG scenes were great. However, after buying the SE, I have to say a BIG thumbs down. I completed the entire game in under two hours. Considering that was a first run through, that was far too fast - if i play it a second time, will I finish it in less than an hour?!? Also, once you got past where the demo ended, there seemed to not be that many HOG scenes.
Am gutted I just wasted a credit on this.
 
 
 posted in PuppetShow: Lost Town on Apr 22, 11 10:36 AM
I played the game through once, although I'm not quite sure how I persevered since it took about 6hrs because of the lagging!! My biggest problem was the saloon, but the railway carriage scene and the wheelbarrow scene were also incredibly slow. In the saloon, it took about 10 minutes for the piano part to be installed, then the lag during what I assumed to be can-can dancing (I checked back every now and again and the legs appeared to be in different positions!) took so long that I managed to watch an hour long TV program whilst waiting for the scene to finish....I was almost crying in frustration! I have just downloaded the update and tried to play again...I got as far as the saloon to see that the lag is still just as bad, so for anyone else with the same issues (I never had any HOG scene problems), this update has NOT fixed it.
 
 
 posted in Gravely Silent: House of Deadlock Collector's Edition on Apr 9, 11 11:30 AM
I'm not convinced on this one either - I have all the right specs for the game and the latest flash, etc, but it's incredibly slow going. I just quit after 20 mins and hadn't got past feeding the worms to the birds! I kept getting the 'freezing' in jerks and starts screens, whereas some other games might have just one particular screen that freezes, this was in every scene, including the HOscenes. I got fed up of having to locate my curser each time it unfroze!
 
 
 posted in Dream Chronicles ™ 2: The Eternal Maze on Feb 27, 11 10:43 AM
there should be one of those metal tiles next to the broken bridge, which you need to take to burn a new shape (diamond) and use the hammer on the larger stones in the courtyard to make more tiles.
 
 
 posted in Dream Chronicles ™ 2: The Eternal Maze on Feb 27, 11 10:40 AM
If I remember right... it might have something to do with the crystal ball. The crystal ball needs to be on the table in front of the book to open it, then I think the other books appear on the floor.
 
 
 posted in Immortal Lovers on Jul 26, 10 9:19 AM
I'm having the same problem as magnetic rose - can't leave the screen with the rusty cables - somebody obviously forgot to activate the link on the back-arrow icon or something! I tried exiting the game but it restarted in that screen and i still couldn't move so i tried using a new profile and starting again but still got stuck on the same screen!

I also won't be wasting my money buying this one! I can't even tell what the objects are in the forest - I can just see there are objects lying about so I just click on them and wait to see what item disappears off the list at the bottom! Definately not one of the best so far....
 
 
 posted in Dream Chronicles: The Book of Air on Jul 8, 10 5:21 AM
I must admit I was very disappointed too - I loved the other 3 so was really looking forward to this one. The third one is quite long and interesting whereas, this one ended very abruptly and without warning....I thought I was at the end of the chapter and about to start the next one and the credits came up! In addition, I didn't think the storyline 'gel' ed with the rest of the games, nor do I feel that the storyline of this one was even completed really.

I am extremely glad I didn't fork out for the collector's edition.
 
 
 posted in The Secrets of Da Vinci on Nov 3, 09 5:03 AM
I am trying to make the fumigant, but I can't get it out of the copper pot. I have put the sugar, water and saltpetre in the copper pot and lit the fire underneath. If I hover the magnifying glass over the pot, it says "the still contains a preparation for fumigant". However, when I try clicking on (or above) the copper pot with the iron box nothing happens, even though the cursor is the gear cursor. Anybody know how I get the fumigant out?

Secondly, I can't figure out how to get the etchings from the floor in the basement. I have been down there numerous times trying ridiculous things that don't work! I finally checked the walkthrough and it said to use the broom....I don't have a broom and I can't see anywhere in the walkthrough where I was supposed to pick one up. If someone could let me know where to find a broom, I'd be really grateful! :o)
 
 
 posted in Princess Isabella: A Witch's Curse on Aug 23, 09 2:27 PM
I have the blue key and am stuck in the powder room. I don't have the red key to get out of there. I have 5 pieces of the king, 2 of the marbles and the only rooms that aren't completed so far are the mirror room and the hallway with the marbles door. Please can someone give me a hint of how to get the red key / where i'm supposed to use the blue key? i've spent the last half hour just wandering around my completed rooms to see if there isn't anything hidden!
 
 
 posted in Princess Isabella: A Witch's Curse on Aug 23, 09 2:02 PM
smash the bugs with the fairy's rock, takes a bit of accurate whacking though! i've got a little further then i'm stuck - i have the blue key (which i can't figure out what it's for) but not the red key and according to my map all other rooms are cleared, so if any one can help with that, much appreciated!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator