Posts created by addieh

 
 
 posted in Hidden Mysteries: The Forbidden City on Sep 11, 11 5:21 AM
This game is one of the best I've played! The music, graphics and play time were great and I love anything to do with China. Good game. I give this an A++.
 
 
 posted in Redemption Cemetery: Children's Plight on Sep 9, 11 7:18 PM
Been waiting a long time for this. It's everything I hoped for and more. Graphics, creepy sounds and music is fantastic. Grade A++ for me!
 
 
 posted in Sacra Terra: Angelic Night on Sep 3, 11 7:17 PM
I'm still playing it, but my oh my what a terrif game! The graphics are A++ altho there is alot of moving around and like others who have played, it's hard on the ole' peepers. LOVE IT!
 
 
 posted in Age of Enigma: The Secret of the Sixth Ghost on Aug 26, 11 2:07 PM
Never mind, I figured it out!
 
 
 posted in Age of Enigma: The Secret of the Sixth Ghost on Aug 26, 11 9:05 AM
I don't have any charcoal in the grate. I've clicked everywhere and nothing so I uninstalled the game and reinstalled it. Still no charcoal. Help please?
Is there something i'm missing?
 
 
 posted in Secrets of the Dark: Temple of Night on Jul 31, 11 7:48 PM
I loved this game! I've played it twice now. The music, graphics, and especially the past in the time of the Mayan/Incas was superb. Wonderful game! I give this an A++ for sure.
 
 
 posted in Celtic Lore: Sidhe Hills on Jul 1, 11 6:31 PM
I found the walkthrough for Celtic Lore through google.
I'll let you know how the game goes!
 
 
 posted in Celtic Lore: Sidhe Hills on Jul 1, 11 6:26 PM
I found this game while skimming hidden objects section and if you google
celtic lore:sidhe hills walkthrough it will take you to the site and click on the first link.
I'm in the midst of printing now so hope for those who tried the game and didn't get far that this will help, even if you bookmark it!
Happy gaming!
 
 
 posted in Empress of the Deep 2: Song of the Blue Whale on Jun 12, 11 7:56 PM
The first Empress game, I had the walkthrough. This one I didn't and altho I used the hint button alot which I don't like doing because I try to use my smarts, I LOVED IT!
Looking forward to the continuation.
Awesome game!
 
 
 posted in Mystery Valley on Jun 11, 11 9:50 AM
The first time I played, I found the key in the hutch no problem but I hit a glitch and had to start again. Now I can't find the key to open the door. Is anyone having or had the same problem, and how do I fix or do I write CS? Thanx.
 
 
 posted in Mystery Trackers: Raincliff on Jun 6, 11 6:44 PM
Hi. I'm writing this for someone else who's playing the game. In the bank when you get to the key code, each time you punch the number in, it changes. Any way around this? Is there a way to beat this code?
Cause when the #'s are punched in, the numbers that show on the digital screen are different.
Any help will be appreciated.
 
 
 posted in PuppetShow: Lost Town on Apr 14, 11 6:15 PM
Yeah, me too. I installed it, started to play and it got quite jerky and slow. So I uninstalled it, shut my computer down and reinstalled. It still didn't work, so I went to Dr. Felix program and finally ended up writing to tech support about the game.
I've played the other Puppetshow games and loved them. Am disappointed that I have to wait for this game to be fixed..hopefully.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator