Posts created by jill312

 
 
 posted in Paranormal State: Poison Spring on Nov 1, 13 11:41 AM
There should be three wooden game pieces. Put them in the corners and turn until the picture is complete.
 
 
 posted in Escape the Museum on Oct 4, 13 1:47 PM
I forgot to tell you there is a electric power cord on the floor in the rubble. That needs to be plugged into the machine before you can get the sticker.
 
 
 posted in Escape the Museum on Oct 4, 13 1:27 PM
How do I combine the sticker, the pole and the magnifying glass. I sort of have an idea but nothing works. Thanks
 
 
 posted in Escape the Museum on Oct 4, 13 1:22 PM
Use t he buttons to move the different pictures, The viking helmet goes on the farthest right side.
 
 
 posted in Voodoo Chronicles: The First Sign on Sep 3, 13 3:36 PM
How do I pick up the handcuffs? I can see them clearly but they wont come.
 
 
 posted in Haunted Legends: The Curse of Vox Collector's Edition on Jul 16, 13 5:01 AM
I have the grain to make the flour but the grinding mill will not accept it. What else do I need to do?

Thanks
 
 
 posted in Reveries: Sisterly Love Collector's Edition on Jun 18, 13 2:42 AM
My slab will not accept the stone flower. Any suggestions? Thanks
 
 
 posted in Reveries: Sisterly Love Collector's Edition on Jun 10, 13 6:43 PM
I am on the bonus game. I have a half painted flower and a paintbrush. The flower will not accept the paintbrush. Any suggestions?
 
 
I have both halves of the mold and am trying to put it on the demon furnace. It shows to put it there in the strategy guide but it will not stay. Any suggestions?
 
 
 posted in Fruit Mania on Jan 31, 13 2:00 PM
I had the same problem you are having. After I tried all the updates the customer service people offered and it still did not work, they gve me a coupon for a new game. Maybe if enough people report this we can get the problem fixed.
 
 
I tried that. I read the strategy guide and tried to put water in the coffee maker and turn it on, but nothing happens.
 
 
 posted in Rite of Passage: The Perfect Show on Nov 12, 12 3:00 PM
I am at the point where I am using the resin glue on the detective badge and the photo of me, I have done all the steps up until cutting the photo out with a razor but the resing glue is off the burner. I cannot place it in the scene to use it. Any suggestions?
 
 
 posted in The Dreamatorium of Dr. Magnus on Oct 8, 12 4:44 AM
I have all the items to dress up the mannequin. I get the message that the mannequin would look better with hair, but I cannot find that anywhere.
 
 
I bought this game because I needed to use a game club credit up before I could use a game club coupon that I earned. I was disapointed because even though the trial was interesting; the actual game was too short and the story line dig not into the villian deeply enough. As far as collector editions go this game should be one to pass on by.
 
 
How do I get the sherrif's badge in the glass case at the train station. I successfully broke the glass case but, the glass is still over the badge. I went out and tried to get back in, but now the game will not let me do that. Thanks
 
 
Where is the locket. I do not see the man I am supposed in Annie Chapman's Room.
 
 
I cannot find the third fuse. I do not have it on the robots lap as shown in walkthrough. It has number 40 on it. Thanks
 
 
 posted in Mystery Trackers: Black Isle on Aug 10, 12 10:28 AM
The window in the cafe is already cut out in a big circle and no microphone is visible as in the walkthrough. Also I cannot find the batteries for the jack hammer that are supposedly by the radio in the curiosity shop. Thanks for your help.

 
 
 posted in Grim Tales: The Legacy on Jul 12, 12 5:13 AM
You should have cement somewhere. Put that in the mold. After that I am stuck too.
 
 
I cannot find the key that is supposed to be on top of the fish that was hauled out of the ocean with the big net.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator