Posts created by Bethyboo74

 
 
 posted in Nancy Drew: The Deadly Device on Apr 1, 14 4:24 AM
I cant seem to get access to Ellies cubical, ive tried checking the video footage again and again, and waiting for the 'humming' sound, but still no joy, can someone please help me?
 
 
 posted in Shadow Shelter on Feb 3, 14 5:47 AM
Ok, completed it....the mistake I made was giving the door emblem to the hand, and the game let me too!!!! so when i needed to open the door, i no longer had it....started the game again and didnt repeat this...so thx for your help
 
 
 posted in Shadow Shelter on Feb 3, 14 2:41 AM
Right, so, I have rechecked every room to make sure i hadnt missed anything, and still nothing, I remember giving the hand the rectangular emblem for the door, before i ot to pick it up....have tried all items (the locket with the thistle, the hand, and the mirror with the writing on it) on all parts of the door and surrounding area, and still nothing, I checked the tasks list, and made sure i had all the items on the list...still nothing /( thinking i might have to restart the game
 
 
 posted in Shadow Shelter on Feb 3, 14 2:09 AM
Hiya, Yh did the mechanical heart and, I always check the map also....read all the hints on here too before hand....boooo, going to give it another go, will let you know if it works
 
 
 posted in Shadow Shelter on Feb 2, 14 12:01 PM
Right, so i have the medallion with the thistle inside, the hand and the mirror, I cant find where to put all these,even though there are wheel signs here... im in the basement...and none of the items i have are working on it....plz help someone : /
 
 
 posted in Return to Mysterious Island 2: Mina's Fate on Jul 21, 09 12:15 PM
I got jep to put the cocnut in the turbine duct but when i started the engines it shot out, and the whole motor situation has gone back to square one and i dont know where to find another cocnut....please help!!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator