Posts created by Krakle

 
 
 posted in Between the Worlds II: The Pyramid on Mar 30, 12 8:33 PM
Figured out that picking up items when partially covered by clouds isn't possible, you can't just see the item in the HO you have to clear the clouds away by holding down the mouse button.

Onwards and Upwards I solved the pyramid, opened with the key from the book and am in the process of placing lens on the 'thingy' when again, an error exception crash.

Here we go again.

Lesson learned, check the techinical issues before committing to buy a game!
 
 
 posted in Between the Worlds II: The Pyramid on Mar 30, 12 4:40 PM
Doing the hidden object in the pyramid and when I clicked on the magnifying glass to return to a previous HO I got an error message and the game crashed.

Closed BFG, restarted and now I can't pick up objects... and they are the right ones because I used a hint to confirm the ping pong ball was where I thought it was and the hint confirmed it, but still can't pick it up.

How frustrating, this is my second technical issue with a game in less than a week and while BFG refunded on my last game I am getting tired of this.
 
 
 posted in Revenge of the Spirit: Rite of Resurrection on Mar 25, 12 3:18 AM
Silly me, read the reviews instead of the technical issues and as the first page of reviews were pretty good I bought the game. Same test mode problems in the HOs, the first time was forgivable. The second was frustrating and third occurrence brought me to the forum. Its disappointing that this much time after the games was issued the problem still hasn't been fixed.

If I next run into the problem with the non-stop talking Doctor, I too will be asking for a refund.

Bad enough to issue a game with glitches, unforgivable to not get them corrected!!!
 
 
 posted in The Scruffs: Return of the Duke on Feb 24, 12 1:32 PM
Yes, all numbers are in the train station... open the clock itself to find a few of them!
 
 
 posted in Deadtime Stories on May 1, 10 7:14 AM
Haven't seen this issue posted yet: A couple of times I needed something from my inventory and it wasn't there. I finally figured out that it was only the graphic that was missing as the inventory item name showed up when I put my mouse over an empty inventory box.

Needless to say this is a technical glitch... the good news is that once I identified what was needed I did a drag and drop, even though there was nothing to drag and drop and I could continue to play.

One example that I remember is at the gazebo where you need triangles to get rid of the ghosts... 3 triangles didn't show up in inventory, and I had to 'pretend' they were there, and viola... the appeared after I dropped them into place.

Hope this helps someone else....
 
 
 posted in Delaware St. John: The Town with No Name on Oct 10, 09 3:02 PM
Just for the record: As there is now a walkthrough, I found my way through the entire demo, and still had 18 minutes to spare. The demo was enough to convince me that its way too lame to buy and continue.
 
 
 posted in Magic Encyclopedia: Moon Light on Jul 6, 09 10:42 AM
Just finished the game and discovered a few things about the missing gems message:
1. If you are missing gems from anywhere, you cannot move past Mayan/Venice.
2. To find out where you are missing gems: visit the map and look for floating gems, they are above the location where your gems are missing
3. If you click on the small gem icons on the bottom right of your screen you will see: a) the color of the missing gem and b)how many gems are missing.
4, Find all the missing gems and return to the Mayan temple and you'll complete the game.
 
 
 posted in Crazy Machines on Sep 21, 08 1:34 PM
It made me crazy that some guy posted that he'd found the solution in pictures and then didn't share the link! After much searching and frustration here is a link to a German site where a pictorial pdf download file for all solutions are posted! Note: its very large... but its good! Also note, there's no link function in this forum so you'll have to cut and paste it!

Update
okay, so its against the rules to post a link. So I suggest you do a search for
crazy machines download fanpage
 
 
 posted in Crazy Machines on Sep 17, 08 9:59 AM
Spent way too long on this level.

This is the one thing I hate about these kinds of puzzles, once you're stuck you're done, no hints, no skip, no solution provided!

Found the answer buried in Chit Chat... and found other's experiencing the same problem... so here's what was posted:
Yep, use the steel ball and magnet to prevent the lower billiard balll from moving. Then it will not hit the switch so the C4 will not explode, the ball will just run over the C4 and straight into the bucket.


It Worked!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator