Posts created by Athenatoo

 
 
I'm on Win7. I had no problem with the game itself, but when I started the "souvenirs", I got about halfway through, and then the screen locked. I can move backwards and get out of "extras", but I cannot collect all the souvenirs. Windows says my drivers are up to date.
 
 
 posted in Myths of the World: Love Beyond Collector's Edition on Feb 8, 18 11:08 PM
No the issue is not a video driver. The problem crops up randomly in the game. When you click on a "hot" area, sometimes the red X to click out of it works, sometimes not. You have to go back to the map, click on an available area, and then return to the scene where the hot area was to be able to continue. There is no pattern to this.
 
 
 posted in Myths of the World: Love Beyond Collector's Edition on Feb 8, 18 11:08 AM
Trying to release the dogs from the cage; screen "grays" out and I can only select one side of the lock. Can't back up, can't go forward. I'm using Win 7.
 
 
 posted in PuppetShow: The Curse of Ophelia Collector's Edition on Feb 4, 18 3:49 PM
Me too .. but the strategy guide should be a help, not a block. "
Play the HOP" does not tell you what this extremely obscure clue means!
 
 
 posted in Dark Romance: Winter Lily Collector's Edition on Jan 25, 18 11:26 AM
Dominii ... please do not succumb to Millenials' Disease by using apostrophes to create plurals. (Strategy Guide .. collectibles). The plural of "lily" is "lilies", not "lily's".

Why does it matter? Because you have a character in the game who is named Lily. Anything belonging to Lily is "Lily's", so when you use that word in the collectible instructions, it's confusing. Yes, I figured it out, but I should not have to try to interpret what you really meant.
 
 
The technical aspects of the game are fine (art, music, hints, etc.) but whoever is writing the text clearly does NOT speak English. This grew progressively worse as I played the bonus game. (I need some pruner??????) Some of the so-called "helpful texts" were English words strung together with no meaning . If you are going to sell games to an English-speaking audience, then for heaven's sake, PROOFREAD. I am playing a game, not devoting time to trying to understand illiterate texts.
 
 
Art is excellent albeit seriously creepy. I understand that this storyline is about the Day of the Dead (which is not my culture) but talking about dressing up as dead people and eating candy skulls was really hard to deal with. The story itself was good, and the journey to collect soulstones was well done. I am not a fan of having so many mini-games; a few are OK, but this was loaded with them. The HOPs were quite well done; finding objects was a good challenge!

A couple suggestions: a) add a "brightness" option under "custom"; (and don't call it "gamma", which has no meaning to non-graphic artists); b) make sure the "helpful text" actually makes sense in English (if English is the language of the game).
 
 
Problems with changes between scenes; keep getting a fatal error once I click on something and the program says "loading". The error is: 0x656e6967

I'm on Win 7. I am able to force quit, then relaunch every time, but that should not be happening.
 
 
Same problem here; the SG says something about colors, but nothing on my monitor seems to match the colors. Where is the skip button? I did post this on Eipix's FB page too; maybe we'll get an update or help?
 
 
I completed the main game with no issues. Just started the Bonus game, got to the study, did all the tasks there, and tried to return to the street view, and it simply will not let me do that. The map shows the swamp as the next location, but I can't get there even using the map itself. Stuck.
 
 
galerw wrote:The game is great, but I have no souvenirs. I checked the walkthrough and where the walkthrough says there are souvenirs to collect, there are none. I can see the acorns to collect, but not the souvenirs. Tried uninstall/reinstall and still nothing. I am running windows 10.

Thank you for any assistance


I don't know where you are in the game, but the souvenirs do not show
up till you complete both the game and the bonus game. This only happens if you have the Collector's Edition. If you do have the CE, then after you finish the bonus game, go to the extras--> souvenirs, and click anywhere on that screen and it will start taking you to all locations where souvenirs exist.

 
 
 posted in Mystery Tales: Eye of the Fire Collector's Edition on Sep 30, 16 8:10 PM
Restarted the game under a new profile. Everything worked this time UNTIL I got to the scene where you need to prop a ladder up to the ceiling light fixture. I put the ladder up, and the screen started blinking. Now the ladder is there, but I can't access the light and whatever is up there on it.

I wonder if we are not allowed to perform actions out of sequence (not the same order as the strategy guide). If we get ahead of steps, the game freezes.
 
 
 posted in Mystery Tales: Eye of the Fire Collector's Edition on Sep 30, 16 8:56 AM
Win 7, 64 bit

Did fine till I got to Amelie's room; the shelves accessed with a lever. First time through, all 4 shelves worked. 2nd time ... program crashed. On reboot, the lever disappeared and I cannot access the shelf with the icon game at all. I'm unable to move forward.
 
 
I also appear to be in the minority I loved it! While I agree that the fragments are a tad difficult to find in the HOPs (maybe that was the goal?), the game as a whole was enchanting and fun. I do agree that morphing objects and the acorns were hard to find (developers: do not assume everyone has high end resolution and monitors) so that could be a "need to improve" for the next chapter in the series. The story line seemed to hang together well and each chapter also had coherence. I'm looking forward to the next episode!
 
 
 posted in Haunted Legends: The Iron Mask Collector's Edition on Jul 1, 16 3:07 PM
Win 7; completed the game just fine. Started the bonus game, handed the money to the guard, and the money disappeared, the guard still is asking for money, the game says "you've done all you can here". Now what? I can't find the coins, the guard doesn't have them, and I am stuck.
 
 
 posted in Hidden Expedition: Midgard's End Collector's Edition on Jun 2, 16 8:56 AM
I tried reducing the music volume in the "options" menu, but
the controls are not working. No matter how I slide the control,
the volume of the music stays the same. Win7.
 
 
 posted in Love Chronicles: Beyond the Shadows Collector's Edition on Apr 12, 16 11:36 AM
gbanjs wrote:Played the original game just fine. Stuck in bonus chapter at the owl coin mini game. Was trying to figure it out on my own, but finally used the strategy guide. For whatever reason I can no longer do anything with the puzzle. None of the pieces will move, the restart button doesn't work and i can't skip out of the game. Tried uninstalling and reinstalling the game with no change.

Windows 10


OK, I'm on Win 7, no game crashes, but the BONUS section has crashed. Got to the scene with the witches in the "bar", it sent me back to get the 2nd potion, and now nothing works. I'm back at the shoreline, I've picked up the 2nd potion (removal) and now I can't go forward or back, there are no "hot" spots, and "hint" does nothing. Stuck.
 
 
 posted in Living Legends: Bound by Wishes Collector's Edition on Mar 5, 16 3:58 PM
3 problems I encountered (both after finishing the game)
I have Win 7 professional, 64 bit

1. Clicked on "collections", found 1 rose I had not collected. Clicked on that to go back to the scene to get it, and the game crashed. Screen went blank, nothing showed up. I had to go to Task Manager to quit the game.

2. Never did find the link to the morphing objects collected. I probably missed one there too, but it would have been nice to know and go back to get it.

3. In the bonus game, I tried to set "custom" game mode to "no tutorial". Clicked it several times to uncheck it, but it did not allow me to do that.
 
 
 posted in Spirit of Revenge: Gem Fury Collector's Edition on Dec 16, 15 5:51 PM
luluofalaugh wrote:I am running Windows 10 and all my drivers are up to date. We usually play games on in the hardest mode, without any clues or hints....but I finally gave in and looked in the strategy guide for the teapot....which I can see but cannot access. Also tried the hint button to see if that would help, but that is not working. I have uninstalled and reinstalled this game.....but nothing helped.

Very frustrating as I am near the end of this game.


Same problem I had (well at least I'm not alone). Clearly, their testing process is failing. I understand that they cannot possibly test for every single configuration on personal computers, but when this many people are having exactly the same problem across platforms, it's a testing and programming fail.
 
 
 posted in Spirit of Revenge: Gem Fury Collector's Edition on Dec 15, 15 1:12 PM
Got all the way to the carnival, and then not such good luck. The teapot never entered inventory, so I can't do the steam. Never got the cover for the illusion powder, and therefore I cannot progress at all. The hint button died. SG still works.

Solutions anyone? (FYI, Win 7 professional 64 bit)
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator