Posts created by Taipai99

 
 
Am in the room with Petey that has the group of lockers on the right.
I'm suppose to put the perforated card in the locker but it won't let me.
Can anyone help with this???? please, please, please
Taiai99
 
 
The music score for Dark Parables: Goldilocks and the Fallen Star is beautiful.
This is the first time I've really been aware of the music playing and really listened.
I've downloaded the soundtrack and will play this many times.
Thanks.
 
 
 posted in Dark Parables: Ballad of Rapunzel Collector's Edition on Apr 11, 15 12:23 AM
I've bought every Dark Parables games and I'm really disappointed in this one.
I've played for about an hour and am not happy with the graphics. Also, there's far too much "junk" in each scene that just clutters up the view.

So, not happy with Rapunzel and will probably never finish it.
I was expecting this to be just as good as the rest of the Dark Parable series so did not buy the shorter version for a trial. I'll never do that again.

Sorry Big Fish, this one is really bad. Sorry I wasted 2 game credits.
Taipai99
 
 
 posted in Awakening: The Sunhook Spire Collector's Edition on Mar 28, 15 11:54 PM
If, after all this time you still haven't figured it out try the following...
You need to lay the sheet music - Melody of Time on the strength statue first
the play the notes in the order it shows.
 
 
 posted in Awakening: The Sunhook Spire Collector's Edition on Mar 28, 15 11:46 PM
Hi...I'm having the same problem you are with the 3 bells.
Sure wish someone that's completed the game would help with this.
 
 
 posted in Awakening: The Golden Age Collector's Edition on Nov 22, 14 5:41 PM
Finally got past that spot but now I'm stuck trying to get the mural put together.
Sometimes these games can make you feel like you're really a dumb bell. Hopefully someone will come up with the answer.
 
 
 posted in Awakening: The Golden Age Collector's Edition on Nov 22, 14 4:29 PM
Same HOP but my problem is I can't figure out how to deal with the magnifying glass and what seems to be lens. The hint button highlights the lens and the magnifying glass but I can't figure out what to do with these items.
 
 
 posted in Dreampath: The Two Kingdoms Collector's Edition on Oct 7, 14 7:54 PM
I completely agree with all of you... there should have been a skip button.
I don't think BF games realizes that a lot of seniors play these games (they're far too easy for teens and 20s).
So get with it BF...and tell your developers to use skip buttons for all the puzzles.
 
 
 posted in Curse at Twilight: Thief of Souls on Mar 24, 13 6:33 PM
Got all the way through the game and discovered I only had 4 of the 5 missing picture pieces.

Does anyone know where the pieces were available? I've gone back to most of the places throughout the game but can't find any stray picture piece.

Hope someone can help. I really don't want to start all over.

Thanks.
 
 
I had the same problem. As soon as I took the scroll from the man and it came up on the screen I couldn't get rid of it in order to continue.
Tried un-enstalling and re-enstalling and it didn't help.
Finally had to give up and create a new profile and start all over. Haven't got to the same spot again but it'll be interesting to see if I can get past that area this time.

 
 
Just finished playing House of Brass and I have to thank BF for this one. Finally, a game that wasn't like all the rest. Really liked the different type HOSs and I thought the story line was great.

I know I've complained about the cost of the collector's editions and how short some of those games are but this one was worth the price.

Taipai99
 
 
 posted in Dream Chronicles ™ 2: The Eternal Maze on Feb 13, 12 12:36 AM
Hi all:
Decided to re-play The Eternal Maze again due to the fact I couldn't get through the Chess Game the first time I played.
Finally made it through tonight but now I have a problem with the Knights.
I can't get the arm and sword on the last knight. In my game he's the one on the left side of the screen. I have one arm and one sword left and it doesn't seem to matter where I try to attach the arm it won't work.
Has anyone else had this problem and if so how did you solve it. Is there by any chance some extra body parts like the puzzle in the music room?
Thanks to anyone that can help.
Taipai99
 
 
 posted in Lost Souls: Enchanted Paintings Collector's Edition on Sep 1, 11 1:08 PM
I agree. Way too short for a CE game.
I felt when the CE games were first introduced that for a while they'd be worth the money but then fall back into ordinary length games and that's what's happened with Lost Souls.

Don't think I'll waste my money on another CE games.
 
 
 posted in Musaic Box on Jul 28, 11 4:55 PM
Sure glad I read all these posts before buying the game. Won't waste money on short games.
Thanks all.
 
 
 posted in Reincarnations: Uncover the Past Collector's Edition on Aug 26, 10 9:23 PM
I totally agree with you. Reincarnations: Awakening was a fantastic game but this one is a bust. I won't be buying this one, even at the reduced price.

 
 
I'm a big fan of Big Fish Games but I'm really disappointed with this one.
The graphics are awful and the grammar, in some places doesn't even make sense. It seems that the game was done in another language and then whoever did the translatting to English doesn't know English.

Sorry to be complaining but I think when a game comes along that is not up to Big Fish standards, the "powers that be" shouldn't even consider putting it into the lineup.


 
 
 posted in Drawn: The Painted Tower ™ on Sep 21, 09 1:45 PM
Dear cesse47:
Thank you so much.
Once I tried a different body part it worked with no problem.
It blow my mind how sometimes the simplest thing can hang you up for hours.
Thanks again.

 
 
 posted in Drawn: The Painted Tower ™ on Sep 20, 09 8:43 PM
Hi all: This is my first post on any game forum. I usually read them but have never needed to open a discussion because you guys are all so great I always find an answer.
BUT, here I am at the task of having to place the frozen pieces on the statue. I know they go in the order of 3, 4, 5, 1, 2 but I can't figure out where to place the pieces on the statue. I've been trying for the last hour and nothing seems to work. I know I must be missing something and any help you can offer would be greatly appreciated.

Love Big Fish Games and I particularly love Drawn: The Painted Tower.
Taipai99
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator