Posts created by KCErin

 posted in Ghost Files: The Face of Guilt Collector's Edition on Jun 27, 17 11:21 AM

I just wanted you to know I had trouble starting the game. I have the latest version of Windows 10 and got an initialization error when starting the game. I changed the resolution to 1400x1050 and it started just fine although the image was scrunched. Once it started, I changed back to the 1920x1080 resolution and the game started just fine and the image looks great.

I am enjoying the game very much. I love mysteries and it's fun getting to do forensic tests as if I'm a real policeman. Thanks for doing some interesting games.


 posted in The Secret Order: Bloodline Collector's Edition on Jun 17, 17 9:46 AM
Thanks for the reminder sazoria. I have the latest version of Windows 10. I was getting the error and changing the resolution worked. The neat thing is that once you start the game, you can restore the resolution to the recommended value and the game continues to open okay.
Just goes to show - you need to try a game and make up your own mind. I beta'd this game and loved it. I liked the Norse theme and the Yggdrasil tiles. Maybe because I've been reading Rick Riodin's Magnus Chase books, but this game was fun for me.
I cannot get the blue wire in the Tunnel. I need this to charge the battery to defeat the Master. The guide shows that this was needed. It seems that when an item isn't picked up in the right order, the program doesn't allow one to go back to select it.
Just to add my two 'tokens' (cents). The bag worked when I returned to the fountain/dead body location. If you get in the HOS map without the pager (as I did), just go to the game map and click on the fountain location.
 posted in Steel LIFE on Feb 25, 16 12:42 PM
If I remember correctly, you use the suction cup on the glass cabinets. I think this makes them stay open and you can get the next item.
 posted in Steel LIFE on Feb 25, 16 12:35 PM
Got it. Turn off the heater. When you go to the wind turbines, go back to the greenhouse yard and the crow will fly into the greenhouse. When you get in, the crow is stuck in the ice patch. You can get him and remove the speaker from him.

Now onto the blacksmith.
Same here. Using Windows 10. Would like to have seen Mother and Daughter reunited.
 posted in Spirit of Revenge: Gem Fury Collector's Edition on Dec 16, 15 9:28 AM
Sorry to hear that moggilicious. I got past that point, but then lost the coin for the strong man photo. I wonder if there is a glitch if the game isn't played in a certain order.
 posted in Spirit of Revenge: Gem Fury Collector's Edition on Dec 16, 15 9:26 AM
I am in the amusement park. I got the film reel and played it. I got the quarter after entering the code, but for some reason it disappeared before I could use it on the strong man photo. Has anyone else had this problem? I hate the thought that I need to start the game all over - I'm on the 4th child, so almost done.
 posted in Spirit of Revenge: Gem Fury Collector's Edition on Dec 15, 15 2:53 PM
The lid should be on the carousel horse - use the up-arrow from the water bucket. When the lid is combined with the teapot, you can use the steam on the mirror.
I had a weird experience. I tried the suggestion to use a display of 125% and it worked. I decided to buy the game and intended to make the display change. When the installation completed, I thought I would start the game without changing the display just for grins. The game worked perfectly.

If this is a result of an upgrade that fixed the problem - thanks for that. If not, I'm not sure why it works on Windows 10 without changing the display. Just glad it works; I am enjoying the game.
 posted in Immortal Love: Letter From The Past Collector's Edition on Dec 11, 15 11:17 AM
Thanks for sharing this. It worked. Here is what I found after doing the change:

- After restarting, I tried the game. It started great except that the screen had black bars, so the picture was small.
- I tried to change to 'widescreen' but this made things worse.
- I exited and restarted the game. This time it was perfect - full screen.
- I'm enjoying the game, but would love an update so the display does not need to be changed each time.

NOTE: You need to change the display back to 100% for other games/apps to work correctly.
 posted in Eventide: Slavic Fable Collector's Edition on Nov 26, 15 9:18 AM
Thanks Valdy.

Hope everyone has a wonderful day with family and / or friends. Our family is all spread out, but we do have friends we will have a lovely dinner with.

Happy Thanksgiving all.
 posted in Haunted Hotel: The X Collector's Edition on Nov 12, 15 8:02 AM
I also did the Beta test and enjoyed it. It's definitely creepy. I said in my comments that it would be great for Halloween, but I'll take it at any time.
 posted in Nancy Drew: Labyrinth of Lies on Nov 11, 15 8:56 PM
After selecting <start> and making the selections, there is a submit button at the upper right. If any selection is wrong, it says 'the gods disapprove" and you can change one or more of the selections. If your selections were right, it says "The gods approve" and automatically prints. Hope that helps.

BTW: Be careful and save during the game and when you leave the game. I thought I did, but didn't and had to start over.
 posted in Nancy Drew: Labyrinth of Lies on Nov 11, 15 11:01 AM
Since no one has reviewed this game, I'll give it a try.

This is a large-file adventure game - typical for Nancy Drew. Two modes of play: Amateur Sleuth (somewhat casual) and Master Sleuth (no hints, harder puzzles). There is a task list that keeps growing. I managed to check one item off the list during the demo.

You start at an amphitheater where a woman yells for 'Help'. There is a lot of wandering around and meeting a few people. I met several people and discovered areas of the amphitheater.

Next I got to the museum. There are lots of interesting exhibits. There is an easy trick to get into the office. I managed to build three temple exhibits, then found the sheet that offered hints (LOL).

I love Greek and Roman mythology, so I will probably buy this game. It promises to take a long time to complete simply because you do a lot of walking around - typical for adventure games there is no map, so no jumping around. (Unless I just missed it.)

As usual, please try the game to see if it is one you might like to play. It will take patience, but the story is quite interesting so far.
 posted in Shrouded Tales: Revenge of Shadows Collector's Edition on Jul 20, 15 2:16 PM
And now we are eight. Bummer - it was going so well, too.
 posted in I Know a Tale on Jun 3, 15 3:56 PM
I had the same problem. I thought the three fingers went on the statue, but they go somewhere else. I finally put the two stone flowers on the left statue holding the case and a door opened to a new room. I think the fingers will go on a robot-like hand in the new room.

Good luck. This game is quite the challenge, but I am enjoying it.
 posted in Demon Archive: The Adventure of Derek on May 28, 15 8:22 PM
I think I have everything for the flask in the cabin, but I only have one coal. I've tried to pick up more from the forge, but can't. Where do I get the other two coals?

Glad we have fishies around to answer our questions.

Edit: I put the one coal in the fire and the door closed. I think that part is done. Now I can't get the flask to go in the top. I must be missing something. I put the liquid silver/mercury(?) and sulfur in the flask with the jewelry. Anyone know what I am missing?

Edit #2: For those in the same fix. I finally poured the water in the bucket into the little bowl and put that into the top of the oven. Then the "boiling" water in the bowl went into the flask and the flask went into the top of the oven. When the door opened the flask was removed with the "Iron clip" which I think were really tongs. Then the hammer was used to break the flask.

As my British sister-in-law would say: Blimey. I was gob-smacked for a while there.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator