Posts created by reg1strar

 
 
 posted in Secret City: London Calling Collector's Edition on Apr 29, 18 8:52 AM
Already played the tracking device in chapter 2. Won't let me go forward because I have to play the tracking device again. Does this mean I have to go back under another name or download the game again. So annoying, I was looking forward to playing this game. Playing on windows 10.

 
 
spikescajunmom wrote:Also cannot access oil drum. Brand new hard drive, brand new video card. No problems with playing other games. This is a glitch in the game, not our computers. Please have developer fix ASAP. It is frustrating getting 3/4 of the way through the game and not being able to complete it. I really don't want to have to start all over again and play something I just played. Unfortunately, this is a problem that is only increasing in frequency with new games coming out - glitch within game that prevents forward progress or some other glitch that prevents play. I LOVE playing Big Fish and have been a member for years, but they need to do a better job at testing games before putting them out for us to purchase. Just my opinion.
 
 
Can't get the second half of the ring from the fish tank. Does this mean I have got to start the game again under another name. Too many games going wrong.
 
 
 posted in The Christmas Spirit: Trouble in Oz Collector's Edition on Dec 15, 17 11:26 AM
got the same problem as squirrelGirri. Cant work the chest. Have reinstalled the game, makes no difference. I was prepared to buy the game, but now I am not so sure.
 
 
 posted in Mystery Tales: The House of Others Collector's Edition on Oct 23, 17 3:13 AM
Downloaded the updated version on 21st October now I cannot finish the bonus game as I cannot get the possessed charm.
 
 
 posted in Mystery Tales: The House of Others on Oct 22, 17 9:22 AM
I downloaded the updated version of this game today. I have already finished the game before this download. In bonus version I cannot fine possessed token to finish the game. Too many games are having problems now. Big fish team have to look at what the developers are putting out.
 
 
 posted in Mystery Tales: Dangerous Desires Collector's Edition on Oct 21, 17 9:23 AM
same problem. I don't want to start the game all over again. I thought the update would have sorted this problem. Obviously not. Anyway I started under another name and I got past chapter 3
 
 
 posted in Mystery Tales: Dangerous Desires Collector's Edition on Oct 20, 17 5:46 AM
Downloaded the updated version, but still can't go up the stairs. Do I have to restart as a new profile.
 
 
 posted in Mystery Tales: Dangerous Desires Collector's Edition on Oct 18, 17 5:47 AM
I am having the same problem,. I can't go up the stairs.
 
 
 posted in Mystery Tales: Dangerous Desires Collector's Edition on Oct 18, 17 5:46 AM
like some of the other gamers I can't go up the stairs.
 
 
Can't collect the lily from the laboratory. Won't let me put the ruby dust on the lily.
 
 
EbonyMoon wrote:Got to the place to make the flower plate. put the living flower melted silver poison and ruby dust. poured the sliver into the plate turned the little red handle and now I can not do anything at all tried to add the flower said to try something else tried the poison same thing ruby dust same thing try moving the handle nothing.
This is the third game in two days that has not worked right. Not a happy person.
 
 
 posted in Dark Romance: Curse of Bluebeard Collector's Edition on Oct 21, 16 4:07 AM
the update didn't work for me either.
 
 
 posted in Dark Romance: Curse of Bluebeard Collector's Edition on Oct 20, 16 7:10 AM
txpeach100 wrote:I was able to put the harpoon and rope together and shoot it across the chasm. However, there is no rope over the chasm for me to cross. When I now click on the cross bow, it shows me a close up of the tree on the other side of the chasm and says I need to find a harpoon and rope to cross.

When I click the hint button in either the hut or outside, it highlights the lower left corner of the screen, where nothing is clickable.

Frustrating!!!
 
 
 posted in Otherworld: Shades of Fall on Sep 20, 16 12:02 PM
when otherworld shades of fall ended I was under the impression that there would be a follow up shades of winter. Was I wrong.
 
 
Chapter tweedledum and tweedledee. Error - access violation at 0x0043918B (tried to read from 0x00000010). I have also uninstalled the game and then re-installed it bu to no avail. Most disappointed as I was looking forward to finishing this game.
Managed to finish the game. Instead of using the mouse after playing the HOG I used
the map to move around and everything worked fine.
According to BFGPANTHALASSA there is an update to this game. I can't get any update. Anyone else got this problem.
 
 
Daxadillion wrote:A thread for your reviews.
 
 
 posted in Mystery Tales: Alaskan Wild Collector's Edition on Aug 29, 15 11:09 AM
At the summit cannot play the hop to gain the lighter. Found a rake I have no idea what to do with. Also the hint button just keeps hinting at itself. I am totally stuck. Don't know what else to do. Grudge paying £10.80 for a game I cannot play
 
 
Has any other player found that the demo was only 24 minutes long. How are you meant to decide on a game that short.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator