Posts created by LisaBoegli

 
 
 posted in Nevertales: Hidden Doorway Collector's Edition on Dec 30, 16 11:02 AM
How did you do it then? I'm having the same issue. Found all of the collectibles and it keeps telling me I have to find it before I can finish it
 
 
 posted in Legendary Mahjong on Apr 4, 16 6:25 PM
I, too, and stuck on the first level. Been trying for days and days now, and cannot figure it out. Managed to unlock the final two tiles, but dumped them into the pit.
 
 
 posted in Off the Record: The Italian Affair Collector's Edition on Jul 6, 14 11:55 AM
I did the same thing. I finally gave up and left the game and came back to it later that day, and it worked! Have had to do the same thing more than once with the camera. Stuck right now myself later in the game. Same issue. The camera.
 
 
 posted in Off the Record: The Italian Affair Collector's Edition on Jul 6, 14 11:53 AM
I had trouble with the camera every time I used it. Seemed to help when I got out of the game and went back later?
 
 
Fortunately, I did place the pieces before backing out, because finding the relationships was HARD! But. There are still several pieces missing and I have no idea why, since I managed to connect all of the relations there. How on earth do I find the Music Box hidden object pictures I understand I have to finish?
 
 
Had the same issue. Using the Strategy Guide, I knew I was supposed to go to a specific place next, but it wasn't highlighted as "Active." Went anyway and successfully completed whatever task I was supposed to do.
 
 
 posted in Fishdom 3 on Jan 24, 13 10:34 AM
I am stuck on Level 13. I have cleared the entire board, but there is a box of jewels, in the middle that I cannot figure out how to clear. I have used the lightning again and again, but no luck.
 
 
 posted in Gothic Fiction: Dark Saga Collector's Edition on Oct 3, 12 4:53 PM
I, too, am stuck at that point. How do I get light to chase the fog away?
 
 
 posted in Midnight Mysteries 3: Devil on the Mississippi on Jul 1, 11 4:45 PM
It took me forever to get the broom to clean up the mess. It's all in the positioning. I had the same problem getting the keys to unlock the doors on the ship. Just keep positioning it in different places, and eventually, it will take over and begin to sweep up the mess.
 
 
 posted in Nancy Drew: Warnings at Waverly Academy on Jan 8, 11 1:42 PM
I finally managed the lower and middle parts of the tree by drawing a diagram bit by bit as the squirrel climbed, and saved as I went. Apparently, I saved too early because when I reload, it comes to the neener, neener part about falling down, asks if I want to try again and when I click on yes, goes to the neener, neener message again....it won't take me back to the tree! Help please! I've come so far!
 
 
 posted in Lost Lagoon: The Trail of Destiny on Jun 9, 10 11:02 AM
I have just entered the cave at the beginning of Chapter Five, yet somehow I missed picking up the torch. I am stuck in the cave being told it's too dark. Yet there does not seem to be anyway to back up or get out of there to try to find the stupid torch. I am stuck. Can anyone please help me?
 
 
 posted in Strange Cases: The Tarot Card Mystery on Aug 11, 09 4:03 PM
I can zero in on the lighthouse and count the three stripes, but I cannot seem to find the "house." I tried setting the "v" dial for three to match the three stripes and the "h" for 10 as it requires, but all I see is a blurry mountain-like picture. Any suggestions?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator