Posts created by keisenhour

 
 
 posted in 4 Aztec Skulls on May 3, 17 8:17 AM
Very disappointed in this game. It's not any different than any other time management game. Not at all like the other Adelantado games. Always like to get new games for series but will not be buying this one.
 
 
 posted in Lost Lands: Dark Overlord Collector's Edition on May 1, 17 2:43 PM
I have the glove and need to get the trowel. I can't move the leaves. Is there a special place to put the glove to move the leaves?
 
 
I recently bought the Mac version of this game; however, I should have bought the PC version (I don't have a Mac). How do I exchange the game?
 
 
 posted in Weather Lord: Hidden Realm on Aug 16, 15 11:05 PM
Why is the tower between the wind tower and the lighting tower marked out?
 
 
 posted in Otherworld: Spring of Shadows on May 1, 15 9:58 AM
cannit attach bell to rope. Is there a specific place to put it?
 
 
 posted in Royal Envoy 3 Collector's Edition on Jun 14, 14 6:34 AM
I've started my game twice now on relaxed mode and it still starts me in "Bonus Levels'. I don't want to play bonus levels, just regular levels. How do I stop this?
 
 
 posted in My Kingdom for the Princess IV on Feb 8, 14 12:06 PM
Thank you so much for your help! I made it with a gold star!
 
 
 posted in My Kingdom for the Princess IV on Feb 8, 14 10:04 AM
Could someone give me some advice for this level? I've tried different combinations of bonuses and cannot get thru it. Any help would be appreciated.
 
 
 posted in Ballad of Solar on Apr 6, 13 9:34 AM
Is there any way to replay certain levels to get all gold stars?
 
 
 posted in Timeless: The Lost Castle on Feb 17, 13 6:51 PM
Where do I find the recipes for the potions? Also, where is the mandrake root and the mistletoe? I read that these are needed.
 
 
 posted in The Dark Hills of Cherai: The Regal Scepter on Dec 1, 12 3:13 PM
I have only two symbols showing in the telescope. Checked the walkthrough and should have three. Tried using the three in the walkthrough and nothing happened. Anyone else have this problem?
 
 
 posted in Adelantado Trilogy: Book One on Sep 28, 12 3:44 PM
How do you increase efficiency?
 
 
 posted in Echoes of the Past: Royal House of Stone on Dec 11, 10 4:30 PM
I have both rings necessary for this door. I have done the puzzle on the stairs twice. I cannot zoom in on the doors. When I try, it says 'The bolts must be aligned correctly' (or words to that effect). What do I need to do to get through this door?
 
 
 posted in Royal Envoy on Jul 10, 10 1:04 PM
Is it possible to upgrade from the regular game to the collector's edition?


 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator