Posts created by LanaPook

 
 
 posted in The Tribloos 3 on Apr 12, 18 2:36 PM
Hi I also can not get the game to play. There is an icon at the bottom of the screen but the game will not boot. I tried uninstalling and reinstalling and nothing. This is sooooooo disappointing. I loved the previous 2 games and have played them multiple times. I have lots of BigFish Games and do not have this problem with them. I hope you will address this issue as I bought it without trying the demo first. Please fix it! Thanks!!!!
 
 
 posted in Artifact Hunter: The Lost Prophecy on Mar 29, 18 3:36 PM
After writing for help I went back to the game and passed the level easily. Somehow I got a lightening powerup and cleared the whole bottom level in a flash. Don't ask me how. I then had plenty of time to clean up all the rest of the screen.
 
 
 posted in Artifact Hunter: The Lost Prophecy on Mar 28, 18 1:27 PM
I have tried to clear this one at least 10 times. It seems almost impossible. I remember this from a game a long time ago. It is the same I think. Does anyone have a hint to make this a little easier?
 
 
 posted in Fish Tycoon 2: Virtual Aquarium on Mar 27, 18 8:40 AM
Should I leave pregnant fish in breeding tank or return them to the common tank? I had several pregnant females but don't think they had babies in common tank? It is so slow doing one at a time in breeding tank.
 
 
 posted in My Pretty Kitty on Mar 7, 18 7:35 PM
So I went back and tried level 94 again. I switched to relaxed mode. I played on after I dropped the 2 cans and one mouse for about 5 more minutes. No second mouse appeared so no more progression through the levels. Stuck with no way out.
 
 
 posted in My Pretty Kitty on Mar 7, 18 7:19 PM
Thanks SynthpopAddict, I think you might be right.
 
 
 posted in My Pretty Kitty on Mar 6, 18 2:42 PM
I am stuck on level 94. It says that you have to drop down 2 mice and 2 cans off the bottom. I drop the 2 cans and one mouse and the other mouse never shows up. What to do?
 
 
 posted in My Pretty Kitty on Mar 6, 18 2:40 PM
Use the power ups and try to avoid finishing the level too soon.
 
 
 posted in My Pretty Kitty on Mar 5, 18 8:11 PM
I am stuck on level 94. I am supposed to drop 2 cans and 2 mice to the bottom. There are only 2 cans and one mouse. I can't finish the level if the other mouse doesn't show up! What to do?
 
 
 posted in Secret Investigations: Nemesis on Jan 16, 18 5:36 PM
In the last Bus section I started having a problem getting the action item out of the box in the lower right corner. It seems to be stuck and takes many tries to move it from the box wasting time.
 
 
Is there a hint for the switches? What do I do with the bowl? Machete?
 
 
Thanks I found it!
 
 
I have to draw someone. Help! so many options. Who is it and what does she look like?
 
 
Works Thanks!
 
 
I don't play these games often. Where is the code for the panel with red buttons? Ready to give up already.
 
 
 posted in Elly's Cake Cafe on Dec 1, 17 7:33 PM
Thanks skpjazz,

I am at about level 50. Hope to see some more power-ups. I agree this game is not that easy.
 
 
 posted in Elly's Cake Cafe on Nov 29, 17 9:40 AM
I used up my power ups thinking I would earn or buy more. At level 40 I am not seeing any more. Thanks
 
 
 posted in Defense of Roman Britain on Oct 11, 17 11:39 AM
I have a similar problem. I played the demo then bought the game. Either game does not down load or is inaccessible to Big Fish app on my computer. ??? In any case I can not play the game I just bought. Also uninstalled, restarted my computer, downloaded again. No luck!
 
 
 posted in Sophia's Pizza Restaurant on Oct 4, 17 4:09 AM
I downloaded but the game would not run. Perhaps another game that doesn't like windows 10.
 
 
 posted in Clutter Infinity: Joe's Ultimate Quest on Sep 18, 17 4:51 AM
I downloaded but program will not run. Problem with windows 10 I think. Please fix!!!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator