Posts created by owlgirl61

 
 
 posted in Midnight Castle on Apr 12, 16 4:57 AM
I have completed the latest task, but the fairy won't give up her gifts.
I have reinstalled the game but to no avail.

Help please?
 
 
 posted in Midnight Castle on Mar 1, 16 2:56 AM
Thanks all. Found him.
 
 
 posted in Midnight Castle on Feb 29, 16 4:07 AM
Haven't played for a few days and I can't remember how to get to Took. Thanks.
 
 
 posted in Midnight Castle on Dec 2, 15 2:55 AM
I briefly had the winter event yesterday - earning bells, wreaths, santa hats and snowflakes. Turned on the game this morning and back to normal. Boooo!!
 
 
 posted in Midnight Castle on Oct 5, 15 2:23 PM
What's happened to the bonus time on the hidden objects. There's nothing to say a certain time has to be achieved to get bonus points.
 
 
 posted in Midnight Castle on Oct 5, 15 2:20 PM
I got a pumpkin from the wheel of fortune. Didn't notice if the cornucopia was on there, though.
 
 
 posted in Haunted Train: Spirits of Charon on Feb 17, 15 2:56 AM
Thank you for that. I'll keep waiting!
 
 
 posted in Haunted Train: Spirits of Charon on Feb 16, 15 2:30 PM
I beta tested the above game (can't remember when) and have been looking forward to it coming out. I've tried the Spirits of Charon and it has a completely different beginning (not as good) to the test game, but the action inside the train is similar, although Olivia doesn't seem to be dead.

Are they the same? Thanks.
 
 
 posted in Nevertales: The Beauty Within on Feb 1, 15 9:53 AM
I've scared off the bandits and pushed over the rock. When I zoom in to where the rock was I'm supposed to be able to pick up coins and and a pedestal key - but they're not there. When I click on it just tells me the things I'm trying to get are too far away. what am I doing wrong, please?
 
 
 posted in Fantasy Mosaics 4: Art of Color on Sep 15, 14 3:34 AM
Every time I exit this game my internet security program pops up asking if I want to remove a threat, and gives this game as the source.

You always claim your games are virus free.
 
 
I've missed an amulet token, I think it's an eagle.

I've gone to the room where the guide says it's found, but there's nothing to click on.

Will I have to start the game again?

Thank you.
 
 
 posted in The Invisible Man on Feb 28, 14 2:40 PM
I agree. What was the point of the visibility potion? I thought perhaps the game continued in a CE - but there isn't one! Very strange ending.
 
 
 posted in Spirits of Mystery: The Silver Arrow on Jan 15, 14 10:53 AM
I keep getting installation failed. At first I got an error message, now Game Manager is saying my trial is over. Today is the first time I've ever tried to download this game. I'm running Windows XP with 130GB memory available, so what is going wrong, please?
 
 
 posted in Spooky Bonus on Nov 30, 13 4:32 PM
I just need to say that I think this game has some of the best music I have ever heard in any game. It makes the game so much more entertaining when you enjoy listening as well as playing.

Thank you!
 
 
 posted in Haunted Legends: The Curse of Vox Collector's Edition on Jul 20, 13 2:30 AM
I've got this problem too - I can't find the ring that gives the M symbol. Been through strategy guide, but can't find where I've gone wrong!
 
 
 posted in Our Worst Fears: Stained Skin on May 29, 12 11:35 PM
All but two scenes are complete and I cannot find the tile for the extreme left wooden door in the pool room - I don't know where to look. Thank you.
 
 
 posted in Victorian Mysteries®: The Yellow Room on Apr 17, 12 1:27 AM
I was really enjoying this when the demo finished 37 minutes in. HIdden object scenes are beautiful, with some items cleverly placed. Didn't need a hint (playing on hard mode - which isn't really hard) and found the games relatively easy. Maybe a purchase.
 
 
 posted in Mystery Trackers: Black Isle Collector's Edition on Apr 11, 12 4:19 AM
In Raincliff, the Bonus Game was necessary to complete the story. Is it the case in this adventure, please? Many thanks.
 
 
 posted in Echoes of the Past: The Citadels of Time on Mar 4, 12 10:16 AM
Anyone else notice that the right hand tomb is inscribed Elizabeth II!
 
 
 posted in Mystic Gateways: The Celestial Quest on Feb 28, 12 11:51 PM
I found this game tedious. the trial was the longest hour of gaming I've ever played. Definitely no buy for me
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator