Posts created by TeachumWell

 
 
 posted in Halloween Stories: Invitation Collector's Edition on Oct 16, 17 1:20 PM
I'm playing the demo and need the 2nd skull to get to the Hostage Room. I found 1st skull but big one in room's center doesn't move when I click on it. Have I missed something? Also, should I already have the "tape" for the wires by the Hostage Room entrance? Thanks for any help you can give. I can't go further without these items. Help!!
 
 
 posted in Grim Tales: The White Lady Collector's Edition on Sep 2, 17 7:07 PM
Help! I've almost finished the HO scene on the Museum desk. I can't find the last item which looks like (to my vision) a bottle with a siphon. I've having lots of trouble using "Dad's" hints as they're hard to see. Can anyone recognize the object I'm after and tell me where it is? (No help in the Guide....I tried!) Thanks.
 
 
 posted in Haunted Legends: The Black Hawk Collector's Edition on Mar 9, 17 5:29 PM
Hi! Am I missing a trick with the candles? I've tried the "left to right" suggestion and it works for each row, but the opposite row re-lights each time. Help! The photo in the Guide doesn't show the order either. I can't go forward in the game 'til this is solved. I thought this game was a keeper runtil the candle puzzle. Has anyone out there solved it? Thanks so much for any solution you can give me.
 
 
 posted in Sunken Secrets on Feb 6, 17 9:27 PM
Hi! I'm playing one game on PC and have started a mobile (Android) game on my phone. I'm enjoying both but have come to a standstill in mobile game because I can't get the sculptor's studio as the game tells me I don't have Ollie the Observer. I don't at all remember how I go him on the PC version, so could someone please tell me how to entice Ollie to balloon over to my Android game so I can get the sculptor studio without which I can't make the bricks for the still unfinished castle areas? I've so enjoyed learning about this cool multi-layered game through the forum and would appreciate any advice/help given. Thank you.
 
 
 posted in Lost Island: Mahjong Adventure on Jan 16, 17 6:49 PM
Being a mahjong fan and a quest-type game player, I was set to enjoy this game. It has proved me right in trying/buying it. The graphics are small but clear, the timing is not daunting, and the open style lets me figure out what to do next. But...a downer for ,me is the tile set. I love that the tiles are huge but we should've been give a choice of tile themes.
An old player with poor vision, the traditional tiles are often hard to see. The size is great, the design not so much. But overall, this is a fun and challenging romp thru a deserted island and give lots of pleasure for fans of several genres.
 
 
 posted in Grim Tales: Crimson Hollow Collector's Edition on Aug 29, 16 2:08 PM
Hi All!
I'm having a ;problem "getting into" the Internet in the office near the beginning of the game. I thought I was following directions (in the Guide) but after entering the password, absolutely nothing happened. No mini game, no search, nothing. Did I miss something? Seems like an interesting and challenging game but if I can't advance from the office computen, well.....Please give me the solution! Thanks!
 
 
I tried many times before I noticed base of each flame has the same shape as on the statue. I don't remember the order ('cause it didn't seem to matter) but just match the shapes and the idols will just "clunk" into place. Hope that helps.
 
 
 posted in Puzzle Quest 2 on Apr 29, 16 12:26 AM
Hi! Wild Gems multiply the number of gems of any color. Just include them in a 2 gem match or as the 4th gem in a 3 match and they multiply the number of gems you get credit for. Hope that helps. Enjoy the game. Bye.
 
 
Thanks so much to all of you who kept me from deleting the game in frustration! The guide was far, far from helpful, only saying to "get the red jewel" so some such. I'm heading back to the demo to find the Magic Ball and, hopefully, to continue a really fun game. Thanks again to each and all of you. Teachumwell :-)
 
 
HI! Please help me deal with the nasty mermaid who keeps splashing me! I tried the hint bar and even the guide, but no help there. I'm visually limited so may have missed a hint or object someplace to stop the soaking but would much appreciate help from my fellow fishies. I am (well, was) enjoying the game but my frustration level is rising and I don't want to go on til I know what to do. Thanks again.
 
 
Just a side note: In some versions of the song "Casey Jones" the term "rounder" is used for a railroad engineer. I've asked trainfan friends and they say that the term was used because of the huge round wheels on steam engines in the 1800's. But I tend to go with the "boundary" idea as being a border watched by a "bounder". Keeps one guessing doesn't it?
 
 
 posted in Whispered Secrets: Golden Silence Collector's Edition on Aug 23, 15 7:50 PM
A very intelligent panda, too! Knows just when to help without being clicked, tapped or otherwise cued in. I foresee a promising game career ahead for him! :-)
 
 
 posted in Hotel Mahjong on Aug 11, 15 10:17 AM
Glad to know someone else couldn't find the "relaxed" mode. I thought maybe I was having a "senior moment" and imagining one was mentioned. If you or another fishie finds this "relaxing" play, please post. I'd like to like the game but with only a timer....Thanks so much!
 
 
Earlier, I said the cursor (both game and Windows type) didn''t work at all, but I've managed to get through at least 20 min. more of the game (and it's excellent) by remembering to click a bit away from the intended target. This may allow you to pick up objects, give things to characters, etc. I'm still holding off on buying 'til I see a fix or can at least finish the demo but I thought this bit of info might be helpful. And thank you, fellow fishies all for your wise tips and encouragement!
 
 
Thanks, fellow fishies for letting me know it isn't only me. I was thinking I was doing (or not) something to cause these problems. The game loads, took my name, but problems began when I couldn't move the sliders to customize. Finally chose easiest mode but no help there. Can't pick up most objects, cursor blinks in and out of Windows cursor form to game cursor, can seldom click to explore item. Wow! Frustration rising quickly here! I've got Windows 7 and all's been fine with other games so seems this one got cleared without checking these major issues. I really could like this game and planned to buy it but now...well....Will BF notify us via the game page if fixes are available? Such a waste of good graphics, story, etc. Should I remove it and reinstall? Nah, other fishies have done so and no luck. Thanks for any help you can give.
 
 
 posted in Farm Up on Apr 26, 15 9:56 AM
I miss Cupid, too. Even if Valentine's Day lasted all spring, he was kinda cute and the gifts (most minor) he gave were ok. As for the keys, somewhere it was said they'd be for "treasure chests" in a later update. So far, lotsa keys, no treasure. And I do know the devs want to make money on the game, but gold seems to do less and vanish faster than before this latest update. And leveling up is soooo slow! By the time I get to the next level, I'll be too old to remember what I'm playing! Does anybody know a shortcut to leveling up? Be blessed, fellow fishies. Bye.
 
 
 posted in Farm Up on Apr 26, 15 9:46 AM
Hi! So much seems to depend on what version you're playing. In the PC updated version (and on Facebook, far as I can tell) Grandma comes after you've built a couple of levels of the "guest house". As someone said, Grandpa comes after you've got the sawmill (or was it the brick factory?) built. Hope this helps. The game IS fun (of a sort) and gets livelier as you progress. Enjoy.
 
 
 posted in Castle Secrets: Between Day and Night on Dec 30, 14 12:18 PM
At first glance the game made little sense but following the beginning directions, thinking "outside the box" and being patient will reward you with a fun, mysterious and imaginative game. The story and game are intertwined and solving minor (and not so minor) quests does move the plot along. As noted elsewhere, the HO's start simply but don't stay that way. Killing villains is useful for rewards, cash and your reputation as a hero. The graphics are quaint but clear and somehow the "old-fashioned" feel of the game fits it's medieval theme very well. Come to it with an open mind which overlooks the flaws (very minor, i.e. some fuzzy objects) and you may find yourself hooked. Gotta go back now as there's still a few vampires to get rid of!
 
 
Thank you sooo much for the "cold head" clue. This is the least helpful Guide I've ever used! Lotsa nice pics but no help on really difficult spots. I, too, tried the hint soldier on this scene, but his sword pointed to a spot diagonally near him which yielded nothing. So again, thank you fellow fishies. But for these frustrations this'd be a truly great game.
 
 
 posted in Mystery Castle: The Mirror's Secret on Oct 10, 14 11:55 PM
To make it work, I fed the envelope to the mailbox after putting on the first stamp, the box crumpled up the envelope. I took it back to the table, changed to the other stamp and fed the mailbox again. Same result. Used first stamp again after smoothing out the crushed envelope. (Gotta use the glue with each stamp.) Did this total of 3 times and the mailbox opened his hand so I could take the battery. Hope this helps.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator